Nvidia Driver 495 (+) not loading or core dumping in Linux Mint 20.3

Ok, it is hard to give a great description because after messing about it seems the problem has changed. For the last several months I’ve been using Linux Mint 20.02 with the Nvidia 495 driver and a Palit GeForce GTX 1650 card. (Note I’ve used the 470 (recommended) driver too). During that time if my machine ever needed to be rebooted, sometimes the nvidia driver would be fine and work great, but sometimes it apparently fellback to the nouveau and my computer suffered. When this happened I’d just reboot a few times until the nvidia driver came back, and I didn’t reboot my machine often, I would just leave it on.

Ok, today I decided to try to pin this problem down. I thought maybe it is a software issue so I decided to upgrade my Mint installation to 20.3, whcih I did no problem. But then the problem became consistent, I could never reboot into a working nvidia driver at all. I reinstalled the nvidia driver using the Driver Manager utility, and tried 495, 470, 460 all with the same result. During this time if I used “nvidia-smi” it would say there was no nvidia driver available.

I then started paying attention to this forum and decided to try the “.run” way of installing the driver. I also switched to an old Geforce 710 card to test whether it would be happy (i.e. is my 1650 card just bad?) But the 710 had the same problem.

Now after switching back to 1650 and redoing the driver install, I now have managed to create a situation where, rather than falling back to nouveau and having bad performance, “startx” crashes. So now I’ve switched over to my crappy onboard Intel graphics card so I can use my computer outside of runlevel 3. At that point, when startx crashes, I can get something from nvidia-smi.

One thing I did was put into /etc/modules the lines
nvidia
nvidia-drm
nvidia-modeset
and then rebuilt the initramfs as this was something recommended I think if the concern was that the nvidia module was not loaded before the login splash screen came up but it didn’t help. I am now using runlevel 3 and manually startx’ing if I want to try the nvidia driver. But at the moment I’ve gone back to using the intel onboard video using “prime-select intel”.

Fairly frustrated but I hope I have all the logs that could help. Uploading the nvidia-install.log, the nvidia-bug-report.sh, and the Xorg.0.log with startx run with the verbose 6 option.

I hope someone can give me an idea of what I need to do.

Thanks
Don
nvidia-bug-report.log.gz (159.1 KB)
Xorg.0.log (502.0 KB)
nvidia-installer.log (4.2 KB)

First of all, the GT710 you used to troubleshoot is kepler-based so only supported up to driver 470. Using that with a 495 driver was expected to fail.
The logs look quite messy but there’s also a successful boot with the 1650 and the 495 driver and it looks like this was when you removed your xorg.conf.
Please try repeating that.

1 Like

If your using Mate it’s known to be broken.

1 Like

Wow… leigh123linux wins! :) Thanks both for your replies! All I did was switch from Mate to Cinnamon and it came up working the first try. Thanks what a life saver!!!

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.