Nvidia 390 proprietary drivers/Fresh install of Ubuntu 18.04.1 LTS/Ryzen 1800X/Asus X370-Pro/EVGA 1070Ti stuck at console after installing drivers and rebooting

I attempted to install the nvidia 390 drivers straight after a fresh install of Ubuntu Server Bionic Beaver but got stuck at reboot.My exact steps:

Ubuntu installation:

Turn off secure boot in BIOS.
Boot from USB ISO, install (delete all existing partitions) & reboot
sudo apt update
sudo apt upgrade
sudo apt install ubuntu-desktop --no-install-recommends
shutdown -r now

Nvidia driver intallation:

Once on desktop,
Open Ubuntu Software&Update GUI
Tick allow proprietary drivers
Install of nvidia-driver-390
reboot

Issue and bug report:

At reboot, I am stuck at the console just before X is supposed to start.
Had to CTRL-SHIFT-F2 to login and run nvidia-bug-report.sh

nvidia-bug-report.log.gz is attached.

Thanks,

Ryan

nvidia-bug-report.log.gz (112 KB)

For some reasons your system still boots with the nouveau kernel driver. That will not work.

Check if nouveau is properly blacklisted and rebuild your initial ramdisk.

https://linuxconfig.org/how-to-disable-nouveau-nvidia-driver-on-ubuntu-18-04-bionic-beaver-linux

Thanks for the advice,

  1. I created /etc/modprobe.d/blacklist-nvidia-nouveau.conf with

blacklist nouveau
options nouveau modeset=0

AND (on second attempt)

blacklist nouveau
blacklist vga167fb
blacklist rivafb
blacklist nvidiafb
blacklist rivatv
alias nouveau off
alias lbm-nouveau off

  1. installed nvidia-driver-390
  2. sudo update-initramfs -u
  3. shutdown -r now
  4. sudo update-initramfs -u

WITH NO CHANGE (bug-report regenerated and attached)

On lshw -c video | grep ‘configuration’, I see nvidia in use
lsmod | grep nouveau or *fb or *tv is empty
lsmod | grep nvidia listed several modules though (one drm, one helper,…)

ANY FURTHER ADVICE?

nvidia-bug-report.log.gz (107 KB)

See also the lsmod output attached.
lsmod.txt (4.24 KB)

The driver is correctly installed and loaded. nvidia-smi even shows that an xserver and gnome-shell are running on the gpu so it’s odd that you don’t see anything. Unfortunately, no xorg logs and config are included in the nvidia logs.
Please run
sudo journalctl -b0 --no-pager _COMM=gdm-x-session >xorg.log
and attach thet

Here you go.

Ryan
xorg.log (46 KB)

This is odd, everything is up and running but there’s simply no monitor detected. There’s also no other gpu detected so I don’t think you misconnected your monitor, please make sure anyway that you’ve used a connector on the nvidia card.
Looks rather like some strange driver bug, please add the ubuntu graphics ppa and install the latest driver using
sudo apt install nvidia-driver-410

OK, I did a clean re-install, update, upgrade of Ubuntu Server as described in op and then did:

  1. sudo add-apt-repository ppa:graphics-drivers/ppa
  2. sudo apt update
  3. sudo apt install nvidia-driver-410
  4. vi appended “blacklist nouveau\nblacklist nvidiafb\noptions nouveau modeset=0”
  5. sudo shutdown -r now
  6. sudo update-initramfs -u (forgot to run earlier)
  7. sudo shutdown -r now

There is no visible change, I get the usual boot scroll which stops stops dead in its tracks before the Ubuntu login screen. I had to ctrl-alt-f2 to run sudo nvidia-bug-report.sh and sudo journalctl … (both attached)

:(

EDIT:

A.looking at the nvidia-bug-report, maybe “nvidia-persistenced” is the culprit?
B.looking at the xorg.log, maybe this is the issue:

“/usr/lib/gdm3/gdm-x-session[1766]: dbus-daemon[1825]: [session uid=114 pid=1825] Activated service ‘org.freedesktop.systemd1’ failed: Process org.freedesktop.systemd1 exited with status 1”

C.on the positive side NVRM is no longer complaining about a module conflict :)

xorg.log (46.6 KB)
nvidia-bug-report.log.gz (1 MB)

Something is completely wrong with your display connection.

From your nvidia-smi --query log:

Display Active                  : Disabled

From xorg.log:

NVIDIA(0): Validated MetaModes:
NVIDIA(0):     "NULL"
NVIDIA(0): Virtual screen size determined to be 640 x 480
NVIDIA(0): Unable to get display device for DPI computation.
...
NVIDIA(0): Setting mode "NULL"

Please either replace your monitor cable or connect to another GPU output. Also check with your manufacture website if there’s a new BIOS available for your GPU and flash it.

Also, by any chance, do you have any files under /etc/X11/xorg.conf.d ?

I second this, looks more like a defective cable/adapter.

OK, I did a sanity check on the hardware by installing Windows 10 Home from USB ISO.

  1. Nvidia drivers were automatically installed (v388.13)
  2. Installed steam and 3dmark demo. TimeSpy gave a reasonable score.

There was no problem whatsoever in Windows, I hope this proves no hardware issue with the GPU itself, the LCD and HDMI cable.

The way I see it, this is now either a Ubuntu problem or an Nvidia Linux driver problem…

Thanks,

Ryan

Ok, try this:
use
nvidia-drm.modeset=1
as kernel parameter, then use this as /etc/X11/xorg.conf:

Section "Device"
    Identifier     "nvidia"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BusID          "PCI:9:0:0"
    Option         "ModeDebug" "true"
    Option         "AllowEmptyInitialConfiguration"
EndSection

and attach new logs.

OK, I did a clean re-install of Ubuntu Server and then:

  1. sudo apt update
  2. sudo apt upgrade
  3. sudo apt install ubuntu-desktop --no-install-recommends
  4. shutdown -r now
  5. sudo add-apt-repository ppa:graphics-drivers/ppa
  6. sudo apt update
  7. sudo apt install nvidia-driver-410
  8. echo -e “blacklist nouveau\nblacklist nvidiafb\noptions nouveau modeset=0\noptions nvidia-drm modeset=1” to /etc/modprobe.d/blacklist-custom.conf
  9. wrote Section as described to /etc/X11/xorg.conf (file did not exists previously)
  10. sudo update-initramfs -u
  11. sudo shutdown -r now
  12. sudo nvidia-bug-report.sh
  13. sudo journalctl …

Reports attached.

Thanks,

Ryan
xorg.log (39.4 KB)
nvidia-bug-report.log.gz (1 MB)

No idea. All that’s left is to try the mentioned kernel parameter.

I edited /etc/default/grub,
GRUB_CMDLINE_LINUX_DEFAULT="" -> GRUB_CMDLINE_LINUX_DEFAULT=“nvidia-drm.modeset=1”

Ran sudo update-grub, but cat /proc/cmdline doesn’t show the modeset… only a one-liner with ‘BOOT_IMAGE=/boot/vmlinuz’…

Any help?

Ryan

Alternatively, create a file
/etc/modprobe.d/99-nvidia-modeset.conf

options nvidia-drm modeset=1

and run
sudo update-initramfs -u
afterwards and reboot.

Yes, that was already done in blacklist-custom.conf.

Ryan

What’s the output of

sudo cat /sys/module/nvidia_drm/parameters/modeset

Y or N?

Final update.

I tried Linux Mint to narrow down the issue to either the nvidia drivers or Ubuntu.
With the exception of some overscan, the nvidia-driver-390.77 worked fine in Mint.

I will chase this up with Ubuntu. This is not an nvidia driver issue.

Thanks all for your help.

Ryan