Linux Mint 19.2 fail to install Driver for GEforce RTX 2060 - new install

Greetings,

I would like to apologies in advance I am a new Linux user and I am not very familiar with how a lot of things suppose to work.

I have recently installed Linux Mint 19.2 (64 bit) as my operating system.
I tried to go in and stall a new driver for my video card GEforce RTX 2060
Using official Nvidia driver link,
I saved file “NVIDEA-LInux-x86_64-435.21.run”
Run the file
The file run and failed with the following error message, “There was an issue opening the file…filename. The file you opened has some invalid characters If you continue editing the file it may become corrupt. You can choose another character encoding and try again”

I saw this message, but I am not sure where to get this. I would be happy to provide logs
“3) In case of NVIDIA Linux graphics driver installation problems (when using one of the official .run installers), please attach the NVIDIA installer log file, /var/log/nvidia-installer.log.”

nvidia-bug-report.log.gz (68.1 KB)

Don’t use the .run installer, just run
sudo apt install nvidia-driver-430
or use the “Software&Drivers” application.

Generix,

Thank you for your response. Please help me understand a little farther…

When I open my driver manager its saying its already using:

nvidia-driver-430(recommended)
version 430.26-0ubunto0.18.04.2

however, i keeped getting a message pop up on my linux saying that I do not have a correct video card driver and my system is running slower than usual.

here is what I got running: ubuntu-drivers devices

== /sys/devices/pci0000:00/0000:00:01.0/0000:01:00.0 ==
modalias : pci:v000010DEd00001F08sv000019DAsd00004520bc03sc00i00
“vendor : NVIDIA Corporation
driver : nvidia-driver-430 - distro non-free recommended
driver : xserver-xorg-video-nouveau - distro free builtin”

its not showing my graphics card.

I am probably missing something please point me in the right direction.

Thank you very much!

Please run nvidia-bug-report.sh as root and attach the resulting .gz file to your post. Hovering the mouse over an existing post of yours will reveal a paperclip icon.
https://devtalk.nvidia.com/default/topic/1043347/announcements/attaching-files-to-forum-topics-posts/

I would be happy to do that. how do I run
? nvidia-bug-report.sh as root

Can you please attach article with steps.

Thank you very much

Open terminal, run
sudo nvidia-bug-report.sh

Thank you I was able to do that. I apologies for what seems to be a simple question. I am still learning how to get around in Linux.

Please see file attached.

You have secure boot enabled so the nvidia driver doesn’t load since it isn’t signed. Please disable secure boot in bios.

Thank you very much for your answer and patience. I have disabled it and system is now able to recognize my video card. Appreciate it!