Basler Dart MIPI CSI memory error


I’m currently testing this Basler BCON MIPI camera on Jetson Nano. Basler provides an image for Jetson Nano which includes Jetpack 4.3, the camera driver and Pylon SDK. While I have little to no issue with using the camera while running Jetson at my desk using Pypylon (a python wrapper for Pylon SDK), I kept getting a persistent memory error that prevents the camera from open when moving the camera to a remote environment for testing.

I have emailed Basler about the issue hoping if there is anything to fix at software level, but haven’t gotten a solution. I also created a github issue with Pypylon here

But today I noticed the camera only has error when there is no USB device attached when I tried to run headless with just power and ethernet. As soon as I plug a USB device (mouse, keyboard, wireless adapter, whatever), the camera did not have any error and run just as normal. In the same session, I unplugged all the USB devices from the Jetson then the error returns. I repeat the same test for several times with shut down then reboot at each test, every single time the camera worked fine with just any USB device still attached to Jetson, and went to error state again without a USB device.

Now this leads me to think something wrong at the hardware level. Does this have anything to do with the Jetpack version 4.3? I want to change to newer Jetpack, but apparently I couldn’t find an easy way to get their driver independently for this camera.

Please advise! Thanks alot!

I got this Jetson Nano 4GB Dev Kit (recent version with 2 CSI lanes, believe it is B01?) brand new in the bag/box a couple months ago and only used it occasionally for vision development with the Basler camera.

Try run below command before do the camera things.

sudo nvpmodel -m 0
sudo jetson_clocks

Hi @ShaneCCC - Can you explain how should running those commands help?

I don’t have the Jetson with me now. But I will try tomorrow and report result.

Those command just boost the system performance.

Changing to MAXN performance unfortunately did not help.

Have a check others resolution if this sensors have.