Bigscreen Beyond HMD unable to be initialized on Nvidia possibly due to DSC BPP issue

The Bigscreen Beyond HMD is not able to be utilized on either the Nvidia proprietary or open kernel drivers.

These two patches are for the open source AMDGPU driver and solve the issue there, may be relevant as the reason the Nvidia driver cannot currently use this HMD.

1 Like

Hi,
what errors do you get? What does steamVR vrcompositor.txt say?

Hi, I have a Bigscreen Beyond and a Linux PC with a 3070 ti. Where can I find this “vrcompositor.txt” ?

Maybe it’s even more helpful to create a full steam vr report. It will include the content of vrcompositor.txt and other information.

The file location alone should be ~/.local/share/Steam/logs/vrcompositor.txt or ~/.steam/steam/logs/vrcompositor.txt

I’m interested in the Bigscreen Beyond HMD and would love to see it running on Linux with nVidia.

I’ve got a Bigscreen Beyond running on a RTX 4090 on Arch Linux (xorg). Can provide info/test
For vrcompositor.txt it fails when trying to access the direct display in SteamVR:

Fri Jun 07 2024 21:23:57.519953 [Info] - HMD deviceUUID is 9b6073163e2788e0
Fri Jun 07 2024 21:23:57.519977 [Info] - Looking for direct display through RandR
Fri Jun 07 2024 21:23:57.519992 [Info] -  - Root 0x571
Fri Jun 07 2024 21:23:59.283165 [Info] -    - Output 0x42 - 0 modes, 0 preferred
Fri Jun 07 2024 21:23:59.283214 [Info] -    - Output 0x43 - 12 modes, 1 preferred
Fri Jun 07 2024 21:23:59.283233 [Info] -      - Mode 0 0x4a 1920x1080 (looking for 3840x1920)
Fri Jun 07 2024 21:23:59.283269 [Info] -    - Output 0x44 - 0 modes, 0 preferred
Fri Jun 07 2024 21:23:59.283302 [Info] -    - Output 0x45 - 0 modes, 0 preferred
Fri Jun 07 2024 21:23:59.283376 [Info] -    - Output 0x46 - 21 modes, 1 preferred
Fri Jun 07 2024 21:23:59.283392 [Info] -      - Mode 0 0x4a 1920x1080 (looking for 3840x1920)
Fri Jun 07 2024 21:23:59.283419 [Info] -    - Output 0x47 - 0 modes, 0 preferred
Fri Jun 07 2024 21:23:59.283538 [Info] -    - Output 0x48 - 0 modes, 0 preferred
Fri Jun 07 2024 21:23:59.283561 [Info] - Tried to find direct display through RandR: (nil)
Fri Jun 07 2024 21:23:59.283580 [Info] - Looking for direct display through Vulkan WSI
Fri Jun 07 2024 21:23:59.385094 [Info] -  - Vulkan output 0: 1920x1080 resolution, 620x340 dimensions - AOC 28E850 (HDMI-0)
Fri Jun 07 2024 21:23:59.385119 [Info] -  - Vulkan output 1: 3840x1920 resolution, 0x0 dimensions - Bigscreen, Inc. Beyond (DP-0)
Fri Jun 07 2024 21:23:59.385132 [Info] - Tried to find direct display through Vulkan WSI: 0x5c6fa1c3ce60
Fri Jun 07 2024 21:23:59.386293 [Info] - Trying to match desired rate of 90.000000Hz.
Fri Jun 07 2024 21:23:59.386309 [Info] - 1 modes on display:
Fri Jun 07 2024 21:23:59.386321 [Info] -  - 0: 3840x1920@90.000008Hz
Fri Jun 07 2024 21:23:59.386332 [Info] - Selected mode 0.
Fri Jun 07 2024 21:24:01.309137 [Info] - Failed to acquire xlib display
Fri Jun 07 2024 21:24:01.309168 [Error] - CHmdWindowSDL: Failed to create direct mode surface
Fri Jun 07 2024 21:24:01.309240 [Error] - CHmdWindowSDL: VR requires direct mode.
Fri Jun 07 2024 21:24:01.309312 [Error] - Error making window!
Fri Jun 07 2024 21:24:01.329474 [Info] - Failed to kill gpu-trace
Fri Jun 07 2024 21:24:01.329529 [Info] - Failed to initialize compositor
Fri Jun 07 2024 21:24:01.329548 [Info] - Failed to start compositor: VRInitError_Compositor_CannotDRMLeaseDisplay

vrcompositor.txt (8.4 KB)

Looked through the other files (vrclient_*.txt, vrmonitor/vrserver etc) and the information there doesn’t really seem HMD specific. HMD works on Windows. What else to provide to help debugging?

SteamVR has been quite unworkable on Linux, we’ve been using Monado instead for an overwhelming majority of our end user VR and gaming.

The headset display fails to even initialize on a DRM level from what I gather, whereas patched AMD can run it just fine under monado.

You can reach out to our community here: Community

Or survey the rest of our docs if you’ve never setup monado before. Let me see if one of our monado users can send some info direct.

Unfortunately this issue happens on any openxr/openvr runtime, be it steamvr or monado etc.

What works:

  • Bigscreen Beyond’s non-desktop property is detected and direct mode can be enabled
  • The HMD display can wake up and the nose sensor works
  • HMD can talk to base stations and controllers

However the displayed output itself is broken.
Half of the screen has fuzzy static noise on a gray background. This “rectangular plane” of noise tracks your head movement so it can’t be a tracking failure.

Thankyou for lending a minute to showcase.

Seems we have initialization but the display is not behaving correctly on nvidia prop here. Hopefully an nvidia rep here might have an idea of what’s going on between this and the necessary patches that enabled AMD to function.

Users report seeing these exact visuals upon DSC handshake failure under windows. More signs point to an issue in the DSC implementation on the binary driver here.

Thank you for the report. What NVIDIA Linux GPU driver versions have you seen this with? Yes, we had a issues with this headset on in the Windows driver that was fixed recently; I think that was a regression introduced in the 550 drivers.

3 Likes

We’ve had users in LVRA tested as far back as 535, no user has been able to init their BSB display for use all the way up to 555.