Black monitor when using nvidia driver on a 4k 60hz screen

Hey. I have a 4k 60hz screen connected to a computer with a Quadro P2200.
Screen is black.
Driver version 450.
Kubuntu 18.04
Screen is detected in xrandr with the correct EDID information and resolution.
Screen is however black when using Nvidia driver.
Tried on computers running windows and works perfectly. Running a certified 1.4 DP cable and have tried 4-5 different brands ranging from 1.2 to 1.4 DP.

If using Nouveau screen works plug & play.

xrandr output:
xrandr --props

DP-0 connected 3840x2160+0+0 (normal left inverted right x axis y axis) 346mm x 194mm
CTM: 0 1 0 0 0 0 0 0 0 1 0 0 0 0 0 0
0 1
CscMatrix: 65536 0 0 0 0 65536 0 0 0 0 65536 0
EDID:
00ffffffffffff004d10141400000000
05180104a523137806de50a3544c9926
0f505400000001010101010101010101
0101010101014dd000a0f0703e803020
35005ac2100000180000001000000000
00000000000000000000000000100000
000000000000000000000000000000fc
004c5131353644314a5830310a200078
BorderDimensions: 4
supported: 4
Border: 0 0 0 0
range: (0, 65535)
SignalFormat: DisplayPort
supported: DisplayPort
ConnectorType: DisplayPort
ConnectorNumber: 2
_ConnectorLocation: 2
3840x2160 60.00*+

Bugreport using nvidia-bug-report.sh:
nvidia-bug-report.log.gz (803.2 KB)

Please upgrade your HWE first
https://wiki.ubuntu.com/Kernel/LTSEnablementStack
and posibly disable your intel igpu in bios. Try again, create a new nvidia-bug-report.log if it still doesn’t work.

Updated HWE and disabled intel igpu still no picture:

New bug report:
nvidia-bug-report.log.gz (259.1 KB)

Found one thing:
If connecting the display though a HP Elite Thunderbolt 3 Hub -> USB C -> computer. With the same Displayport cable from previous tests connected to the hub the screen works. But this solution does not work since I can’t use a hub in my setup later on.

What might the reason behind this be?
Is the hub not using the NVIDIA driver for graphics?

The dock has some DisplayLink graphics devices built in, so it’s not using the nvidia gpu.
Things to try:

  • disconnect the dock
  • does the monitor work with any other resolution?
  • does the monitor work if it’s the only one?
  • does using the kernel parameter ‘nvidia-drm.modeset=1’ help?
1 Like

The dock was just connected for testing, after that I disconnected it.

Monitor does not work if it’s the only one. Same result.

Modeset did not affect the results.

Thanks for the quick reply,
Happy holidays!

Any more information I could provide to help us solve this issue?

Best regards
myhrmans

I’m actually a bit confused by your hardware setup shown in the logs. In your initial log you provided, three diplaylink devices are reported, did you have the dock connected when you created it?

I did not. All logs have been without the dock connected.

Best regards
myhrmans

Did you already try connecting it to a different connector on the Quadro?
If your mainboard has a displayport connector, you could also try reenabling the igpu and connect the monitor to it.

Yes. I tried also a different computer running same Ubuntu and Nivida driver. Same issue. Connecting it to the iGPU works if it is not using the driver, so seems to be some sort of problem with the screen + driver.

Yes, seems so. What kind of brand/model is this? The edid only reports the panel that built into the monitor Sharp LQ156D1JX01

Its a screen created by HOSIDEN. Screen works with windows with or without nvidia card + nvidias latest driver. but not working on Linux nvidia driver… :/

Did you check if this is a general incompatibility or a regression, e.g. by installing a 440 driver (kernel 5.4 max)?

I have tried drivers from 390 and up. So seems to be all drivers.
Also tried Ubuntu and Kubuntu, same results.

Please check with the latest 460.32.03 driver, it has a fix for “DP multistream displays”. Might be related.

No difference from what I can tell. Did a new bugreport after the update, hopefully one might be able to see something from this report:

nvidia-bug-report.log.gz (870.5 KB)

Just for testing, did you ever disconnect the HP monitor and boot only with the problematic display connected to check whether at least POST and boot messages are displayed?

Yes. Just did that and no boot messages are shown, sadly.

Maybe try kernel parameter
nvidia-drm.modeset=1