Blank screen only on Ubuntu 18.04.2 on 430, 440, etc. driver

I posted about the problem (with some logs) here. I’ve tried multiple purges of the nvidia drivers and reinstalling. I’ve tried the 440 (latest) drivers, the 430 drivers, 415 drivers (got llvmpipe on that one). I’ve been unable to install 418 drivers because even with PPA it tries to install 430 drivers. I can get a desktop without any drivers, but then my resolution is all screwed up and CPU usage is high with llvmpipe. I’ve tried switching my display manager but that doesn’t solve it, I can get to TTY if I restart gdm3 while in recovery mode, otherwise I can’t even get TTY, the screen is just blank and my monitor goes into power saving mode. I can recreate the state it gets in by running startx in recovery or TTY. Issue continues even when using nomodeset as you can see here: https://youtu.be/PTZvduRg-AM

I can provide NVIDIA bug report, but I don’t know whether I should take it with or without the NVIDIA drivers running.
0dqx.gz (3 Bytes)

nvidia-bug-report.log.recovery.gz (1.08 MB)
nvidia-bug-report.log.working.gz (1.12 MB)
nvidia-bug-report.log.blackscreen.gz (1.12 MB)

Please run nvidia-bug-report.sh as root with the driver running and attach the resulting .gz file to your post. Hovering the mouse over an existing post of yours will reveal a paperclip icon.
https://devtalk.nvidia.com/default/topic/1043347/announcements/attaching-files-to-forum-topics-posts/

Okay today when I tried to boot it up to get the logs it was actually working for a few minutes before it went to the black screen again! Anyway here’s the log I was able to capture before the display crashed again. That’s log 0dqx. The log I took while drivers were not running is 2mak.

Both are broken 3 byte long files.

Sorry about that. Tried to use termbin.com to send them, I setup SSH and got new copies as well as ran the bug report again in the broken state. They should be correct this time.

Driver/software setup is fine. Unfortunately, there’s not much more to see than that the gpu gets reset after some time, sometimes earlier or later. Looks like a hardware issue but there’s no real hint to what to look at first. Please start by reseating the nvidia card, check it in another system.

Ouch. That’s exactly what I didn’t want to hear. I’ll try to find a system to reseat it in. I don’t have one at home so I’ll have to find someone else’s. Better start an RMA anyway.

Just reseat it in the slot of your current system first.

Alright, I haven’t tried that yet, but I did notice another error, I got a crash report for the nvidia kernel source. I did unplug and replug the power though, and right now it seems to be working.