Blendshape Solve Node

I working with the example in Audio2Face 2023.1.1, using the allison_tagged example. However, after hitting ‘set up blendshape solve’ it doesn’t work. Ever thing prior to this works fine. The usdSkel model isn’t moving. I saw a video showing that with blender models you have to change the inputs #s at the l2_regul_weight and below. This did not work, or at least the #s they used. Is there a know # for this example?

@michael.bullington96 i am just another user, but could you be a bit more specific and elaborate on your steps (if any) leading up to clicking “set up blendshape solve”. and which video were you referring to, was it one of the tutorials by Nvidia?

@3:13 in the video he talks about needing to change the #s. Am not using the rain character, am using the allison model example proved by audio2face.

this post from the dev should help:

the suggested 0.01 should work fine if you set up the A2F pipeline after setting up the blendshapes. here’s what that should look like at 0.01


1 Like

and here is what’d happen if you were to set up A2F Pipeline before blendshape solve no matter what the weight values were set at. you’d only get slight jittering (hard to see even zoomed in at this level) which can easily be perceived as ‘not moving’.


Thanks. These are the #s. Would not have known to leave the 3.5 for the first one based off the video’s info.

these numbers do seem arbitrary at times. the 0.001 mentioned in the blender video is perhaps for Rain in that specific demo; i suspect users will need to do some additional tweaking if custom mesh was used like he suggested later on. glad the numbers by @Ehsan.HM worked out on Allison 🙌

p.s. you could consider activating the loop in your audio player and change the slider to see the changes in viewport. this may help save some clicking back and forth.

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.