Audio2faceBlendshape conversion doesn't work

I’ve created an animation following this video :

But i’ve got an issue when I make the blendshape conversion (4:50 in the video) and click on set up blendshape solve, I have all blendshape but I don’t have the animation on my usdSkel

Have you any idea that could help me ? Thank you

Hello @celeber12! Welcome to the Community! Let me reach out to the development team for some help.

Hi @celeber12, seems like you selected the correct prims for blendshape solve, and I’m not sure what is blocking the process from this still image.

I’ve just tested the same process using a different asset (localhost/NVIDIA/Assets/Audio2Face/Samples/char_transfer/allison_mark_tagged_v001.usd) and it worked fine.
Can you try couple more times from the clean new scene? If it keeps failing, please upload the face model you’re testing, so we can check if the model has any issue.


Hi, firstly, thank you for helping me, I’ve tried with allison and it’s worked just fine, but I tried twice after that with my own character and firstly, when I import the usdskell, the scale seems to be 0.01 and the mesh has a rotation of -90° in the X axis. And when I clic on set up blendshape solve nothing happen, the mesh doesn’t move or anything else.
I’ve also got this warning

“[Warning] [omni.usd] Warning (secondary thread): in ProcessPropertyChange at line 519 of E:\w\ca6c508eae419cf8\USD\pxr\usdImaging\usdSkelImaging\skeletonAdapter.cpp – Unhandled ProcessPropertyChange callback for cachePath </aya_n5_bs_usdSkel/Mesh_005/joint1/bs_anim> in UsdSkelImagingSkelAdapter.”

n5.usda (1.1 MB)
n5_fixed.usda (1.1 MB)

here is my mesh if it could help,
thank you very much !

Seems like your model is too small (like 1/100 size), so the blendshape solve parameters need to be adjusted.
could you tune the settings in image near zero like this and see if it works? (It worked for me)


it worked ! thank you very much !

@yseol I’ve exported before without problems, but now it gets stuck on 100% and the usd file is 1KB.
My last usd file (with a diff recording) was 700KB long and I didn’t have any trouble. I’ve spent like 1 hr waiting and testing diff settings, such as the ones you pointed out above. But I stay at 100%

Would you be so kind to help me out, pls?

Also, I opened the project I had before where I succesfully exported, but now with this recording I can’t. Is it because it is too small? The recording is like 3 seconds long.

Well, the different parameters wouldn’t affect the file writing, can you change the output file name not to include the dot? like D_m2_1.usd

1 Like

God bless you @yseol !! that was the solution
Such a small detail made a huge difference. The exporting was immediate. thank you tons!!!

thanks for letting us know and sorry for your inconvenience, we will address this bug very soon.

1 Like