bootfromUSB not working after install Arducam driver

Hi everyone!

I have 2 Jetson Nano. the one is no problem, but another one cannot boot by USB memory and stop like attached photo.
It can boot by USB a few times, but after installing Arducam camera driver (IMX477) then reboot, it cannot be booted by USB everafter.

I made boot USB and installed Jetpack several times, but no meaning.
JetPack : first installed 4.6, after installed 4.5.1
USB Memory : Samsung USB 3.1 256GB

I refered this site.

Please, help me.

Use uart console to see if the board is able to boot or not.

Using SD card, can boot, no problem. I forgot to write it.

But your problem is with USB, why should we care about SDcard.

I mean this one can boot (by sd card).
tomorrow I prepare some cable and try you wrote.

Just focus on the problem you hit. I don’t care and you shouldn’t care about the sdcard at all.

No matter what kind of boot source it is , boot issue always requires uart to debug.

i have used FADUIO’s uart cable. but i can never read acsii char. for every baud rate.
What is wrong? 115200 is right?

If you can still see something printed over the screen, which means the board is still booting.

For such case, I can only suggest you check your uart connection or change to another cable.

Nano_UsbBoot_01 (67.7 KB)
I could get boot log file after I changed uart board. Then, what can i do?

It looks like most of your kernel log get truncated. Could you dump it again and make sure they are completed?

I need to check your Kernel command line but it is not completed.

[ 0.000000] Kernel command line: tegraid= ddr_die=4096M@2048M sect

Nano_UsbBoot_02.txt (94.8 KB)
i tried again, but it maybe same.

Can you just take a picture on your monitor and let me see what does your log look like?

i think it is same. i don’t understand what you need.

Ahh… can you put your terminal into full screen, reboot the device and dump the log again?

For example,

This is the log you shared

[ 0.000000] Built 1 zonelists in Zone order, mobility grouping on. Total pa4

But actually the full line should be like below

[ 0.000000] Built 1 zonelists in Zone order, mobility grouping on. Total pages: 1023544

(this is from my jetson nano)
All of your lines are not full one in your log file.

Nano_UsbBoot_05.txt (71.4 KB)
i got it. i changed full hd monitor.
this is full screen log. you may see what you want.

Nano_UsbBoot_00.txt (22.1 KB)
this is the log able to boot of device. but have some problem of getting image of imx477.
you can refer.

Just want to tell you that your log file is still being cut.

The kernel command line is still not full.

But I can see the cause of your issue now, your root device looks like still mmcblk0p1. This is the default node for sdcard. But appears that sdcard does not exist on your board so it is not able to find the rootfs.

[ 6.584544] Root device found: mmcblk0p1
[ 8.088769] scsi 0:0:0:0: Direct-Access Samsung Flash Drive FIT 1100 PQ: 0 ANSI: 6
[ 8.097569] sd 0:0:0:0: [sda] 501253132 512-byte logical blocks: (257 GB/239 GiB)
[ 8.105234] sd 0:0:0:0: [sda] Write Protect is off
[ 8.110193] sd 0:0:0:0: [sda] Write cache: enabled, read cache: enabled, doesn’t support DPO or FUA
[ 8.127453] sda: sda1
[ 8.130936] sd 0:0:0:0: [sda] Attached SCSI removable disk
[ 16.742326] ERROR: mmcblk0p1 not found

You can learn by reading this post to understand what gets missing on your board now.

A simple solution is put your sdcard image back, let it boot into filesystem.

Then, you mount your sda1 to a mount point by using mount command. Goes to the your_mount_point/boot/extlinux/extlinux.conf and add root=/dev/sda1 to the kernel command line. Reboot and see if it helps.

But again, you need to get the full log so that we can see the kernel cmdline.

Nano_UsbBoot_07.txt (72.5 KB)
then, how about this?

Kernel command line: tegraid= ddr_die=4096M@2048M section=512M memtype=0 vpr_resize usb_port_owner_info=0 lane_owner_info=0 emc_max_dvfs=0 touch_id=0@63 video=tegrafb no_console_suspend=1 console=ttyS0,115200n8 debug_uartport=lsport,4 earlyprintk=uart8250-32bit,0x70006000 maxcpus=4 usbcore.old_scheme_first=1

Yes, do as what I suggested.