Building ETH miner on Jetson TX1

Does any one know an arm based miner that can mine ETH or Zcash on the TX1? I am trying to cross compile MInerGate on the TX1.

Hi spottybadrabbit,

We don’t have experience on this case, hope someone could share their result if they ever done something similar.

Thanks

Hi spottybadrabbit
Did you ever start mining with your Jetson TX1, I have one too and i want to know if its possible, thanks.

Hi,

I also want to know if this is possible.
I found a CUDA version miner, but not sure if it can run on tx1.

I was able to build and run ethminer on JTX2 (JetPack-3.0 / L4T R27.1) by the following steps.

  1. Checkout the source code.
$ mkdir -p ~/src
$ cd ~/src
$ git clone --recursive https://github.com/ethereum-mining/ethminer.git
$ cd ethminer
  1. Modify “libethash-cuda/CMakeLists.txt” as follows:
--- a/libethash-cuda/CMakeLists.txt
+++ b/libethash-cuda/CMakeLists.txt
@@ -17,6 +17,7 @@ else()
                "-gencode arch=compute_52,code=sm_52"
                "-gencode arch=compute_60,code=sm_60"
                "-gencode arch=compute_61,code=sm_61"
+               "-gencode arch=compute_62,code=sm_62"
        )
 endif()
  1. cmake, build and install.
$ cd ~/src/ethminer
$ mkdir build
$ cd build
$ cmake .. -DETHASHCUDA=ON -DETHASHCL=OFF
$ cmake --build .
$ sudo make install
  1. But when benchmarking, I only get 0 H/s!
$ ethminer -U -M

I also tried to mine from https://eth.nanopool.org/, and I could sometimes get non-zero (but still very low) hash rate.

This worked for me with geth(a CPU based miner):

wget https://gethstore.blob.core.windows.net/builds/geth-linux-arm64-1.6.7-ab5646c5.tar.gz
tar -xvzf geth-linux-arm64-1.6.7-ab5646c5
cd geth-linux-arm64-1.6.7-ab5646c5
cp geth /usr/local/bin 
geth --fast --cache=512 console
geth account import ~/Desktop/nothing_special_delete_me.txt

Will look into CUDA in the next few weeks. Working on compiling a smart miner that is GUI based to run on ARM64

When You run miner on this jetson, could You please tell me roughly how many H/s do You have?
It’s very interesting for me, thanks

any news?

Any update on this? Curious to see if anyone benchmarked the TX1’s GPU Sol/s or H/s for mining and hashcracking.

I was able to build on a Jetson TX2 (build took under 10 minutes), only gotcha is to remember to activate CUDA during the ethminer cmake config. The latest ethminer builds do a great job with Cmake to fetch dependencies, and there are 0 problems with AARCH64. I need some help configuring the cuda options so that this can get any kind of hashrate above 1MH/s. I’m squeaking along at 0.25MH/s.

I ran ethminer on Jetson TX2 with Jetpack 3.1 and achieved 1.05 MH/s.

The TX1 achived 1.11MH/s at around 11Watts

Any other ubdates ? I dont see why this one cant mine ethereum same as 4gb mining card.
Anyone used anything else and got bigger mining speed ??

I changed my args to something like this, to help it go from 0 to about 0.25MH/s:

./ethminer --cuda-grid-size 2048 --cuda-block-size 128 --cuda-parallel-hash 4 -U

Can the folks that were pulling 1MH/s post their arguments?

Hi there,

Whenever I do pool mining the Hash Rate drops to 0. I just tried solo mining. Results are incoming! :)

Cheers,
Matthias

Speed goes way down to 0.35MH/s

Any update here ?

you probably could get it working with any miner that supports “cuda”

however, in my experience, even the usb sticks (gekko 2pac $99) are faster than my gtx 1060, which has 1208 cores at 1.7gzh. the tx1 is 256 cores.
so your going to burn your electricity and wear out the tegra for low to none returns.

another hint: dont buy used mining equipment off ebay… you are buying something that probably ran 24/7 for a year or two in a data center and is near end of hardware life. i.e. they buy 100 mining units and when 2 or 3 start to pop they buy new ones and sell the olds on ebay.

the best git i used was for compiling cgminer
beware “precompiled” mining programs, as they likely have added features by the guys wearing black hats

for reference, i’m using a pair of the gekkos and right this minute they are doing 32.37 GH/s
also you need a powered usb hub for those. the best one i’ve used is sold by walmart lol. it’s called blackweb powered usb hub

i 13:04:30 ethminer Selected pool localhost:0
i 13:04:30 ethminer Established connection to localhost:0
i 13:04:30 ethminer Spinning up miners…
cu 13:04:30 cuda-0 Using Pci Id : 00:00.0 Xavier (Compute 7.2) Memory : 15.45 GB
i 13:04:30 sim Epoch : 0 Difficulty : 4.29 Gh
i 13:04:30 sim Job: 438f31f0… block 30 localhost:0
cu 13:04:30 cuda-0 Generating DAG + Light : 1.02 GB
cu 13:04:30 cuda-0 Unexpected error CUDA error in func set_constants at line 124 invalid device symbol on CUDA device 00:00.0
cu 13:04:30 cuda-0 Mining suspended …
m 13:04:35 ethminer 0:00 A0 0.00 h - cu0 0.00
m 13:04:40 ethminer 0:00 A0 0.00 h - cu0 0.00
^C i 13:04:43 main Got interrupt …
i 13:04:43 main Simulation results : Max 0.000000 h Mean 0.000000 h
i 13:04:43 main Disconnected from localhost:0
i 13:04:43 main Shutting down miners…
i 13:04:44 main Terminated!

I tried Jetson Xavier but had cuda bugs that I couldn’t fix
“Unexpected error CUDA error in func set_constants at line 124 invalid device symbol on CUDA device 00:00.0”

@kivvi3412 Check how I solved a similar issue here: https://github.com/ethereum-mining/ethminer/issues/2047