What is the exactly GPU type of TX1?

I know that the GPU on TX1 is Maxwell microarchitecture, but I want to know the exactly type which can be found by the link:

https://www.nvidia.com/Download/index.aspx

Hi zhangygdyx, TX1’s GPU is GM20B. The drivers for it aren’t downloaded from the page you linked to — they are installed by JetPack or L4T.

FYI, one of the big reasons the drivers are not there (beyond being arm64 instead of x86_64) is that the GPU is integrated directly to the memory controller and the drivers where you are looking are for PCIe devices.

they are iGPU

I install the TX1 by L4T and then I install the cuda manually, but it can’t run the cuda samples and shows that can not find the GPUs.
There must be some problems.

In my case nvcc appears rather to work, though some features of CUDA, targeted, for example on MPS wont run.
How do you run the samples? What is the exact error you are getting?
Do you run some particular samples?

It shows cuda 8.0 when I run ‘nvcc -V’.
And when I run ‘./deviceQuery’ in 1_Utilities of cuda samples, it shows fail with ‘CUDA driver version is insufficient for CUDA runtime version’.

what if you try to run a basic "hello world " like application that just does print hello and that you will compile with

nvcc hello.cu -o hello --run

?

you may use pages 12-13 of the http://www.nvidia.com/docs/IO/116711/sc11-cuda-c-basics.pdf

otherwise http://www.math.uaa.alaska.edu/~afkjm/cs448/handouts/cuda-firstprograms.pdf

It comes out with some warning but runs successful.
The warning is like “The ‘compute_20’, 'sm_20‘ and’sm_21‘architectures are deprecated…”.

but jetson doesn’t have sm20, neither it has 21;
you should revise the code you are running in my opinion.
I am not sure what sm is at tx1, I am using tx2 and it has, I am inclined to believe sm 6.1 or so.
You may specify the sm architecture when running nvcc like in the example below:

nvcc -arch=sm_6.1 hello.cu -o hello --run

For TX1, cuda arch is 5.3 (sm_53).

Really appreciate for all your replys.
It runs good with ‘nvcc -arch=sm_53 hello.cu -o hello --run’.
But I still can’t run the cuda samples like somkes and water waves.

do you mean samples/5_Simulations/smokeParticles ?

In my case [tx2], I can execute the below

/usr/local/cuda-9.0/samples/5_Simulations/smokeParticles$ sudo make
[sudo] password for nvidia: 
/usr/local/cuda-9.0/bin/nvcc -ccbin g++ -I../../common/inc  -m64    -gencode arch=compute_30,code=sm_30 -gencode arch=compute_32,code=sm_32 -gencode arch=compute_35,code=sm_35 -gencode arch=compute_37,c
...
...
...

now it appears to build the examples

now it finished the make process and executes the resulting binary just fine:

/usr/local/cuda-9.0/bin/nvcc -ccbin g++   -m64      -gencode arch=compute_30,code=sm_30 -gencode arch=compute_32,code=sm_32 -gencode arch=compute_35,code=sm_35 -gencode arch=compute_37,code=sm_37 -gencode arch=compute_50,code=sm_50 -gencode arch=compute_52,code=sm_52 -gencode arch=compute_53,code=sm_53 -gencode arch=compute_60,code=sm_60 -gencode arch=compute_61,code=sm_61 -gencode arch=compute_62,code=sm_62 -gencode arch=compute_62,code=compute_62 -o smokeParticles GLSLProgram.o ParticleSystem.o ParticleSystem_cuda.o SmokeRenderer.o SmokeShaders.o framebufferObject.o particleDemo.o renderbuffer.o   -lGL -lGLU -lX11 -lglut
mkdir -p ../../bin/aarch64/linux/release
cp smokeParticles ../../bin/aarch64/linux/release
nvidia@tegra-ubuntu:/usr/local/cuda-9.0/samples/5_Simulations/smokeParticles$ ls
data                   GLSLProgram.o      particleDemo.cpp             ParticleSystem.h   SmokeRenderer.h
doc                    GpuArray.h         particleDemo.o               ParticleSystem.o   SmokeRenderer.o
findgllib.mk           Makefile           particles_kernel.cuh         readme.txt         SmokeShaders.cpp
framebufferObject.cpp  NsightEclipse.xml  particles_kernel_device.cuh  renderbuffer.cpp   SmokeShaders.h
framebufferObject.h    nvMath.h           ParticleSystem.cpp           renderbuffer.h     SmokeShaders.o
framebufferObject.o    nvMatrix.h         ParticleSystem_cuda.cu       renderbuffer.o
GLSLProgram.cpp        nvQuaternion.h     ParticleSystem_cuda.o        smokeParticles
GLSLProgram.h          nvVector.h         ParticleSystem.cuh           SmokeRenderer.cpp
nvidia@tegra-ubuntu:/usr/local/cuda-9.0/samples/5_Simulations/smokeParticles$ ./smokeParticles 
CUDA Smoke Particles Starting...

NOTE: The CUDA Samples are not meant for performance measurements. Results may vary when GPU Boost is enabled.

Loaded './data/floortile.ppm', 256 x 256 pixels

try run the

sudo make

from the folder where the samples you want to execute are located, and then use the resulting binaries to run the samples

Also beware that if you log in from a remote system with X forwarding you may have results which depend on the host’s CUDA and GPU instead of the Jetson’s. A virtual desktop forwarding setup avoids that issue (or just log in locally to the Jetson).

My ‘sudo make’ command is ok, but it just blink a window and then closed(failed) when I execute it.
And when I run the deviceQuery, it says ‘CUDA driver verison is insufficient for CUDA runtime version’, and ‘cudaDeviceCount returned 35’