Building kernel Image flash to JetsonNano no screen show up

Hi,NV Team

We follow the steps and try to bulid linux kernel.

https://developer.ridgerun.com/wiki/index.php?title=Jetson_Nano/Development/Building_the_Kernel_from_Source

1.Source File: Tegra210_Linux_R32.2.1_aarch64.tbz2
2.Run ./source_sync.sh (use: tegra-l4t-r32.2.1 as the tag)
3.Follow the steps and bulid kernel-4.9 sucessfully created Image
4.Replace directory /Linux_for_Tegra/kernel/Image , use our new bulid Image.
5.sudo ./apply_binaries.sh
6.sudo ./create-jetson-nano-sd-card-image.sh -o jetson_nano.img -s 12G -r 100

Then we flash jetson_nano.img to sdcard and boot the system.

Everything goes fine when first boot.(Screen show up)
Accept license-> choose TimeZone -> create user

Apply packages is done,system automatic reboot.
Then No screen show up.
Command dmesg(check kernel message)
Continuously pop up AUX1(HDMI) enable and Extcon AUX1(HDMI) disable.

Any idea about this situation??

[  25.844444] tegradc tegradc.0: hdmi: tmds rate:148500K prod-setting:prod_c_hdmi_75m_150m
[   25.845478] tegradc tegradc.0: hdmi: get RGB quant from EDID.
[   25.845484] tegradc tegradc.0: hdmi: get YCC quant from EDID.
[   25.882193] extcon-disp-state extcon:disp-state: cable 47 state 1
[   25.882195] Extcon AUX1(HDMI) enable
[   25.882511] tegradc tegradc.0: sync windows ret = 250
[   26.177093] tegradc tegradc.0: blank - powerdown
[   26.212525] extcon-disp-state extcon:disp-state: cable 47 state 0
[   26.212526] Extcon AUX1(HDMI) disable
[   26.232872] tegradc tegradc.0: unblank
[   26.271060] tegradc tegradc.0: nominal-pclk:148500000 parent:148500000 div:1.0 pclk:148500000 147015000~161865000
[   26.271132] tegradc tegradc.0: hdmi: tmds rate:148500K prod-setting:prod_c_hdmi_75m_150m
[   26.272151] tegradc tegradc.0: hdmi: get RGB quant from EDID.
[   26.272157] tegradc tegradc.0: hdmi: get YCC quant from EDID.
[   26.312565] extcon-disp-state extcon:disp-state: cable 47 state 1
[   26.312570] Extcon AUX1(HDMI) enable
[   26.313095] tegradc tegradc.0: sync windows ret = 250
[   26.601588] tegradc tegradc.0: blank - powerdown
[   26.639137] extcon-disp-state extcon:disp-state: cable 47 state 0
[   26.639139] Extcon AUX1(HDMI) disable
[   26.659583] tegradc tegradc.0: unblank
[   26.697734] tegradc tegradc.0: nominal-pclk:148500000 parent:148500000 div:1.0 pclk:148500000 147015000~161865000
[   26.697807] tegradc tegradc.0: hdmi: tmds rate:148500K prod-setting:prod_c_hdmi_75m_150m
[   26.698869] tegradc tegradc.0: hdmi: get RGB quant from EDID.
[   26.698876] tegradc tegradc.0: hdmi: get YCC quant from EDID.
[   26.738282] extcon-disp-state extcon:disp-state: cable 47 state 1
[   26.738285] Extcon AUX1(HDMI) enable
[   26.738614] tegradc tegradc.0: sync windows ret = 250
[   27.029396] tegradc tegradc.0: blank - powerdown
[   27.065932] extcon-disp-state extcon:disp-state: cable 47 state 0
[   27.065934] Extcon AUX1(HDMI) disable
[   27.086314] tegradc tegradc.0: unblank
[   27.124416] tegradc tegradc.0: nominal-pclk:148500000 parent:148500000 div:1.0 pclk:148500000 147015000~161865000
[   27.124490] tegradc tegradc.0: hdmi: tmds rate:148500K prod-setting:prod_c_hdmi_75m_150m
[   27.125511] tegradc tegradc.0: hdmi: get RGB quant from EDID.
[   27.125516] tegradc tegradc.0: hdmi: get YCC quant from EDID.
[   27.162175] extcon-disp-state extcon:disp-state: cable 47 state 1

Here is console log:

[0000.126] [TegraBoot] (version 00.00.2018.01-l4t-89b97a49)
[0000.131] Processing in cold boot mode Bootloader 2
[0000.136] A02 Bootrom Patch rev = 1023
[0000.140] Power-up reason: pmc por
[0000.143] No Battery Present
[0000.145] pmic max77620 reset reason
[0000.149] pmic max77620 NVERC : 0x40
[0000.152] RamCode = 0
[0000.154] Platform has DDR4 type RAM
[0000.158] max77620 disabling SD1 Remote Sense
[0000.162] Setting DDR voltage to 1125mv
[0000.166] Serial Number of Pmic Max77663: 0xa02a5
[0000.173] Entering ramdump check
[0000.176] Get RamDumpCarveOut = 0x0
[0000.180] RamDumpCarveOut=0x0,  RamDumperFlag=0xe59ff3f8
[0000.185] Last reboot was clean, booting normally!
[0000.189] Sdram initialization is successful
[0000.194] SecureOs Carveout Base=0x00000000ff800000 Size=0x00800000
[0000.200] Lp0 Carveout Base=0x00000000ff780000 Size=0x00001000
[0000.205] BpmpFw Carveout Base=0x00000000ff700000 Size=0x00080000
[0000.211] GSC1 Carveout Base=0x00000000ff600000 Size=0x00100000
[0000.217] GSC2 Carveout Base=0x00000000ff500000 Size=0x00100000
[0000.223] GSC4 Carveout Base=0x00000000ff400000 Size=0x00100000
[0000.229] GSC5 Carveout Base=0x00000000ff300000 Size=0x00100000
[0000.235] GSC3 Carveout Base=0x000000017f300000 Size=0x00d00000
[0000.251] RamDump Carveout Base=0x00000000ff280000 Size=0x00080000
[0000.257] Platform-DebugCarveout: 0
[0000.260] Nck Carveout Base=0x00000000ff080000 Size=0x00200000
[0000.266] Non secure mode, and RB not enabled.
[0000.689] Csd NumOfBlocks=62521344
[0000.694] Set High speed to 1
[0000.704] Using GPT Primary to query partitions
[0000.709] Loading Tboot-CPU binary
[0000.721] Verifying TBC in OdmNonSecureSBK mode
[0000.731] Bootloader load address is 0xa0000000, entry address is 0xa0000258
[0000.738] Bootloader downloaded successfully.
[0000.742] Downloaded Tboot-CPU binary to 0xa0000258
[0000.747] MAX77620_GPIO5 configured
[0000.751] CPU power rail is up
[0000.753] CPU clock enabled
[0000.757] Performing RAM repair
[0000.760] Updating A64 Warmreset Address to 0xa00002e9
[0000.765] Loading NvTbootBootloaderDTB
[0000.801] Verifying NvTbootBootloaderDTB in OdmNonSecureSBK mode
[0000.866] Bootloader DTB Load Address: 0x83000000
[0000.871] Loading NvTbootKernelDTB
[0000.906] Verifying NvTbootKernelDTB in OdmNonSecureSBK mode
[0000.971] Kernel DTB Load Address: 0x83100000
[0000.975] Loading cboot binary
[0001.019] Verifying EBT in OdmNonSecureSBK mode
[0001.062] Bootloader load address is 0x92c00000, entry address is 0x92c00258
[0001.069] Bootloader downloaded successfully.
[0001.073] Next binary entry address: 0x92c00258
[0001.078] BoardId: 3448
[0001.083] Overriding pmu board id with proc board id
[0001.087] Display board id is not available
[0001.128] Verifying SC7EntryFw in OdmNonSecureSBK mode
[0001.180] /bpmp deleted
[0001.182] SC7EntryFw header found loaded at 0xff700000
[0001.371] OVR2 PMIC
[0001.372] Bpmp FW successfully loaded
[0001.377] WB0 init successfully at 0xff780000
[0001.381] Set NvDecSticky Bits
[0001.385] GSC2 address ff53fffc value c0edbbcc
[0001.391] GSC MC Settings done
[0001.394] TOS Image length 53680
[0001.397]  Monitor size 53680
[0001.400]  OS size 0
[0001.409] Secure Os AES-CMAC Verification Success!
[0001.413] TOS image cipher info: plaintext
[0001.417] Loading and Validation of Secure OS Successful
[0001.433] SC7 Entry Firmware - 0xff700000, 0x4000
[0001.437] NvTbootPackSdramParams: start.
[0001.443] NvTbootPackSdramParams: done.
[0001.446] Tegraboot started after 53778 us
[0001.450] Basic modules init took 1064552 us
[0001.454] NvTbootQspiFlashIoctl: Opcode = 1 not supported
[0001.460] Sec Bootdevice Read Time = 622327755 ms, Read Size = 622327755 KB
[0001.466] Sec Bootdevice Write Time = 0 ms, Write Size = 0 KB
[0001.472] Storage Device Read Time = 164 ms, Read Size = 2241 KB
[0001.478] Storage Device Write Time = 0 ms, Write Size = 0 KB
[0001.483] Next stage binary read took 37577 us
[0001.487] Carveout took -49250 us
[0001.491] CPU initialization took 374816 us
[0001.495] Total time taken by TegraBoot 1427695 us

[0001.499] Starting CPU & Halting co-processor

64NOTICE:  BL31: v1.3(release):a28d87f09
NOTICE:  BL31: Built : 21:10:01, Aug 12 2019
ERROR:   Error initializing runtime service trusty_fast
[0001.622] RamCode = 0
[0001.626] LPDDR4 Training: Read DT: Number of tables = 2
[0001.631] EMC Training (SRC-freq: 204000; DST-freq: 1600000)
[0001.644] EMC Training Successful
[0001.647] 408000 not found in DVFS table
[0001.654] RamCode = 0
[0001.657] DT Write: emc-table@204000 succeeded
[0001.662] DT Write: emc-table@1600000 succeeded
[0001.667] LPDDR4 Training: Write DT: Number of tables = 2
[0001.716]
[0001.717] Debug Init done
[0001.719] Marked DTB cacheable
[0001.722] Bootloader DTB loaded at 0x83000000
[0001.727] Marked DTB cacheable
[0001.730] Kernel DTB loaded at 0x83100000
[0001.734] DeviceTree Init done
[0001.746] Pinmux applied successfully
[0001.750] gicd_base: 0x50041000
[0001.753] gicc_base: 0x50042000
[0001.756] Interrupts Init done
[0001.760] Using base:0x60005090 & irq:208 for tick-timer
[0001.766] Using base:0x60005098 for delay-timer
[0001.770] platform_init_timer: DONE
[0001.774] Timer(tick) Init done
[0001.777] osc freq = 38400 khz
[0001.781]
[0001.782] welcome to cboot
[0001.785]
[0001.786] Cboot Version: 00.00.2018.01-t210-3a168c35
[0001.791] calling constructors
[0001.794] initializing heap
[0001.797] initializing threads
[0001.800] initializing timers
[0001.803] creating bootstrap completion thread
[0001.807] top of bootstrap2()
[0001.810] CPU: ARM Cortex A57
[0001.813] CPU: MIDR: 0x411FD071, MPIDR: 0x80000000
[0001.818] initializing platform
[0001.821] Scratch reg 37 & 271 initial value set..
[0001.827] cboot:secure-pmc present
[0001.830] Manufacturer: MF = 0xc2, ID MSB = 0x25
[0001.835] ID LSB = 0x36, ID-CFI len = 194 bytes
[0001.839] Macronix QSPI chip present
[0001.843] SPI device register
[0001.846] init boot device
[0001.848] allocating memory for boot device(SPI)
[0001.853] registering boot device
[0001.862] sdmmc node status = okay
[0001.865] sdcard instance = 0
[0001.868] sdcard gpio handle 0x56
[0001.871] sdcard gpio pin 0xc9
[0001.874] sdcard gpio flags 0x0
[0001.877] vmmc-supply 0x99
[0001.880] Instance: 0
[0001.882] Allocating memory for context
[0001.886] enabling clock
[0001.888] sd card init
[0001.891] Check card present and stable
[0001.894] Send command 0
[0001.911] Send command 3
[0001.915] Set RCA for the card
[0001.918] Query card specific data by command 9
[0001.925] Parse CSD data
[0001.927] Send command 7
[0001.937] Calling sd device register
[0001.941] Init sdcard
[0001.943] Allocating memory for boot device
[0001.947] Registering user device
[0001.960] Enable APE clock
[0001.963] Un-powergate APE partition
[0001.966] of_register: registering tegra_udc to of_hal
[0001.971] of_register: registering tegra_udc to of_hal
[0001.976] of_register: registering inv20628-driver to of_hal
[0001.982] of_register: registering ads1015-driver to of_hal
[0001.988] of_register: registering lp8557-bl-driver to of_hal
[0001.993] of_register: registering bq2419x_charger to of_hal
[0001.999] of_register: registering cpc to of_hal
[0002.004] of_register: registering bq27441_fuel_gauge to of_hal
[0002.015] gpio framework initialized
[0002.018] of_register: registering tca9539_gpio to of_hal
[0002.024] of_register: registering tca9539_gpio to of_hal
[0002.029] of_register: registering i2c_bus_driver to of_hal
[0002.035] of_register: registering i2c_bus_driver to of_hal
[0002.040] of_register: registering i2c_bus_driver to of_hal
[0002.046] of_register: registering i2c_bus_driver to of_hal
[0002.051] pmic framework initialized
[0002.055] of_register: registering max77620_pmic to of_hal
[0002.060] regulator framework initialized
[0002.064] of_register: registering tps65132_bl_driver to of_hal
[0002.070] initializing target
[0002.076] gpio_driver_register: register 'tegra_gpio_driver' driver
[0002.084] fixed regulator driver initialized
[0002.101] initializing OF layer
[0002.104] NCK carveout not present
[0002.108] Skipping dts_overrides
[0002.112] of_children_init: Ops found for compatible string nvidia,tegra210-i2c
[0002.128] I2C Bus Init done
[0002.131] of_children_init: Ops found for compatible string nvidia,tegra210-i2c
[0002.141] I2C Bus Init done
[0002.144] of_children_init: Ops found for compatible string nvidia,tegra210-i2c
[0002.154] I2C Bus Init done
[0002.157] of_children_init: Ops found for compatible string nvidia,tegra210-i2c
[0002.167] I2C Bus Init done
[0002.170] of_children_init: Ops found for compatible string nvidia,tegra210-i2c
[0002.180] I2C Bus Init done
[0002.182] of_children_init: Ops found for compatible string maxim,max77620
[0002.193] max77620_init using irq 118
[0002.198] register 'maxim,max77620' pmic
[0002.202] gpio_driver_register: register 'max77620-gpio' driver
[0002.208] of_children_init: Ops found for compatible string nvidia,tegra210-i2c
[0002.218] I2C Bus Init done
[0002.222] NCK carveout not present
[0002.225] shim_invoke: No NCT, Calling dts updates
[0002.237] Find /i2c@7000c000's alias i2c0
[0002.240] get eeprom at 1-a0, size 256, type 0
[0002.249] Find /i2c@7000c500's alias i2c2
[0002.253] get eeprom at 3-a0, size 256, type 0
[0002.257] get eeprom at 3-ae, size 256, type 0
[0002.262] pm_ids_update: Updating 1,a0, size 256, type 0
[0002.267] I2C slave not started
[0002.270] I2C write failed
[0002.273] Writing offset failed
[0002.276] eeprom_init: EEPROM read failed
[0002.280] pm_ids_update: eeprom init failed
[0002.284] pm_ids_update: Updating 3,a0, size 256, type 0
[0002.314] pm_ids_update: The pm board id is 3448-0000-200
[0002.321] Adding plugin-manager/ids/3448-0000-200=/i2c@7000c500:module@0x50
[0002.328] pm_ids_update: pm id update successful
[0002.333] pm_ids_update: Updating 3,ae, size 256, type 0
[0002.363] pm_ids_update: The pm board id is 3449-0000-200
[0002.369] Adding plugin-manager/ids/3449-0000-200=/i2c@7000c500:module@0x57
[0002.377] pm_ids_update: pm id update successful
[0002.407] eeprom_get_mac: EEPROM invalid MAC address (all 0xff)
[0002.413] shim_eeprom_update_mac:267: Failed to update 0 MAC address in DTB
[0002.421] eeprom_get_mac: EEPROM invalid MAC address (all 0xff)
[0002.427] shim_eeprom_update_mac:267: Failed to update 1 MAC address in DTB
[0002.436] updating /chosen/nvidia,ethernet-mac node 00:04:4b:e6:46:15
[0002.442] Plugin Manager: Parse ODM data 0x00094000
[0002.452] shim_cmdline_install: /chosen/bootargs: root=/dev/mmcblk0p1 rw rootwait rootfstype=ext4 console=ttyS0,115200n8 console=tty0 fbcon=map:0 net.ifnames=0
[0002.473] Find /i2c@7000c000's alias i2c0
[0002.477] get eeprom at 1-a0, size 256, type 0
[0002.486] Find /i2c@7000c500's alias i2c2
[0002.490] get eeprom at 3-a0, size 256, type 0
[0002.494] get eeprom at 3-ae, size 256, type 0
[0002.498] pm_ids_update: Updating 1,a0, size 256, type 0
[0002.504] I2C slave not started
[0002.507] I2C write failed
[0002.509] Writing offset failed
[0002.512] eeprom_init: EEPROM read failed
[0002.516] pm_ids_update: eeprom init failed
[0002.520] pm_ids_update: Updating 3,a0, size 256, type 0
[0002.551] pm_ids_update: The pm board id is 3448-0000-200
[0002.557] Adding plugin-manager/ids/3448-0000-200=/i2c@7000c500:module@0x50
[0002.564] pm_ids_update: pm id update successful
[0002.569] pm_ids_update: Updating 3,ae, size 256, type 0
[0002.599] pm_ids_update: The pm board id is 3449-0000-200
[0002.605] Adding plugin-manager/ids/3449-0000-200=/i2c@7000c500:module@0x57
[0002.612] pm_ids_update: pm id update successful
[0002.643] Chip UID is 00000001644476401c00000015018300
[0002.648] Add serial number:14224190888210008301 as DT property
[0002.656] Applying platform configs
[0002.662] platform-init is not present. Skipping
[0002.667] calling apps_init()
[0002.692] Found 12 GPT partitions in "sd0"
[0002.696] Proceeding to Cold Boot
[0002.699] starting app android_boot_app
[0002.703] Device state: unlocked
[0002.706] display console init
[0002.715] could not find regulator
[0002.718] hdmi cable connected
[0002.733] edid read success
[0002.749] edid read success
[0002.751] widtDT entry for leds-pwm not found
h[0002.759]  = 640, height = 480, frequency = 25174825
[0002.764] width = 640, height = 480, frequency = 25174825
[0002.769] width = 640, height = 480, frequency = 25174825
[0002.775] width = 640, height = 480, frequency = 25174825
[0002.780] width = 1920, height = 1080, frequency = 148500000
[0002.786] width = 1920, height = 1080, frequency = 148500000
[0002.791] width = 1920, height = 1080, frequency = 148351648
[0002.797] width = 1280, height = 720, frequency = 74175824
[0002.802] width = 720, height = 480, frequency = 26973026
[0002.808] width = 720, height = 480, frequency = 26973026
[0002.813] width = 1920, height = 1080, frequency = 148351648
[0002.819] width = 1280, height = 720, frequency = 74175824
[0002.824] width = 720, height = 576, frequency = 26973026
[0002.830] width = 720, height = 576, frequency = 26973026
[0002.835] width = 640, height = 480, frequency = 25174825
[0002.840] Best mode Width = 1920, Height = 1080, freq = 148351648
[0002.848] tmds-config node not found
[0002.852] pmc_set_io_pad_voltage: Error -2 retrieving platform-io-pad-voltagepropsetting 'avdd-io-hdmi-dp' regulator to 1050000 micro volts
[0002.867] setting 'vdd-1v8' regulator to 1800000 micro volts
[0002.874] could not find regulator
[0002.878] could not find regulator
[0002.881] could not find regulator
[0002.909] using default cmu settings
[0002.913] dc_hdmi_enable, starting HDMI initialisation
[0002.919] dc_hdmi_enable, HDMI initialisation complete
[0002.924] list and configure display window
[0002.933] display console init completed
[0002.944] subnode volume_up is not found !
[0002.948] subnode back is not found !
[0002.951] subnode volume_down is not found !
[0002.956] subnode menu is not found !
[0002.959] Gpio keyboard init success
[0003.003] found decompressor handler: lz4-legacy
[0003.018] decompressing blob (type 1)...
[0003.053] load_bmp_blob: panelresolution=1080 type=3
[0003.104] decompressor handler not found
[0003.107] load_firmware_blob: Firmware blob loaded, entries=2
[0003.113] se_aes_verify_sbk_clear: Error
[0003.117] bl_battery_charging: connected to external power supply
[0003.124] xusb is supported
[0003.130] error while finding nvidia,portmap
[0003.136] could not find regulator
[0003.639] xusb blob version 0 size 124416
[0003.643] firmware size 124416
[0003.648] Firmware timestamp: 0x5cd2a472, Version: 50.22 release
[0003.663] xhci0: 64 bytes context size, 32-bit DMA
[0003.703] usbus0: 5.0Gbps Super Speed USB v3.0
[0003.723] uhub0: <Nvidia XHCI root HUB, class 9/0, rev 3.00/1.00, addr 1> on usbus0
[0004.373] uhub0: 9 ports with 9 removable, self powered
[0005.373] failed to get HID devices
[0005.376] failed to init xhci or no usb device attached
[0005.386] device_query_partition_size: failed to open partition sd0:MSC !
[0005.393] MSC Partition not found
[0005.399] device_query_partition_size: failed to open partition sd0:USP !
[0005.406] USP partition read failed!
[0005.410] blob_init: blob-partition USP header read failed
[0005.415] android_boot Unable to update recovery partition
[0005.421] kfs_getpartname: name = LNX
[0005.424] Loading kernel from LNX
[0005.484] Verifying boot image in OdmNonSecureSBK mode
[0005.528] kernel load address: 0x80080000, size: 482032 bytes
[0005.533] ramdisk load address: 0x84100000, size: 0 bytes
[0005.539] load kernel from storage
[0005.551] decompressor handler not found
[0005.608] Successfully loaded kernel and ramdisk images
[0005.614] load_bmp_blob: panelresolution=1080 type=3
[0006.109] display bmp image done
[0006.112] NCK carveout not present
[0006.115] Skipping dts_overrides
[0006.118] NCK carveout not present
[0006.122] shim_invoke: No NCT, Calling dts updates
[0006.133] Find /i2c@7000c000's alias i2c0
[0006.137] get eeprom at 1-a0, size 256, type 0
[0006.146] Find /i2c@7000c500's alias i2c2
[0006.150] get eeprom at 3-a0, size 256, type 0
[0006.154] get eeprom at 3-ae, size 256, type 0
[0006.158] pm_ids_update: Updating 1,a0, size 256, type 0
[0006.164] I2C slave not started
[0006.167] I2C write failed
[0006.169] Writing offset failed
[0006.172] eeprom_init: EEPROM read failed
[0006.176] pm_ids_update: eeprom init failed
[0006.180] pm_ids_update: Updating 3,a0, size 256, type 0
[0006.211] pm_ids_update: The pm board id is 3448-0000-200
[0006.217] Adding plugin-manager/ids/3448-0000-200=/i2c@7000c500:module@0x50
[0006.225] pm_ids_update: pm id update successful
[0006.229] pm_ids_update: Updating 3,ae, size 256, type 0
[0006.259] pm_ids_update: The pm board id is 3449-0000-200
[0006.266] Adding plugin-manager/ids/3449-0000-200=/i2c@7000c500:module@0x57
[0006.273] pm_ids_update: pm id update successful
[0006.304] eeprom_get_mac: EEPROM invalid MAC address (all 0xff)
[0006.310] shim_eeprom_update_mac:267: Failed to update 0 MAC address in DTB
[0006.318] eeprom_get_mac: EEPROM invalid MAC address (all 0xff)
[0006.324] shim_eeprom_update_mac:267: Failed to update 1 MAC address in DTB
[0006.332] updating /chosen/nvidia,ethernet-mac node 00:04:4b:e6:46:15
[0006.339] Plugin Manager: Parse ODM data 0x00094000
[0006.349] shim_cmdline_install: /chosen/bootargs: root=/dev/mmcblk0p1 rw rootwait rootfstype=ext4 console=ttyS0,115200n8 console=tty0 fbcon=map:0 net.ifnames=0
[0006.363] Add serial number:14224190888210008301 as DT property
[0006.373] "bpmp" doesn't exist, creating
[0006.378] Updated bpmp info to DTB
[0006.383] Updated initrd info to DTB
[0006.387] "proc-board" doesn't exist, creating
[0006.392] Updated board info to DTB
[0006.395] "pmu-board" doesn't exist, creating
[0006.401] Updated board info to DTB
[0006.404] "display-board" doesn't exist, creating
[0006.410] Updated board info to DTB
[0006.413] "reset" doesn't exist, creating
[0006.418] Updated reset info to DTB
[0006.421] Cmdline: tegraid=21.1.2.0.0 ddr_die=4096M@2048M section=512M memtype=0 vpr_resize usb_port_owner_info=0 lane_owner_info=0 emc_max_dvfs=0 touch_id=0@63 video=tegrafb no_console_suspend=1 console=ttyS0,115200n8 debug_uartport=lsport,2 earlyprintk=uart8250-32bit,0x70006000 maxcpus=4 usbcore.old_scheme_first=1 lp0_vec=0x1000@0xff780000 core_edp_mv=1075 core_edp_ma=4000 tegra_fbmem=0x800000@0x92cb7000 is_hdmi_initialised=1
[0006.460] DTB cmdline: root=/dev/mmcblk0p1 rw rootwait rootfstype=ext4 console=ttyS0,115200n8 console=tty0 fbcon=map:0 net.ifnames=0
[0006.472] boot image cmdline: root=/dev/mmcblk0p1 rw rootwait rootfstype=ext4 console=ttyS0,115200n8 console=tty0 fbcon=map:0 net.ifnames=0
[0006.485] Updated bootarg info to DTB
[0006.489] Adding uuid 00000001644476401c00000015018300 to DT
[0006.495] Adding eks info 0 to DT
[0006.500] WARNING: Failed to pass NS DRAM ranges to TOS, err: -7
[0006.506] Updated memory info to DTB
[0006.512] Updated system-lp0-disable info to DTB
[0006.520] set vdd_core voltage to 1075 mv
[0006.524] setting 'vdd-core' regulator to 1075000 micro volts
[0006.543] could not find regulator
[0006.547] Found secure-pmc; disable BPMP


U-Boot 2016.07-gd917e08cec (Aug 12 2019 - 21:10:20 -0700)

TEGRA210
Model: NVIDIA P3450-Porg
Board: NVIDIA P3450-PORG
DRAM:  4 GiB
MMC:   Tegra SD/MMC: 0, Tegra SD/MMC: 1
Using default environment

In:    serial
Out:   serial
Err:   serial
Net:   No ethernet found.
Hit any key to stop autoboot:  0
switch to partitions #0, OK
mmc1 is current device
Scanning mmc 1:1...
Found /boot/extlinux/extlinux.conf
Retrieving file: /boot/extlinux/extlinux.conf
733 bytes read in 121 ms (5.9 KiB/s)
L4T boot options
1:      primary kernel
Enter choice: 1:        primary kernel
Retrieving file: /boot/initrd
5562384 bytes read in 347 ms (15.3 MiB/s)
Retrieving file: /boot/Image
33980424 bytes read in 1529 ms (21.2 MiB/s)
append: tegraid=21.1.2.0.0 ddr_die=4096M@2048M section=512M memtype=0 vpr_resize usb_port_owner_info=0 lane_owner_info=0 emc_max_dvfs=0 touch_id=0@63 video=tegrafb no_console_suspend=1 console=ttyS0,115200n8 debug_uartport=lsport,2 earlyprintk=uart8250-32bit,0x70006000 maxcpus=4 usbcore.old_scheme_first=1 lp0_vec=0x1000@0xff780000 core_edp_mv=1075 core_edp_ma=4000 tegra_fbmem=0x800000@0x92cb7000 is_hdmi_initialised=1  root=/dev/mmcblk0p1 rw rootwait rootfstype=ext4 console=ttyS0,115200n8 console=tty0 fbcon=map:0 net.ifnames=0    root=/dev/mmcblk0p1 rw rootwait rootfstype=ext4 console=ttyS0,115200n8 console=tty0 fbcon=map:0 net.ifnames=0 quiet
## Flattened Device Tree blob at 83100000
   Booting using the fdt blob at 0x83100000
   reserving fdt memory region: addr=80000000 size=20000
   Using Device Tree in place at 0000000083100000, end 0000000083177080

Starting kernel ...

<hit enter to activate fiq debugger>
[    1.091864] tegradc tegradc.1: dpd enable lookup fail:-19
[    1.253865] imx219 6-0010: imx219_board_setup: error during i2c read probe (-121)
[    1.253896] imx219 6-0010: board setup failed
[    2.836015] cgroup: cgroup2: unknown option "nsdelegate"
[    4.247988] using random self ethernet address
[    4.254157] using random host ethernet address
[    4.331148] using random self ethernet address
[    4.337255] using random host ethernet address
[    4.411638] random: crng init done
[    4.416551] random: 7 urandom warning(s) missed due to ratelimiting

Ubuntu 18.04.2 LTS pesi-desktop ttyS0

pesi-desktop login: [    9.480075] Host read timeout at address 5458045c

Ubuntu 18.04.2 LTS pesi-desktop ttyS0

pesi-desktop login: pesi

Hi,

One possible case is that you didn’t configure the LOCALVERSION during kernel image build.
A pre-built image from jetpack would have “-tegra” suffix. You can check it by using command “uname -r”. However, the tutorial in your guideline seems not configure LOCALVERSION.

The reason that it may cause monitor blank is due to missing external modules (probably nvgpu driver).

There are some kernel modules loaded up after boot up and these files are under /lib/modules/<uname -r>.

For example,

~/nvidia/nvidia_sdk/JetPack_4.2.1_Linux_GA_P2888/Linux_for_Tegra/rootfs/lib/modules$ ls
4.9.140-tegra

Thus, after boot up, system should try to load all modules from these folder but it faild on your board because “unamer -r” indicates system to find “4.9.140” instead of “4.9.140-tegra”.

You could try to add below during kernel build.
export CROSS_COMPILE=<cross_prefix> export LOCALVERSION=-tegra

Hi,NV Team

The problem solves.

Screen works!Kernel works!

Thanks for your help :)

make ARCH=arm64 O=KERNEL OUT CROSS_COMPILE={CROSS_COMPILE} LOCAL VERSION=-tegra

WayneWWW why LOCALVERSION can cause a kernel breakdown? https://unix.stackexchange.com/questions/194129/linux-kernel-version-suffix-config-localversion

A kernel looks for its modules in the directory tree at:

/lib/modules/$(uname -r)/

“uname -r” starts with the kernel base version, e.g., “4.9.140”, and appends the suffix via the CONFIG_LOCALVERSION. If this is the config:

CONFIG_LOCALVERSION="-tegra"

…then “uname -r” becomes “4.9.140-tegra”.

Absolutely every single module feature will fail for this example if the module is not somewhere under “/lib/modules/4.9.140-tegra/”. This location is embedded into the base kernel Image and is not configurable after compile.

In brief, nvgpu driver is under /lib/modules/4.9.140-tegra/.
Missing “-tegra” during kernel compilation would cause system to search another non-existing path so that nvgpu driver is not loaded.