Built-in display glitches, HDMI external display is fine on Ubuntu 19.10 with GTX 1650

Hello good people,

I have a unique problem for which I found no other info online, where my built-in display glitches and is unusable, while my external display is completely fine. I uploaded a short demonstration here https://imgur.com/a/kkNy6Zj.

The laptop is a Dell XPS 15 7590 with GTX 1650 with FullHD IPS display (not the OLED version). It came with Windows preinstalled and the screen was fine then so I suppose it is not a hardware issue. This issue is the same in Live USB with both Ubuntu 19.10 and 18.4.03 LTS Driver is nvidia-driver-435 installed via Software & Updates app. BIOS is updated (through Windows) to 1.3.3, SecureBoot disabled and set to AHCI mode. The DM currently running is LightDM I don’t actually know why anymore.

Ubuntu 19.10 Live USB without safe graphics mode is pretty much the same as my setup. With safe graphics it successfully boots and the flickering stops! However my external monitor does not work and is not even detected. When I try to boot my system with nomodeset (written during boot to the grub line after “quiet splash”), only a black screen shows and I cant start LightDM with tty terminal.

I have tried a lot of things past few days, but I don’t remember what things I did and what I reverted, so I hope the included log clears it up. What I am pretty sure didn’t work is:

  • nvidia-driver-440 with apt install from graphics-drivers PPA
  • nvidia-driver-430 from Software & Update app
  • nouveau drivers from Software & Update app
  • installing newest PopOS (same screen flickering)

I tried to configure the displays with “nvidia-settings”, but in the X Server Display Configuration when I click the Advanced button it shows no new options.

The GPU is apparently working fine though, I can run “nvidia-settings” and “nvidia-smi” no problem and even Tensorflow can run on the GPU.

Thank you for reading, if I should add more info, please let me know.
nvidia-bug-report.log.gz (265 KB)

Please check if this is a problem with the intel or nvidia gpu by switching to intel:
sudo prime-select intel
and reboot.

I followed your instructions but the issue persisted, both displays behave the same way.

“sudo prime-select query” now prints “intel”

Ok, then this has nothing to do with the nvidia gpu since it’s off now and only the integrated gpu is used. I don’t see any i915 related errors in the logs either so you should rather reinstall Windows + intel gpu driver to really rule out a hw issue.

Thank you, I will try the reinstall.

Hey, I reinstalled Windows 10 as suggested and both displays work flawlessly, so it is not a hardware issue. Any ideas what to try next? Would you maybe suggest another Linux distribution?

Since the problem is with the intel gpu, you could try a different kernel, just by booting a live image, e.g. of older ubuntu releases with 4.15, 4.18 or 5.0 kernels to check if this a regression or general bug.

I checked these Linux distros:

  1. Ubuntu 18.4.3
  2. Ubuntu 19.4
  3. Ubuntu 19.10
  4. Pop!_OS 19.10
  5. Linux Manjaro 18.0
  6. Fedora 31

None of these work unfortunately, so probably a general bug.

If this is an intel GPU issue I should probably head to an intel support forum, any suggestions where to?

Thanks a lot

You would have to open a bug report on the kernel bugzilla, I presume.
Two things you should check beforehand:

  1. Check your system memory by running some rounds of memtest86
  2. try kernel parameter i915.enable_psr=0

OK, so the kernel parameter i915.enable_psr=0 didn’t help. I also tried i915.force_probe=1 and it didn’t help either.

I did just one round of memtest86 and no errors. Will do a few more rounds overnight.

Maybe this is a reprise of and old bug, please check if it works when using kernel parameter
intel_idle.max_cstate=1
also check if a bios update is available.

intel_idle.max_cstate=1 seemed to work on a Live Ubuntu, I was super excited, but I tried to boot a second time and it didn’t work anymore, nor a third time.

BIOS is the newest available - Dell BIOS 1.3.3.

Hi, I have the exact same issue on the exact same machine XPS 7590 2019 and same distro Ubuntu 19.10 5.3.0-23-generic

I was able to reduce the flickering significantly by using the following kernel parameters

i915.enable_psr=0
intel_idle.max_cstate=0

However, the remaining flickering are driving me mad, so if anyone figures out the solution please update the thread :)

I also have this line in dmesg:

[drm:intel_cpu_fifo_underrun_irq_handler [i915]] ERROR CPU pipe A FIFO underrun

I looked it up and it seems to have been related to flickering issues in the past. Do you have the same message ?

Does disabling cstate control in bios (if possible) help? Remove the kernel parameter when trying that.

Not really no…

As it does not occurs to the HDMI connected screens, could that be an issue with the built in screen driver ?

Like said, it’s an intel gpu bug, the hdmi is connected to the nvidia gpu, thus works.

Disabling cstates in BIOS did not help :( I also tried disabling Intel SpeedStep and Intel TurboBoost but it did not help either.

Then you should revert to Dell, seems to be a model specific issue with the built-in panel. Also open a bug report on kernel bugzilla regarding the i915 driver.

I’m having the same issue with a Dell Precision 5530.

                                              system         Precision 5530 (087D)

/0/3e memory 32GiB System Memory
/0/4a processor Intel® Core™ i9-8950HK CPU @ 2.90GHz
/0/100/1/0 display GP107GLM [Quadro P2000 Mobile]
/0/100/2 display UHD Graphics 630 (Mobile)

$ prime-select query
nvidia

$ lspci -k

00:02.0 VGA compatible controller: Intel Corporation UHD Graphics 630 (Mobile)
DeviceName: Onboard IGD
Subsystem: Dell UHD Graphics 630 (Mobile)
Kernel driver in use: i915
Kernel modules: i915
01:00.0 3D controller: NVIDIA Corporation GP107GLM [Quadro P2000 Mobile] (rev a1)
Subsystem: Dell GP107GLM [Quadro P2000 Mobile]
Kernel driver in use: nvidia
Kernel modules: nvidiafb, nouveau, nvidia_drm, nvidia

I suspect that generix is correct that it is an intel issue, but figured I should add my details anyway since there’s multiple models involved.

Oh yeah, definitely. I didn’t have much time solving this issue (running Windows atm), but I will definitely post this to the Intel forum, thank you. Let me know if you solve it somehow!