Burnt fuses now secure-boot does not complete. (PTM Debugger). SOLVED

I am doing some secure boot testing on kernel 3.10.96 on jetson-tk1 (and 3.10.40 on TK1) and my exact kernel and DTB were working fine until I burnt fuses for some testing. I did not burn the PKC hash and did not set the production fuse so I can still flash normally without signing images.

Edit: I have now burned my PKC and production mode to 01. See post #9

SOLVED SEE POST 19

Please NVIDIA devs help to solve this error or give input on what the cause is onn kernel 3.10.96: 3.10.40 works just fine on TK1. I will post my kernel dmesg later on my TK1 that has no fuses burnt.

Here is where my kernel halts:

[    8.634065] device-mapper: ioctl: 4.24.0-ioctl (2013-01-15) initialised: dm-devel@redhat.com
[    8.642831] sdhci: Secure Digital Host Controller Interface driver
[    8.649023] sdhci: Copyright(c) Pierre Ossman
[    8.653388] sdhci-pltfm: SDHCI platform and OF driver helper
[    8.659453] mmc0 using board files instead of DT
[    8.664121] sdhci-tegra sdhci-tegra.3: Parent select= pll_p rate=408000000
[    8.671033] sdhci-tegra sdhci-tegra.3: Parent select= pll_c rate=600000000
[    8.678448] sdhci-tegra sdhci-tegra.3: Speedo value 2362
[    8.683783] sdhci-tegra sdhci-tegra.3: Tuning constraints: nom_mv 1150, boot_mv 1150, min_or_mv 1150
[    8.693466] mmc0: no vqmmc regulator found
[    8.697595] mmc0: no vmmc regulator found
[    8.701616] mmc0: Invalid maximum block size, assuming 512 bytes
[    8.731973] mmc0: SDHCI controller on sdhci-tegra.3 [sdhci-tegra.3] using ADMA
[    8.740300] mmc1 using board files instead of DT
[    8.745038] sdhci-tegra sdhci-tegra.2: Parent select= pll_p rate=408000000
[    8.751025] tegra_cec tegra_cec: tegra_cec_init Done.
[    8.757058] sdhci-tegra sdhci-tegra.2: Parent select= pll_c rate=600000000
[    8.764411] sdhci-tegra sdhci-tegra.2: vddio_sd_slot regulator not found: -517. Assuming vddio_sd_slot is not required.
[    8.775225] sdhci-tegra sdhci-tegra.2: Speedo value 2362
[    8.780580] sdhci-tegra sdhci-tegra.2: Tuning constraints: nom_mv 1150, boot_mv 1150, min_or_mv 1150
[    8.789846] mmc1: no vqmmc regulator found
[    8.794025] mmc1: no vmmc regulator found
[    8.798101] mmc1: Invalid maximum block size, assuming 512 bytes
[    8.827966] mmc1: SDHCI controller on sdhci-tegra.2 [sdhci-tegra.2] using ADMA
[    8.835242] mmc0: BKOPS_EN bit is not set
[    8.835435] gpio wake56 for gpio=170
[    8.835733] mmc2 using board files instead of DT
[    8.835749] sdhci-tegra sdhci-tegra.0: Parent select= pll_p rate=408000000
[    8.835761] sdhci-tegra sdhci-tegra.0: Parent select= pll_c rate=600000000
[    8.836298] sdhci-tegra sdhci-tegra.0: Speedo value 2362
[    8.836307] sdhci-tegra sdhci-tegra.0: Tuning constraints: nom_mv 1150, boot_mv 1150, min_or_mv 1150
[    8.875857] mmc2: no vqmmc regulator found
[    8.878690] mmc0: new high speed DDR MMC card at address 0001
[    8.879056] mmcblk mmc0:0001: Card claimed for testing.
[    8.879355] mmcblk0: mmc0:0001 SEM16G 14.6 GiB 
[    8.879627] mmcblk0rpmb: mmc0:0001 SEM16G partition 3 4.00 MiB
[    8.882126]  mmcblk0: p1 p2 p3 p4 p5 p6 p7 p8 p9 p10 p11
[    8.906574] mmc2: no vmmc regulator found
[    8.910606] mmc2: Invalid maximum block size, assuming 512 bytes
[    8.940970] mmc2: SDHCI controller on sdhci-tegra.0 [sdhci-tegra.0] using ADMA
[    8.950139] tegra-se tegra12-se: tegra_se_probe: complete
[    8.955950] hidraw: raw HID events driver (C) Jiri Kosina
[    8.963625] usbcore: registered new interface driver usbhid
[    8.969209] usbhid: USB HID core driver
[    8.973175] tegra_bootloader_debug: Created tegra_bootloader directory
[    8.979724] tegra_bootloader_debug: Created sysfs interface tegra_bootloader_verify_regs in tegra_bootloader directory
[    8.990430] tegra_bootloader_debug: Created sysfs interface tegra_bootloader_prof in tegra_bootloader directory

My current fuse/strap configs for TK1:

chip uid from BR is: 0x34001001740970420800000006fc0400
rcm version 0X400001
Skipping BoardID read at miniloader level
System Information:
   chip name: unknown
   chip id: 0x40 major: 1 minor: 1
   chip sku: 0x81
   chip uid: 0x00000001740970420800000006fc0400
   macrovision: disabled
   hdcp: disabled
   jtag: disabled
   sbk burned: true
   board id: 375
   warranty fuse: 0
   dk burned: false
   boot device: emmc
   operating mode: 3
   device config strap: 0
   device config fuse: 0
   sdram config strap: 0

(Have not attempted burning fuses on TX1 yet due to this kernel halt)

Here is where the kernel passes on non-fuse burn tegra:

[    7.923260] tegra_bootloader_debug: Created tegra_bootloader directory
[    7.923281] tegra_bootloader_debug: Created sysfs interface tegra_bootloader_verify_regs in tegra_bootloader directory
[    7.923300] tegra_bootloader_debug: Created sysfs interface tegra_bootloader_prof in tegra_bootloader directory
[    7.923948] ptm ptm: ETB is initialized.
[    7.924129] ptm ptm: PTM driver initialized.
[    7.928106] ptm ptm: Failed to start the PTM device

ETB is initialized.

deleted post - full description of issue added to post #9

deleted double post

Complete fuses on 3.10.40 TK1:

device_key = 0xaabbccdd
driver
ignore_dev_sel_straps = 0x00000000
jtag_disable = 0x00000001
modalias = platform:tegra-fuse
odm_lock = 0x00000000
odm_production_mode = 0x00000000
odm_reserved = 0x0000000012345678123456781234567898765432123456781234567812345678
pkc_disable = 0x00000001
power
public_key = 0x0000000000000000000000000000000000000000000000000000000000000000
sec_boot_dev_cfg = 0x00000000
sec_boot_dev_sel = 0x00000000
secure_boot_key = 0x89abcdef0123456789abcdef01234567
subsystem
sw_reserved = 0x00000000
uevent =

DRIVER=tegra-fuse
OF_NAME=efuse
OF_FULLNAME=/efuse@7000f800
OF_COMPATIBLE_0=nvidia,tegra124-efuse
OF_COMPATIBLE_N=1
MODALIAS=of:NefuseT<NULL>Cnvidia,tegra124-efuse

vp8_enable = 0x00000001

I have flashed same images on same devices, One TK1 device burnt fuses one not. Device with no burnt fuses starts correctly same flash.cfg same bootloader same kernel same dtb, now on exact same system with fuses burnt kernel halts same place every time. How can we implement secure when same kernel dtb configs etc halt kernel:

[    9.981172] tegra_bootloader_debug: Created tegra_bootloader directory
[    9.987834] tegra_bootloader_debug: Created sysfs interface tegra_bootloader_verify_regs in tegra_bootloader directory
[    9.998701] tegra_bootloader_debug: Created sysfs interface tegra_bootloader_prof in tegra_bootloader directory

linux4all,
First of all, I’d like to confirm what you were trying to accomplish is to enable secure boot for your development, correct?

Like to check if you follow secure boot package document (readme)? If you did, we can work it out which stage you were having issue. Thanks.

Thanks for the reply chuang. Ive studied the boot flow process in the webinar. Let me put together a detailed response later today. I think since I am using kernel 3.10.96 on Jetson TK1 the kernel does not set boardid or pmu_boardid so when kernel brings up boardfiles for specific hardware it halts not finding the correct ID’s. Now with this said I can boot non-secure unsigned bootloader and kernel 3.10.96 no problem. Let me add I am using fastboot not u-boot on Android.

Okay I spent the whole weekend diving into the secure boot process on Android. I can successfully boot wx_na_wf 5.1 (nvidia 3.1.1) signed on jetson-tk1 no issues. I have use an NCT_jetson.txt with the following information to properly set boardid, pmu_boardid and board_panelid.

<name:serial_number;     idx:0;  tag:0x80; data:042071508196100002cf>
<name:cm_id;             idx:3;  tag:0x20; data:0x0000>
<name:lbh_id;            idx:4;  tag:0x20; data:0x0000>
<name:factory_mode;      idx:5;  tag:0x40; data:0>
<name:ramdump;           idx:6;  tag:0x40; data:0>
<name:board_info;        idx:8;  tag:0x4A; data:375; data:0; data:0;data:1734; data:0; data:0; data:1797; data:0; data:0 >
//typedef struct
{
    unsigned int proc_board_id; 375
    unsigned int proc_sku;
    unsigned int proc_fab;
    unsigned int pmu_board_id; 1734 as3722 pmu
    unsigned int pmu_sku;
    unsigned int pmu_fab;
    unsigned int display_board_id; 1797 1920x1200 generic panisonic panel
    unsigned int display_sku;
    unsigned int display_fab;
} nct_board_info_type;

With the above info on Android 5.1 I have to change the boardid to 374 due to the corresponding nvidia bootloader not allowing boardid 375 yet the bootloader in 7.0 allows 375.

I am using the exact device tree and sources for compiling android for shieldtablet tk1 no modifications.

My kernel 3.10.96 has been properly setup to boot on Android 7.0 with zero issues i have extensively tested my kernel over the past year and have had zero issues up until booting secure with signed bootloaders.

My flash.cfg is ga_android_fastboot_nvtboot_dtb_emmc_full_signed.cfg zero modifications except for dtb and clear eks.dat.

I have signed all of my bootloaders with the following command:

./nvsecuretool --pkc ~/Key_File --chip 0x40 --blob blob.bin --bct PM375_Hynix_2GB_H5TC4G63AFR_RDA_924MHz.cfg PM375_Hynix_2GB_H5TC4G63AFR_RDA_924MHz_signed.bct --bl bootloader.bin bootloader_signed.bin --cfg ga_android_fastboot_nvtboot_dtb_emmc_full_signed.cfg --blocksize 32

My flash command is like so:

sudo ./nvflash --boardid 0x177 0x00 0x03 --bct PM375_Hynix_2GB_H5TC4G63AFR_RDA_924MHz_signed.bct --setbct --configfile ga_android_fastboot_nvtboot_dtb_emmc_full_signed.cfg  --create --bl bootloader_signed.bin --blob blob.bin --nct NCT_ardbeg.txt --odmdata 0x6009C000 --go

Now over the weekend I messed around with ODMDATA for a few boots and when I received the kernel error above using --odmdata 0x80098000 i received the following bootloader display but no command access to continue.

I am also linking a full bootflow kernel log from early bootflow until kernel decompression and early stage boot until the halt at “tegra_bootloader_debug: Created tegra_bootloader directory”

FULL LOG: https://pastebin.com/Ejx19Rfh

I did just notice I am missing one dt-overide that MAY be my issue on jetson-tk1’s dts:

watchdog@60005100 {
		status = "disabled";
		nvidia,enable-on-init;
		nvidia,heartbeat-init = <120>;
		dt-override-status-odm-data = <0x80000000 0x80000000>;
	};

	soft_watchdog {
		compatible = "softdog-platform";
		status = "disabled";
		dt-override-status-odm-data = <0x80000000 0x00000000>;
	};

and also for uart-over-sd:

sdmmc3_cmd_pa7_uart_sd {
				nvidia,pins = "sdmmc3_cmd_pa7";
				nvidia,function = "uarta";
				nvidia,enable-input = <TEGRA_PIN_ENABLE>;
				nvidia,pull = <TEGRA_PIN_PULL_NONE>;
				nvidia,tristate = <TEGRA_PIN_DISABLE>;
				status = "disabled";
				dt-override-status-odm-data = <0x00038000 0x00028000>;
			};

			sdmmc3_dat1_pb6_uart_sd {
				nvidia,pins = "sdmmc3_dat1_pb6";
				nvidia,function = "uarta";
				nvidia,enable-input = <TEGRA_PIN_DISABLE>;
				nvidia,pull = <TEGRA_PIN_PULL_NONE>;
				nvidia,tristate = <TEGRA_PIN_DISABLE>;
				status = "disabled";
				dt-override-status-odm-data = <0x00038000 0x00028000>;
      };

And UART console:

serial@70006000 {
		compatible = "nvidia,tegra20-uart";
		console-port;
		dt-override-status-odm-data = <0x00038000 0x00028000>;
	};

	serial@70006040 {
		compatible = "nvidia,tegra114-hsuart";
		status = "okay";
	};

	serial@70006200 {
		compatible = "nvidia,tegra114-hsuart";
		status = "okay";
	};

	serial@70006300 {
		compatible = "nvidia,tegra20-uart", "nvidia,tegra114-hsuart";
		console-port;
		sqa-automation-port;
		dt-override-status-odm-data = <0x00038000 0x00018000>;
	};

double post deleted

Okay on my 2nd jetson-tk1 here is where the bootflow continues with non-secure no burnt fuses:

I hope this is enough information to debug this issue. Thanks for any help.

6.933655] usbhid: USB HID core driver
[    6.933838] tegra_bootloader_debug: Created tegra_bootloader directory
[    6.933858] tegra_bootloader_debug: Created sysfs interface tegra_bootloader_verify_regs in tegra_bootloader directory
[    6.933878] tegra_bootloader_debug: Created sysfs interface tegra_bootloader_prof in tegra_bootloader directory
[    6.934553] ptm ptm: ETB is initialized.
[    6.934735] ptm ptm: PTM driver initialized.
[    6.938785] ptm ptm: Failed to start the PTM device
[    6.939440] soctherm: tz:0 not found, skip thresh prog
[    6.939447] soctherm: tz:1 not found, skip thresh prog
[    6.939453] soctherm: tz:2 not found, skip thresh prog
[    6.939457] soctherm: tz:3 not found, skip thresh prog
[    6.940607] thermal thermal_zone1: Registering thermal zone thermal_zone1 for type CPU-therm
[    6.941125] thermal thermal_zone2: Registering thermal zone thermal_zone2 for type GPU-therm
[    6.941425] thermal thermal_zone3: Registering thermal zone thermal_zone3 for type MEM-therm
[    6.941710] thermal thermal_zone4: Registering thermal zone thermal_zone4 for type PLL-therm
[    6.942397] tegra_throttle : init passed
[    6.944568] Tegra cpuquiet initialized: disabled
[    6.944761] cpu-tegra: init EDP limit: 2116 MHz
[    6.945766] ------------[ cut here ]------------
[    6.945783] WARNING: at /home/jetson/nvidia/shield/kernel/drivers/platform/tegra/gpu-edp.c:211 tegra_gpu_edp_probe+0xb0/0x4e4()
[    6.945787] missing required parameter: nvidia,edp_limit
[    6.945794] Modules linked in:
[    6.945804] CPU: 2 PID: 1 Comm: swapper/0 Not tainted 3.10.96+ #3
[    6.945833] [<c0017008>] (unwind_backtrace+0x0/0x13c) from [<c00131e4>] (show_stack+0x18/0x1c)
[    6.945851] [<c00131e4>] (show_stack+0x18/0x1c) from [<c003c7d4>] (warn_slowpath_common+0x5c/0x74)
[    6.945866] [<c003c7d4>] (warn_slowpath_common+0x5c/0x74) from [<c003c824>] (warn_slowpath_fmt+0x38/0x48)
[    6.945882] [<c003c824>] (warn_slowpath_fmt+0x38/0x48) from [<c11ecec0>] (tegra_gpu_edp_probe+0xb0/0x4e4)
[    6.945901] [<c11ecec0>] (tegra_gpu_edp_probe+0xb0/0x4e4) from [<c04ae544>] (platform_drv_probe+0x38/0x5c)
[    6.945918] [<c04ae544>] (platform_drv_probe+0x38/0x5c) from [<c04ac34c>] (driver_probe_device+0x144/0x3a8)
[    6.945933] [<c04ac34c>] (driver_probe_device+0x144/0x3a8) from [<c04ac690>] (__driver_attach+0x94/0x98)
[    6.945948] [<c04ac690>] (__driver_attach+0x94/0x98) from [<c04aa414>] (bus_for_each_dev+0x68/0x9c)
[    6.945962] [<c04aa414>] (bus_for_each_dev+0x68/0x9c) from [<c04ab8d0>] (bus_add_driver+0x1dc/0x280)
[    6.945977] [<c04ab8d0>] (bus_add_driver+0x1dc/0x280) from [<c04ad1f0>] (driver_register+0x80/0x148)
[    6.945992] [<c04ad1f0>] (driver_register+0x80/0x148) from [<c04ae598>] (platform_driver_probe+0x20/0xa8)
[    6.946006] [<c04ae598>] (platform_driver_probe+0x20/0xa8) from [<c00087c0>] (do_one_initcall+0xdc/0x188)
[    6.946019] [<c00087c0>] (do_one_initcall+0xdc/0x188) from [<c11a1bec>] (kernel_init_freeable+0x13c/0x1dc)
[    6.946034] [<c11a1bec>] (kernel_init_freeable+0x13c/0x1dc) from [<c0c8eb50>] (kernel_init+0x14/0x160)
[    6.946048] [<c0c8eb50>] (kernel_init+0x14/0x160) from [<c000f1a0>] (ret_from_fork+0x14/0x20)
[    6.946072] ---[ end trace 86a2ed4410403600 ]---
[    6.946075] ------------[ cut here ]------------
[    6.946086] WARNING: at /home/jetson/nvidia/shield/kernel/drivers/platform/tegra/gpu-edp.c:246 tegra_gpu_edp_probe+0x4cc/0x4e4()
[    6.946090] GPU EDP management initialization failed
[    6.946097] Modules linked in:
[    6.946105] CPU: 2 PID: 1 Comm: swapper/0 Tainted: G        W    3.10.96+ #3
[    6.946121] [<c0017008>] (unwind_backtrace+0x0/0x13c) from [<c00131e4>] (show_stack+0x18/0x1c)
[    6.946137] [<c00131e4>] (show_stack+0x18/0x1c) from [<c003c7d4>] (warn_slowpath_common+0x5c/0x74)
[    6.946151] [<c003c7d4>] (warn_slowpath_common+0x5c/0x74) from [<c003c824>] (warn_slowpath_fmt+0x38/0x48)
[    6.946166] [<c003c824>] (warn_slowpath_fmt+0x38/0x48) from [<c11ed2dc>] (tegra_gpu_edp_probe+0x4cc/0x4e4)
[    6.946182] [<c11ed2dc>] (tegra_gpu_edp_probe+0x4cc/0x4e4) from [<c04ae544>] (platform_drv_probe+0x38/0x5c)
[    6.946197] [<c04ae544>] (platform_drv_probe+0x38/0x5c) from [<c04ac34c>] (driver_probe_device+0x144/0x3a8)
[    6.946212] [<c04ac34c>] (driver_probe_device+0x144/0x3a8) from [<c04ac690>] (__driver_attach+0x94/0x98)
[    6.946225] [<c04ac690>] (__driver_attach+0x94/0x98) from [<c04aa414>] (bus_for_each_dev+0x68/0x9c)
[    6.946238] [<c04aa414>] (bus_for_each_dev+0x68/0x9c) from [<c04ab8d0>] (bus_add_driver+0x1dc/0x280)
[    6.946252] [<c04ab8d0>] (bus_add_driver+0x1dc/0x280) from [<c04ad1f0>] (driver_register+0x80/0x148)
[    6.946266] [<c04ad1f0>] (driver_register+0x80/0x148) from [<c04ae598>] (platform_driver_probe+0x20/0xa8)
[    6.946278] [<c04ae598>] (platform_driver_probe+0x20/0xa8) from [<c00087c0>] (do_one_initcall+0xdc/0x188)
[    6.946290] [<c00087c0>] (do_one_initcall+0xdc/0x188) from [<c11a1bec>] (kernel_init_freeable+0x13c/0x1dc)
[    6.946302] [<c11a1bec>] (kernel_init_freeable+0x13c/0x1dc) from [<c0c8eb50>] (kernel_init+0x14/0x160)
[    6.946315] [<c0c8eb50>] (kernel_init+0x14/0x160) from [<c000f1a0>] (ret_from_fork+0x14/0x20)
[    6.946319] ---[ end trace 86a2ed4410403601 ]---
[    6.946338] tegra_gpu_edp: probe of gpu_edp.20 failed with error -61
[    6.964653] usbcore: registered new interface driver snd-usb-audio
[    6.971586] tegra_offload_platform probe successfull.
[    6.971591] succefully registered offload ops
[    6.972249] tegra30_avp_audio_platform_probe successful.
[    6.972291] tegra-snd-rt5639 tegra-snd-rt5639: Fail gpio_request AUDIO_LDO1
[    7.423146] tegra-snd-rt5639 tegra-snd-rt5639: ASoC: CODEC rt5639.0-001a not registered
[    7.423207] tegra-snd-rt5639 tegra-snd-rt5639: snd_soc_register_card failed (-517)
[    7.504025] sdhci-tegra sdhci-tegra.3: Found T2T coeffs data
[    7.509707] sdhci-tegra sdhci-tegra.3: 200MHz tap hole coeffs found
[    7.673709] platform tegra-snd-rt5639: Driver tegra-snd-rt5639 requests probe deferral
[    7.790988] **********Auto tuning windows*************
[    7.796232] WIN_ATTR legend: 0-BOUN_ST, 1-BOUN_END, 2-HOLE
[    7.801731] win[0]: 0(0) - 66(1)
[    7.804970] win[1]: 72(0) - 142(1)
[    7.808382] win[2]: 146(0) - 217(1)
[    7.811879] win[3]: 220(0) - 255(1)
[    7.815374] ***************************************
[    7.820267] ********tuning windows after inserting holes*****
[    7.826019] WIN_ATTR legend: 0-BOUN_ST, 1-BOUN_END, 2-HOLE
[    7.831511] win[0]:-3(0) - 37(2)
[    7.834748] win[1]:39(2) - 66(1)
[    7.837985] win[2]:72(0) - 112(2)
[    7.841308] win[3]:114(2) - 142(1)
[    7.844718] win[4]:146(0) - 187(2)
[    7.848128] win[5]:189(2) - 217(1)
[    7.851538] win[6]:220(0) - 255(1)
[    7.854953] ***********************************************
[    7.860533] **********Tuning values*********
[    7.864810] **estimated values**
[    7.868048] T2T_Vmax 54, T2T_Vmin 74, 1'st_hole_Vmax 50, UI_Vmax 92
[    7.874316] **Calculated values**
[    7.877640] T2T_Vmax 66, 1'st_hole_Vmax 38, UI_Vmax 75
[    7.882783] T2T_Vmin 66, 1'st_hole_Vmin 38, UI_Vmin 75
[    7.887925] ***********************************
[    7.892466] ***********final tuning windows**********
[    7.897523] win[0]: 12 - 30
[    7.900326] win[1]: 47 - 51
[    7.903129] win[2]: 87 - 100
[    7.906019] win[3]: 127 - 127
[    7.908994] win[4]: 161 - 169
[    7.911970] win[5]: 208 - 202
[    7.914946] win[6]: 235 - 240
[    7.917920] ********************************
[    7.922199] best tap win - (12-30), best tap value 21
[    7.927263] sdhci-tegra sdhci-tegra.3: sdhci_tegra_verify_best_tap: tuning freq 200000000hz, best tap 21
[    7.932889] tegra-i2c 7000c000.i2c: no acknowledge from address 0x1c
[    7.933022] rt5639 0-001c: Codec not ready yet: write failed: Retry 25
[    7.951203] mmc0: new HS200 MMC card at address 0001
[    7.956484] mmcblk mmc0:0001: Card claimed for testing.
[    7.961994] mmcblk0: mmc0:0001 SEM16G 14.6 GiB 
[    7.966769] mmcblk0rpmb: mmc0:0001 SEM16G partition 3 4.00 MiB
[    7.974799] Primary GPT is invalid, using alternate GPT.
[    7.980203]  mmcblk0: p1 p2 p3 p4 p5 p6 p7 p8 p9 p10 p11 p12 p13 p14 p15 p16 p17 p18 p19 p20 p21 p22 p23 p24 p25

Has to be this:

GPU EDP management initialization failed

missing required parameter: nvidia,edp_limit

Nope not GPU EDP. I added:

cpu_edp {
                nvidia,edp_limit = <14000>;
        };

        gpu_edp {
                nvidia,edp_limit = <11200>;
        };
};

to my dtsi and still hangs at:

[    9.167911] tegra_bootloader_debug: Created tegra_bootloader directory
[    9.174598] tegra_bootloader_debug: Created sysfs interface tegra_bootloader_verify_regs in tegra_bootloader directory
[    9.185407] tegra_bootloader_debug: Created sysfs interface tegra_bootloader_prof in tegra_bootloader directory

For some reason I am missing the initialization if the mmc tuning on secure boot:

[    7.790988] **********Auto tuning windows*************
[    7.796232] WIN_ATTR legend: 0-BOUN_ST, 1-BOUN_END, 2-HOLE
[    7.801731] win[0]: 0(0) - 66(1)
[    7.804970] win[1]: 72(0) - 142(1)
[    7.808382] win[2]: 146(0) - 217(1)
[    7.811879] win[3]: 220(0) - 255(1)
[    7.815374] ***************************************
[    7.820267] ********tuning windows after inserting holes*****
[    7.826019] WIN_ATTR legend: 0-BOUN_ST, 1-BOUN_END, 2-HOLE
[    7.831511] win[0]:-3(0) - 37(2)
[    7.834748] win[1]:39(2) - 66(1)
[    7.837985] win[2]:72(0) - 112(2)
[    7.841308] win[3]:114(2) - 142(1)
[    7.844718] win[4]:146(0) - 187(2)
[    7.848128] win[5]:189(2) - 217(1)
[    7.851538] win[6]:220(0) - 255(1)
[    7.854953] ***********************************************
[    7.860533] **********Tuning values*********
[    7.864810] **estimated values**
[    7.868048] T2T_Vmax 54, T2T_Vmin 74, 1'st_hole_Vmax 50, UI_Vmax 92
[    7.874316] **Calculated values**
[    7.877640] T2T_Vmax 66, 1'st_hole_Vmax 38, UI_Vmax 75
[    7.882783] T2T_Vmin 66, 1'st_hole_Vmin 38, UI_Vmin 75
[    7.887925] ***********************************
[    7.892466] ***********final tuning windows**********
[    7.897523] win[0]: 12 - 30
[    7.900326] win[1]: 47 - 51
[    7.903129] win[2]: 87 - 100
[    7.906019] win[3]: 127 - 127
[    7.908994] win[4]: 161 - 169
[    7.911970] win[5]: 208 - 202
[    7.914946] win[6]: 235 - 240
[    7.917920] ********************************
[    7.922199] best tap win - (12-30), best tap value 21
[    7.927263] sdhci-tegra sdhci-tegra.3: sdhci_tegra_verify_best_tap: tuning freq 200000000hz, best tap 21
[    7.932889] tegra-i2c 7000c000.i2c: no acknowledge from address 0x1c
[    7.933022] rt5639 0-001c: Codec not ready yet: write failed: Retry 25
[    7.951203] mmc0: new HS200 MMC card at address 0001
[    7.956484] mmcblk mmc0:0001: Card claimed for testing.
[    7.961994] mmcblk0: mmc0:0001 SEM16G 14.6 GiB 
[    7.966769] mmcblk0rpmb: mmc0:0001 SEM16G partition 3 4.00 MiB
[    7.974799] Primary GPT is invalid, using alternate GPT.
[    7.980203]  mmcblk0: p1 p2 p3 p4 p5 p6 p7 p8 p9 p10 p11 p12 p13 p14 p15 p16 p17 p18 p19 p20 p21 p22 p23 p24 p25

Okay i am getting close PTM:

ptm ptm: Failed to start the PTM device

* We need know:
         * 1. PFT 1.0 or PFT 1.1, and
         * 2. Security Extension is implemented or not, and
         * 3. privilege mode or user mode tracing required, and
         * 4. security or non-security state tracing
         * in order to set correct matching mode and state for this register.
         *
         * However using PTM_ACC_TYPE_PFT10_IGN_SECURITY will enable matching
         * all modes and states under PFT 1.0 and 1.1

Looks like PTM has to do with CORESIGHT secure and non-secure boot so this is most definitely my issue.

SOLVED. I had to disable the PTM Debugger now secure-boot on Android is functional and working :)

config TEGRA_PTM
	bool "Enable PTM debugger on Tegra"
	default n
	help
	  This option enables PTM debugger on Tegra. This driver is used
	  for tracking each branch instructions executed by processor. It
	  can save such tracking information to the ETB buffer, which can
	  be further parsed by a user space program to re-construct the
	  complete program flows.