CAM_I2C_SDA/CAM_I2C_SCL i2c issue

Hi Team,

I have connect ltc4266A IC in CAM_I2C_SDA/CAM_I2C_SCL line.
I have detect two address 0x20 and 0x30 in i2c no 7 when powered on this IC. but in data sheet mentioned only 3 i2c.

cimcon@cimcon:~$ i2cdetect -y -r 7
0 1 2 3 4 5 6 7 8 9 a b c d e f
00: – – – – – – – – – – – – –
10: – – – – – – – – – – – – – – – –
20: 20 – – – – – – – – – – – – – – –
30: 30 – – – – – – – – – – – – – – –
40: UU – – – – – – – – – – – – – – –
50: – – – – – – – – – – – – – – – –
60: – – – – – – – – – – – – – – – –
70: – – – – – – – –

I have change another bus frequency using below commands.
echo 50000 > /sys/bus/i2c/devices/i2c-2/bus_clk_rate
but this command is not working with i2c-7

Q1) How can changed frequency of i2c-7 bus?
Q2) How can access i2c-7. Have I enable something for that.?

regards,
Babbelal

hello babbelal.patel1,

are you using TX2 NX?
please check this topic to enable /dev/i2c-7 interface for EEPROM reading on TX2 NX.

I am using NVIDIA Jetson Nano Developer Kit - B01
https://www.electronicscomp.com/nvidia-jetson-nano-developer-kit-b01?gclid=EAIaIQobChMI59H267P78wIVwSMrCh2b7g3wEAQYASABEgLTPvD_BwE

Please let me know solution for that.

I am moving this topic to the correct category.

hello babbelal.patel1,

please check device tree configuration,
for example,
$L4T_Sources/r32.6.1/Linux_for_Tegra/source/public/hardware/nvidia/soc/t210/kernel-dts/tegra210-soc/tegra210-soc-base.dtsi

i2c7: i2c@546c0000 {
...
                        clock-frequency = <400000>;

Hello Team,

My question is : I am able to change i2c0/i2c/i2c2 frequency using below commands and I have seen frequency in oscilloscope analyzer.
echo 50000 > /sys/bus/i2c/devices/i2c-2/bus_clk_rate

But why I am not able to changes i2c7 frequency using above commands.
Fisrt please let me know, How can enable i2c-7 ?
regards,
Babbelal

hello babbelal.patel1,

do you have device connected to i2c7, is there any other software using this?
please refer to comment #6 to review the i2c7 definition in your device tree sources.
thanks

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.