I2c0 seems to be dead- Jetson Nano

I have i2c0 problem with Jetson Nano SOM.
I have made my own carrier board and have exposed i2c0 to to the connector for connecting some peripheral, in particular case the TCA6424A. I worked few weeks and everything was completely fine. I have measured 3.3V good shaped SCL and SDA. i2cdetect -y -r 0 worked also fine. Suddenly i2c0 became unresponsive, nothing, both SDA and SCL are just few mV above zero if a make a oscilloscope measurements (once again it was toggled during the boot before problem accrued). The really bad thing that “I killed” already three Jetson Nano(two from eval kit and one production), but the most important I cannot understand what is wrong…The only thing that I think was able to cause the Jetson i2c0 fail is that I connected my external PCB with TCA6424A while carrier board was under power(hot connection) in such case was it passable that the damage is by ESD…I was not implemented ESD protection on i2c0…but three boards, both sda, scl…seems to me very weak idea.
Please help me to understand what could be wrong.

The partial output as a respond to i2cdetect -y -r 0 is below.

Thanks for your help!

What’s the voltage level if leave I2C lines unconnected on your board? Did you try the module onto devkit carrier board and with default version software to confirm if I2C failed?

Hi Trumany,

If I leave the Jetson on a carrier board without connecting the expansion board the I2C SDA and SCL are 3.3V. The same situation if I connect Jetson on a devkit - no i2c0(i2cdetect -y -r 0 presents the output I shared earlier). For visualization I’m sharing simplified schematics of what is implemented in relation to the i2c0 bus.


There is no device on I2C0 in module. If it is normal voltage without expansion board, it shows no problem to module, you need to check the expansion design.

If so it is even more strange…I checking the i2c0 while no expansion board is connected. I also checked the module on a devkit platform. I got no i2c0.

What’s do you mean got no i2c0?

When I run i2cdetect -y -r 0 no component detected on the i2c0, the output on a terminal is very slow, each address updating once at about 10 sec…the output looks like below.(on eval kit)

What’s the BSP version? I just check my Nano with r32.5.1 don’t see the problem while run the detect command.

Hi Shane. You will no see any problem on good module. On my three modules everything was also fine till something happened that I can not understand and explain and then I asked Nvidia help. The only thing I did it is hot unplugging the expansion board. Even if it is not recommended to do, it should not be a reason for malfunction i2c0…I broke three modules like this…again I still not understand real reason for it…

The it looks like port damaged. There are ESD diodes (D39, D40) for SCL and SDA line, you can remove them to see if they are damaged by ESD and so cause I2C failure.

On the carrier board I developed I did not install the ESD protection on i2c bus and I have a problem with i2c functionality if install the module on my carrier board. Same problem appears to be on a dev kit carrier board if I move module there. It appears the damage is on module. My goal is to understand the event, as I have three modules like this…it appears that three modules were damaged by hot plugin of the expansion board. This idea of ESD damage seems to me very weak, but I have no others.

The port is easy damaged by ESD, that’s why on devkit carrier board there are ESD protection components for I2C. You can run RMA for the modules. Jetson FAQ | NVIDIA Developer

Thanks. I will take it in account for the future.
Could you let me know the RMA procedure?

It is in the link just posted.