Can bus not working in NX Dev kit

I have referred following pages, but have not received any command by shorting CAN-H and CAN-L pins.

  1. Link to an existing forum question: How to using CAN In nx devkit

Please suggest a solution or approach to communicating using CANBus communication in NX Dev Kit.

JetPack version: 4.6

hello maharshi.oza,

may I know what’s your steps to enable CAN networks in detail.
had you also test loopback mode for sanity check?
furthermore, there’s developer guide for reference, CAN (Controller Area Network).

Hello JerryChang,

I have followed this " Enabling CAN on Nvidia Jetson Xavier Developer Kit | by Ramin Nabati | Medium " link only to enable CAN in NX Dev kit.

hello maharshi.oza,

wait… may I confirm the Jetson platform you’re using. is it AGX Xavier, or Xavier NX?
please note that there’s only single CAN controller, i.e. mttcan@c310000 for Xavier NX.

Hey JerryChang,

I am using Xavier NX Dev Kit.

I know that the Xavier NX has one CAN controller, so I have changed the value of the following registers only.

0x0c303000 = 0x0000c400
0x0c303008 = 0x0000c458

that’s incorrect address,
please check developer guide for reference, CAN (Controller Area Network).
for example,
Xavier NX,
can0_din / address: 0x0c303020 / Value:0x458
can0_dout / address: 0x0c303018 / Value:0x400

Thank you, it has worked for me.

hello maharshi.oza,

thanks for sharing test results, we’ll mark this as solved and close this discussion thread if there’s no further questions.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.