Can not connect through Omniverse Streaming Client

Hi. I’m trying to connect to my remote Create through Omniverse Streaming Client with LAN, but It does not work.

I got the following error message.

Unable to initiate a connection to the server. Please validate the server address is accurate, and that is reachable from the network

Following the Streaming Clinet Documantation, I copy and paster the following command (kit.bat apps/omni.create.kit --enable omni.kit.livestream.native --no-window) at the directory I installed the Create, and confiremed that The Omniverse Create is running as no-window mode on my remote server.

I think the IP address is correct because I can stream via WebSocket with the same one.
(i.e., http://{my-IP}:8111/streaming/clinet is no problem)

Could you gime me some advices?
Thanks in advance !

Hello @teyon.son! I am asking the dev team for some assistance.

I have a few questions for you:

  • What version of the Streaming Client are you using?

  • Is your Server using the same Operating System as the Client?

  • Also, you say that you are connecting through LAN, but then you mention that you are running no-window mode on your remote server. Is your Server and Client on the same network?

1 Like

Hello again @teyon.son! The dev team had a few more questions for you:

  • What version of Create are you using?
  • Can you confirm if the ports you are using for streaming are cleared by your firewall settings?

Here are some links to the documentation for reference: Using Omniverse Streaming Client — Omniverse Streaming Client documentation

1 Like

Hello @WendyGram

Thank you for your kind response.

  • What version of the Streaming Client are you using?

Server ( Workstation ) : Omniverse Create 2022.1.4
Client: Omniverse Streaming Client 103.1.1

  • Is your Server using the same Operating System as the Client?

yes, both server and client is windows.
more specifically,
Server (Workstation): Microsoft Windows 10 Pro
Client: Microsoft Windows 10 Pro for Workstations

Also, you say that you are connecting through LAN, but then you mention that you are running no-window mode on your remote server. Is your Server and Client on the same network?

Sorry for my ambiguous expression. I should have said just Server instead of a remote server.
Yes, the server and client are on the same network.

  • Can you confirm if the ports you are using for streaming are cleared by your firewall settings?

I understand. I’m going to respond after checking the port.
Thank you.

Had something similar on my AWS instance. Solved it by opening the ports specificed in their documentation:

https://docs.omniverse.nvidia.com/app_streaming-client/app_streaming-client/user-manual.html

and accessing it via server_ip/streaming/client

hope this helps!

1 Like

Hi, @michael.s1.ellis
Thank you for letting me know!

I have some questions.

Did you access that AWS instance through Omniverse Client App?

if yes, Should I desginate “$(server_ip)/streaming/client” for Server window of Omniverse Clinet App ?

In the second screenshot which is in this document ( Using Omniverse Streaming Client — Omniverse Streaming Client documentation), they just disignated not “$(server_ip)/streaming/client” but server IP address (In this sreenshot, 127.0.0.1 ).

If I remember correctly, I need to use “”$(server_ip)/streaming/client" for streaming via websocket/ webrtc.

Yes I am using the Omniverse streaming client v103.1. My custom app is ran on the AWS ubuntu instance (after having the ports opened) with ./run_app.sh --enable omni.kit.livestream.native --no-window

I was originally using the websocket prior, and recently made the change to connect by filling out the top portion of the Omniverse streaming client Server (on a windows machine) field with: server_ip/streaming/client/ which was not very well documented and honestly just a guess.

I certainly hope this helps.

Hi, @michael.s1.ellis .

Thank you for your reply, and I apologize for the late reply.

That’s what I wanted to know. Thank you for your Kind & swift response.

Thanks to your tips, Omniverse Client Streming worked well on my env :)
I tried several things ( e.g., port setting, FW setting, etc…), and It seems like the problem was, activating several extensions which provide a live stream feature.

( I have not investigated yet, but the extension you checked autoreload activate automatically loads to Create even though you launch from cmd)

I disabled these extensions except omni.kit.livestream.native, it worked now.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.