can not find the lib of libnvbufsurface.so.1.0.0 - Xavier

I have installed Jetpack 4.2.1 on xavier and download DeepStream 4.0 SDK from https://developer.nvidia.com/deepstream-download. but i can not run the sample.because of the missing libnvbufsurface.so.1.0.0.

and here is the log

(gst-plugin-scanner:7428): GStreamer-WARNING **: 16:44:56.923: Failed to load plugin '/usr/lib/aarch64-linux-gnu/gstreamer-1.0/deepstream/libnvdsgst_dsexample.so': libnvbufsurface.so.1.0.0: cannot open shared object file: No such file or directory

(gst-plugin-scanner:7428): GStreamer-WARNING **: 16:44:56.926: Failed to load plugin '/usr/lib/aarch64-linux-gnu/gstreamer-1.0/deepstream/libnvdsgst_infer.so': libnvbufsurface.so.1.0.0: cannot open shared object file: No such file or directory

(gst-plugin-scanner:7428): GStreamer-WARNING **: 16:44:56.972: Failed to load plugin '/usr/lib/aarch64-linux-gnu/gstreamer-1.0/deepstream/libnvdsgst_segvisual.so': libnvdsbufferpool.so.1.0.0: cannot open shared object file: No such file or directory

(gst-plugin-scanner:7428): GStreamer-WARNING **: 16:44:56.974: Failed to load plugin '/usr/lib/aarch64-linux-gnu/gstreamer-1.0/deepstream/libnvdsgst_tracker.so': libnvbufsurface.so.1.0.0: cannot open shared object file: No such file or directory

(gst-plugin-scanner:7428): GStreamer-WARNING **: 16:44:56.975: Failed to load plugin '/usr/lib/aarch64-linux-gnu/gstreamer-1.0/deepstream/libnvdsgst_multistream.so': libnvdsbufferpool.so.1.0.0: cannot open shared object file: No such file or directory

(gst-plugin-scanner:7428): GStreamer-WARNING **: 16:44:56.985: Failed to load plugin '/usr/lib/aarch64-linux-gnu/gstreamer-1.0/deepstream/libnvdsgst_dewarper.so': libnvdsbufferpool.so.1.0.0: cannot open shared object file: No such file or directory

(gst-plugin-scanner:7428): GStreamer-WARNING **: 16:44:56.988: Failed to load plugin '/usr/lib/aarch64-linux-gnu/gstreamer-1.0/deepstream/libnvdsgst_ofvisual.so': libnvdsbufferpool.so.1.0.0: cannot open shared object file: No such file or directory

(gst-plugin-scanner:7428): GStreamer-WARNING **: 16:44:56.989: Failed to load plugin '/usr/lib/aarch64-linux-gnu/gstreamer-1.0/deepstream/libnvdsgst_multistreamtiler.so': libnvbufsurface.so.1.0.0: cannot open shared object file: No such file or directory
nvbuf_utils: Could not get EGL display connection
One element could not be created. Exiting.

by the way ,for this:nvbuf_utils: Could not get EGL display connection (can I use ssh to run the sample application?)

It looks your BSP is not correct.
You can download the latest SDK manager 0.9.13 from https://developer.nvidia.com/embedded/downloads and install bsp, os, tensorRT, cudnn, …, from jetpack 4.2.1


But I have used the latest SDK manager 0.9.13.4763

You can check if it’s jetpack 4.2.1

$ cat /etc/nv_tegra_release | head -1

R32 (release), REVISION: 2.0, GCID: 15925399, BOARD: t186ref, EABI: aarch64, DATE: Sat Jul 13 07:31:45 UTC 2019

R32 (release), REVISION: 2.0