Cannot Access Jupyter Notebook in DLI 'Getting started with AI on Jetson Nano' course

Hi

Sorry I asked this question on another thread and realised that the thread had already been closed. But it does not answer my question.

I am unable to get the Jupyter Notebook to open as per the example.

I get to the login page of the Jupyter Notebook. I type in the password and the page just reloads requesting the password with no messages.

If I type in anything other than ‘dlinano’ the page reloads with the message ‘Invalid credentials’ below the password box. So i am sure I am typing in the password correctly. I just cannot move forward.

I have tried restarting. I have tried making a new SD from the image you download on the site. There is no difference.

Please help.
Thank you

Hi genie-run, which web browser are you using to connect? If you are having this login issue using Chrome, you might want to try a different browser like Internet Explorer or Firefox.

For reference, see this Stack Overflow post: https://stackoverflow.com/questions/39759623/jupyter-notebook-server-password-invalid

Hi Dusty

Thanks for the response.

I am currently using Firefox

Hi All

I think I managed to find the problem. It is a browser issue. My settings were set to permanent private browsing mode in Firefox. Once I changed this the notebook worked.

Also changing browsers did help me realise that it was the settings in firefox.

Thank you for the help and for pointing me in the right direction.

Hi,
I have the same problem. When I accessed by password “dlinano”, I had notification “Invalid credentials”. I tried to change browser Firefox, Chorm, Internet Explorer but ““Invalid credentials””
I tried to change permanent private browsing mode in Firefox but “Invalid credentials”
I need any help because this one is very important for my education in University.
Thanks you and I look forward to hearing something from all of you.

Hi,
I tried many browser and USB cable and still can’t access 192.168.55.1:8888.
How to successfully setup the headless device mode is my first homework.

Hi hsinhsinhsin, are you able to ping your Nano at 192.168.55.1 from your PC? I would guess so since you get as far as attempting to login to the Jupyter server. Are you able to SSH into it with username dlinano and password dlinano?

Can you try disabling any firewall that you may have running on your PC? If you have classmates that are doing similar homework, it would be useful to know if their PC can login to your Nano’s Jupyter server - if so, that would indicate some issue specific to your PC’s networking or browser configuration. If they also have trouble logging into your Nano, I would recommend re-flashing your Nano with the DLI image.

I flash dli nano 20gb image and try to log dieectly on Ubuntu ,the password dlinano doesn’t work. What Can i do?

Hi,

I had the same problem, and solved it by changing site specific settings in Chrome, as per this page:
https://support.google.com/chrome/answer/114662?visit_id=637197039062872938-4132302316&p=settings_manage_exceptions&rd=2

I allowed all items for the “nano” site, http://192.168.55.1/

HI !

i have a problem when i launch the Jupyter Notebook in this cours i have a problem with the VLC stream ,i got this Error : VLC is unable to open the MRL ‘rtsp://192.168.55.1:8554/ds-test’. Check the log for details. geting started with deepstream ,how can i find a solution for that .thanks

Try checking ip address of your nano device and make sure you can ping it.