Cannot access JupyterLab server on Jetson Nano

I have combed through a majority of the post but to no avail while going through the initial setup am I able to access JupyterLab server on a freshly imaged Jetson Nano.

Initially, I flashed as instructed through the coarse material and was not able to establish a connection.

Then I found another post which suggested using the image. It did load and I was able to connect to however the password “dlinano” did not grant access.

Both of these scenarios were attempted on both Windows 7 and 10.

This exercise corresponds to running the Jetson Nano in “Headless Mode”. Sure, I can SSH or through a serial port access the Nano but I am trying to stay inline with the coarse material and hopefully any newbes that come along won’t have to endure the countless hours trying to follow the directions.

Hi iNfin8,

If you are to follow the DLI course, you need to use ““.
The “dlinano” password for the JupyterLab is correct.
Can you please check the case?

Unfortunately, the password “dlinano” did not work for me. I keep getting “invalid credentials” when entering it on the “dlinano_v1-0-0_image_20GB” image. After doing some more research I will try the image “nv-jetson-nano-sd-card-image-r32.2.1” rather than the default “nv-jetson-nano-sd-card-image-r32.2.3” image.

The “Write Image to The MicroSD Card” section of the DLI course material (Course > Getting Started with AI on Jetson Nano > Setting up your Jetson Nano > Write Image to the microSD Card) instructs;

> 1. Download the NVIDIA DLI Jetson Nano SD Card Image, and note where it was saved on the computer.

which links to
This DLI image has all the course notebooks, as well as neccesary dependencies and services like JupyterLab pre-installed, and set up with the default username and password.

“nv-jetson-nano-sd-card-image-r32.2.1” and “nv-jetson-nano-sd-card-image-r32.2.3” are base images, something DLI team would use to create their DLI course specific image.
They don’t have JupyterLab installed.

So the only one issue you are facing is that you cannot log into JupyterLab server using “dlinano” password.
DLI course shows a video that shows all the physical setup and logging into the JupyterLab.
Can you check if you are doing the exactly the same?

I am having the same problem. Everything went according to plan until I had to put dlinano at the password prompt
OK so I found out that I was using Firefox and it didn’t work so I switched to Chrome and the password does work. Good luck

I confirm, Chrome work, Firefox didn´t.

On 12/28/19, I too had problems getting to the JupyterLab server. In both the Developers’ Getting Started instructions and the DLI Course materials sections for Instructions For Linux, I found the wrong zipfile specified for DLI course work. The two locations as of this date are:

Once I found this posting, burned rather than, gave up on the Firefox browser and used Chrome, and swapped out 3-4 different USB A to USB micro B cables to get one which was data-capable, I did get a dlinano login that accepted the dlinano password.

Suggestion: include minimal-cost data-capable USB cable and one jumper in the DevKit, as well as fixing the written file names/locations/links, to increase developer acceptance of the kit and get us started more quickly on the interesting stuff.

Confirmed … Chrome worked and Firefox did not.

Thanks for the heads up with the correct image.

Hi frankhoeflich,
I faced the same problem and solved with your message. Thanks.

Sorry I’m an absolute newbee on nanoJet.
I use the latest dli image from the course
I could not get Jupyterlab running with password dlinano on firefox with the USB connection to my desktop computer, but as soon as I tried to connect to nanoJet through an ethernet link, it worked perfectly with firefox on my desktop (win10-2004).
I don’t know why, just I observed this.
I tried to make R and scala kernels running by following instructions at jupiterlab site.
I succeded with R (very straitforward by following instructions) but not with scala up to now…