Cannot flash Drive AGX Orion

Please provide the following info (tick the boxes after creating this topic):
Software Version
DRIVE OS 6.0.5
DRIVE OS 6.0.4 (rev. 1)
DRIVE OS 6.0.4 SDK
other

Target Operating System
Linux
QNX
other

Hardware Platform
DRIVE AGX Orin Developer Kit (940-63710-0010-D00)
DRIVE AGX Orin Developer Kit (940-63710-0010-C00)
DRIVE AGX Orin Developer Kit (not sure its number)
other

SDK Manager Version
1.9.1.10844
other

Host Machine Version
native Ubuntu Linux 20.04 Host installed with SDK Manager
native Ubuntu Linux 20.04 Host installed with DRIVE OS Docker Containers
native Ubuntu Linux 18.04 Host installed with DRIVE OS Docker Containers
other

When SDK manager tries to flash the connected Drive AGX Orin, it fails and the log has error messages about not being able to bind a partition. I’ve tried different cables / ports, etc. to no avail. What can I do to debug this further?

Can you please share the logs located in the directory “~/.nvsdkm” to aid in our investigation? Thank you.

driveinstaller.log (290.9 KB)

I only have the driveinstaller log to hand. Is this sufficient? I can get the rest of the logs on Monday.

"Thank you for providing the driveinstaller log. However, to better understand the issue, could you please also provide the complete logs for our review? This would greatly help us in resolving the issue.

Hi @VickNV,

I have most likely the same issues.
Native 20.04 Linux Host same SDK Manager
I tried it multiple times but it fails at different stages during flash. I used the original USB cables. Also on different Ports. I use a laptop so the USB controller for the USB Type C connection and debug port are most likely the same.

Platform: 940-63710-0010-200
.nvsdkm.tar.xz (1.3 MB)

Please create a new topic for your issue. If you believe it is related to this one, please reference it in your post. Thank you.

Logs attached.
nvsdkm-folder.tgz (547.8 KB)

I noticed the following message in your logs indicating that SDK Manager failed to put the devkit into recovery mode. Have you been able to flash the system or any other system previously?

[2023-02-16 17:31:34,130 root DEBUG utilities.py 294 9461] ^[[01;31mCould not put Tegra-A in recovery^[[0m

To troubleshoot this, please try power cycling both your host and target systems, then attempt flashing again with SDK Manager. If the issue persists, I suggest referring to my forum post and attempting to manually put the system into recovery mode. You should be able to see both USB devices listed below:

Bus 001 Device 013: ID 0955:7023 NVIDIA Corp.
Bus 001 Device 011: ID 0955:7045 NVIDIA Corp.

@hugh.dowling any update on this topic?

Hi

I have the same issue and could not flash Drive Orin as well.
I attached my logs.

my dev-env is as follows:

  • Host OS: Ubuntu 20.04
  • Software Version: DRIVE OS 6.0.5
  • Target Operating System: Linux
  • Hardware Platform: DRIVE AGX Orin Developer Kit (940-63710-0010-300)
  • SDK Manager Version: sdkmanager_1.9.1-10844_amd64

nvsdkm.zip (2.8 MB)

@hyunkoo.kim Please feel free to create a new topic for your issue on the forum. If you think it is related to an existing topic, you can mention it in your post. Thank you.

@hugh.dowling any update on the flashing issue?