Cannot get Riva working in any way

Hi!

I am currently struggling to make Riva work. When I enter sudo bash ./riva_start.sh it gets stuck on “Waiting Riva servers to load all models…” and when I try to use the python examples through Python API: I get the following:

grpc._channel._MultiThreadedRendezvous: <_MultiThreadedRendezvous of RPC that terminated with:
status = StatusCode.UNAVAILABLE
details = “failed to connect to all addresses”
debug_error_string = “{“created”:”@1637761034.224669439",“description”:“Failed to pick subchannel”,“file”:“src/core/ext/filters/client_channel/client_channel.cc”,“file_line”:3094,“referenced_errors”:[{“created”:"@1637761034.224668097",“description”:“failed to connect to all addresses”,“file”:“src/core/lib/transport/error_utils.cc”,“file_line”:163,“grpc_status”:14}]}"

I tried changing the localhost to 0.0.0.0 to no avail. Do you have any suggestions?.

Hardware - GPU (A100/A30/T4/V100) = RTX3070
Hardware - CPU = i7-11800H
Operating System = tried both on Ubuntu 18.04 and 20.04 WSL2
Riva Version = 1.7.0 beta
TLT Version (if relevant)
How to reproduce the issue ? (This is for errors. Please share the command and the detailed log here)