Cannot set MAXN power mode

I have an AGX Orin with a Connect Tech forge carrier board using Jetpack 5.0.2.

When I try and set MAXN on the GUI or by using sudo nvpmodel -m 0 it fails.

For the latter, I got the following error.

Hi,

What is the tegrastats result after you tried nvpmodel -m 0?

Could you attach it?

BlockquoteOrin2:~ ➜ sudo nvpmodel -m 0
[sudo] password for aiserver:
NVPM ERROR: Error opening /sys/devices/system/cpu/cpu8/online: 2
NVPM ERROR: failed to write PARAM CPU_ONLINE: ARG CORE_8: PATH: /sys/devices/system/cpu/cpu8/online VAL: 1
NVPM ERROR: Error opening /sys/devices/system/cpu/cpu8/cpufreq/scaling_available_frequencies: 2
NVPM ERROR: failed to read PARAM CPU_A78_2: ARG FREQ_TABLE: PATH /sys/devices/system/cpu/cpu8/cpufreq/scaling_available_frequencies
NVPM ERROR: failed to set power mode!
NVPM ERROR: optMask is 1, no request for power mode
Orin2:~ ➜ tegrastats
01-16-2023 15:17:30 RAM 5579/30537MB (lfb 4747x4MB) SWAP 0/15269MB (cached 0MB) CPU [7%@2201,5%@2201,4%@2201,6%@2201,9%@2201,10%@2201,8%@2201,11%@2201] EMC_FREQ 0% GR3D_FREQ 0% CV0@-256C CPU@44.031C Tboard@32C SOC2@40.718C Tdiode@33.25C SOC0@41.218C CV1@-256C GPU@39.375C tj@44.031C SOC1@40.156C CV2@-256C
01-16-2023 15:17:31 RAM 5577/30537MB (lfb 4747x4MB) SWAP 0/15269MB (cached 0MB) CPU [11%@2201,4%@2201,7%@2201,6%@2201,9%@1344,11%@1344,7%@1344,8%@1344] EMC_FREQ 0% GR3D_FREQ 0% CV0@-256C CPU@43.937C Tboard@32C SOC2@40.687C Tdiode@33.25C SOC0@41.187C CV1@-256C GPU@39.593C tj@44.312C SOC1@40.093C CV2@-256C
01-16-2023 15:17:32 RAM 5576/30537MB (lfb 4747x4MB) SWAP 0/15269MB (cached 0MB) CPU [4%@1113,4%@1113,5%@1113,5%@1113,6%@2201,8%@2201,8%@2201,12%@2201] EMC_FREQ 0% GR3D_FREQ 0% CV0@-256C CPU@43.906C Tboard@32C SOC2@40.625C Tdiode@33.25C SOC0@41.281C CV1@-256C GPU@39.656C tj@43.906C SOC1@40.093C CV2@-256C
01-16-2023 15:17:33 RAM 5589/30537MB (lfb 4747x4MB) SWAP 0/15269MB (cached 0MB) CPU [9%@729,5%@729,9%@729,6%@729,8%@729,11%@729,11%@729,9%@729] EMC_FREQ 0% GR3D_FREQ 0% CV0@-256C CPU@43.781C Tboard@32C SOC2@40.718C Tdiode@33.25C SOC0@41.187C CV1@-256C GPU@39.625C tj@43.781C SOC1@40.218C CV2@-256C
01-16-2023 15:17:34 RAM 5577/30537MB (lfb 4747x4MB) SWAP 0/15269MB (cached 0MB) CPU [6%@960,3%@960,4%@960,3%@960,10%@1881,7%@1881,9%@1881,6%@1881] EMC_FREQ 0% GR3D_FREQ 0% CV0@-256C CPU@43.906C Tboard@32C SOC2@40.625C Tdiode@33.25C SOC0@41.312C CV1@-256C GPU@39.468C tj@43.906C SOC1@40.125C CV2@-256C
01-16-2023 15:17:35 RAM 5578/30537MB (lfb 4747x4MB) SWAP 0/15269MB (cached 0MB) CPU [9%@1420,10%@1420,10%@1420,6%@1420,11%@1881,13%@1881,7%@1881,9%@1881] EMC_FREQ 0% GR3D_FREQ 0% CV0@-256C CPU@43.937C Tboard@32C SOC2@40.75C Tdiode@33C SOC0@41.218C CV1@-256C GPU@39.718C tj@43.937C SOC1@40.125C CV2@-256C
01-16-2023 15:17:36 RAM 5576/30537MB (lfb 4747x4MB) SWAP 0/15269MB (cached 0MB) CPU [11%@729,6%@729,5%@729,6%@729,6%@729,9%@729,7%@729,6%@729] EMC_FREQ 0% GR3D_FREQ 0% CV0@-256C CPU@43.343C Tboard@32C SOC2@40.656C Tdiode@33.25C SOC0@41.25C CV1@-256C GPU@39.718C tj@43.343C SOC1@40.218C CV2@-256C
01-16-2023 15:17:37 RAM 5577/30537MB (lfb 4747x4MB) SWAP 0/15269MB (cached 0MB) CPU [13%@2201,9%@2201,9%@2201,5%@2201,11%@2201,4%@2201,7%@2201,8%@2201] EMC_FREQ 0% GR3D_FREQ 0% CV0@-256C CPU@44.281C Tboard@32C SOC2@40.687C Tdiode@33C SOC0@41.25C CV1@-256C GPU@39.75C tj@44.281C SOC1@40.093C CV2@-256C
01-16-2023 15:17:38 RAM 5578/30537MB (lfb 4747x4MB) SWAP 0/15269MB (cached 0MB) CPU [8%@729,7%@729,5%@729,3%@729,7%@729,10%@729,10%@729,7%@729] EMC_FREQ 0% GR3D_FREQ 0% CV0@-256C CPU@43.406C Tboard@32C SOC2@40.718C Tdiode@33.25C SOC0@41.312C CV1@-256C GPU@39.718C tj@43.406C SOC1@40.218C CV2@-256C
01-16-2023 15:17:39 RAM 5576/30537MB (lfb 4747x4MB) SWAP 0/15269MB (cached 0MB) CPU [7%@1267,7%@1267,6%@1267,4%@1267,10%@1651,12%@1651,2%@1651,6%@1651] EMC_FREQ 0% GR3D_FREQ 0% CV0@-256C CPU@44.093C Tboard@32C SOC2@40.687C Tdiode@33C SOC0@41.062C CV1@-256C GPU@39.718C tj@43.687C SOC1@40.25C CV2@-256C
^C
Orin2:~ ➜

Hi alex247,

Set to MAXN power mode is working on r35.1+ AGX-Orin.

$ sudo nvpmodel -m 0
[71532.520853] nvgpu: 17000000.ga10b                 tpc_pg_mask_store:1078 [ERR]  golden image size already initialized
NVPM ERROR: Error writing 0 to /sys/devices/gpu.0/tpc_pg_mask: 16
NVPM WARN: Reboot required for changing to this power mode: 0
NVPM WARN: DO YOU WANT TO REBOOT NOW? enter YES/yes to confirm:

→ After confirm yes and reboot system

$ sudo nvpmodel -q
NV Power Mode: MAXN
0

Are you using default r35.1 BSP? or change any files?