Can't detect CX6DX NIC

Hello,

I am having trouble configuring CX6DX (MPN: MCX623106AN-CDAT, Serial Number: MT2211T18421) NIC on my PC.

I typed lspci command and it shows below. As I know, NIC should be detected as Ethernet controller NOT Memory controller

tkhan@tkhan-XPS-8940:~$ lspci | grep Mell
01:00.0 Memory controller: Mellanox Technologies MT2892 Family [ConnectX-6 Dx Flash Recovery]

After doing mst start, mst status shows:

tkhan@tkhan-XPS-8940:~$ sudo mst status
MST modules:

MST PCI module is not loaded
MST PCI configuration module is not loaded

PCI Devices:

01:00.0

Also mlxfwmanager failed to open device even though I checked that there is /dev/mst/mt530_pciconf0.

I also tried several flint commands to burn the firmware on NIC device, and it always gives “MFE_ICMD_NOT_SUPPORTED” error.

sudo dmesg shows below and I wonder if that can be a clue about what’s causing the trouble.

tkhan@tkhan-XPS-8940:~$ sudo dmesg | grep mlx
[ 0.960286] mlx_compat: loading out-of-tree module taints kernel.
[ 0.960302] mlx_compat: module verification failed: signature and/or required key missing - tainting kernel

I tried rebooting and power cycling several times but it doesn’t solve the issue, and I have no idea what is causing this error. Could anybody help me?