Can't find BNO055 on nano I2C

Hi everyone,

I bought an Adafruit BNO055 IMU and i would like to connect it over the I2C interface to my Jetson Nano. Somehow i can not detect it
I also tried the sudo i2cdetect -y 0-8 but i cant fir a 0x28 or 0x29 address.

Wiring
BNO055 vin -> nano 3.3V
BNO055 GND -> nano GND
BNO055 SDA -> nano SDA1
BNO055 SCL -> nano SDL1

I also tried RTIMULib but that did not work either
sudo ./RTIMULibDemo

Same when using the adafruit_bno055 python library, the result is:
ValueError: No I2C device at address: 28

ludvig,

try i2cdetect -y -r 0-8

Dr Scott AZ

Hi, did you measure the voltage level of each pin? Did you probe the waveform of I2C when scan the address?

How do i do that? Can I do that on the nano or do i need extra tools?

hi @sbtagain, that does not provide anything useful either

Use a multi-meter to get the voltage level of each pin, and a oscilloscope to observe the waveform.

thanks everyone, problem is solved, i did not realise the pins have to be soldered on to establish a proper contact. The IMU now works exactly like i set it up before