Can't flash agx xavier

Hello I’m newbie in deeplearning and first using jetson product.
After doing some examples in deeplearning I had no more disk left in my agx xavier. So I moved docker directory into new ssd disk ( I think I didn’t move properly. I moved the whole docker file to my ssd disk) . And then something got mixed up, and I can’t run docker, can’t redownload docker. So I tried to flash agx xavier using sdkmanager in Ubuntu 18.04. But the error has been occured . Please help me ( This is my first project and paying another agx xavier is too expensive)

1st error is when my ssd is in the agx xavier. (invoke _rc:d: could not determine current run level
2st error is when I detached ssd from agx xavier.(ECID read fail put the target board in RCM mode and retry,
[exec command]: /bin/bash -c /tmp/;[error]

Sorry for bad english.

Hi machasong,

Can you please uninstall JetPack 4.5.1 with SDK Mananger first, then reinstall JetPack 4.5.1 target image to the SSD?
Please note that the SSD disk should be ext4 disk format.

Sorry for late reply. I don’t know how to make target image to SSD. For right now, I detached SSD from agx xavier. Should I combine SSD (It’s M.2 nvme ssd) with agx xavier? I will uninstall JetPack 4.5.1 and reinstall.

I think docker is affecting when I try to flash. I have a error picture below when I turn on agx xavier. After waiting 3min, it does turn on normally)

Thanks for reply

Hi machasong,

Sorry I didn’t understand your initial question. Now I understand that you want to flash L4T image to the NVME attached to Jetson device.
Now we don’t support flashing L4T to NVME attached to Jetson device yet. We’ll support this feature in future release.

If my above understanding is still wrong. Can you please rewrite the following steps with the exact commands you run? For example:

  1. command 1.
  2. command 2.

Thanks for reply. What I meant was because I can’t use docker in xavier due to error, I want to factory reset agx xavier. (Not on NVME , in the original internal disk in Xavier)
But when I try to factory reset agx xavier with sdk manager, flash didn’t work at all. I also used but it didn’t work too.

When I type ‘lsusb’ in terminal, I can see the Nvidia being plugged in. But when I connect Xavier with Hdmi cable in Recovery mode, it shows nothing. (just black screen)

I also tried force recovery mode by using terminal. But it didn’t workout.

Is there anything you want me to try?

I am really thankful for replying my question!
(sorry for bad english)

Can you please provide the full command line and its output?

Here’s the command line and the output

hello machasong,

it’s mmcblk0p1, to flash the internal eMMC.
please re-flash the board as following, for example, $ sudo ./ -r jetson-xavier mmcblk0p1

Thank you, I will try right now.

Here’s the output

I have a 64 GB micro SD. Because I can’t solve problem in internal disk, how do you think about booting the xavier by using sd card → format the internal disk using disks app → copy sd card file into internal disk? ( I don’t know if this is possible)

If that’s a good way, could you give me some advise to flash jetpack into sd card, and how to choose boot by sd card?

Or if that’s a nonsense, I will keep follow your instruction.
Thanks for replying

hello machasong,

here’s commands to assign the board information to the pipeline for image flashing.
for example,
$ sudo BOARDID=<boardid> BOARDSKU=<sku> FAB=<fab> BOARDREV=<rev> ./ -r jetson-xavier mmcblk0p1

where actual values are:

                                      BOARDID  BOARDSKU  FAB  BOARDREV
     jetson-agx-xavier-devkit (16GB)  2888     0001      400  H.0
     jetson-agx-xavier-devkit (32GB)  2888     0004      400  K.0

please do have another testing,

Did I type it well? I don’t know why is not working.

hello machasong,

you must execute this under the correct path. for example, ~/nvidia/nvidia_sdk/JetPack_4.5.1_Linux_JETSON_AGX_XAVIER/Linux_for_Tegra/

Here’s the output

hello machasong,

please ensure you’re hold recovery button to put device to enter forced-recovery mode. you may also remove any peripheral devices.

may I know what’s your development environment?
are you using native UbuntuOS, or you’re having virtual machine, or docker container?

When I go in to forced-recovery mode, I push and hold 2nd button in xavier, then pushing 1st button(toggle) to turn on, and then hold off the 2nd button.

I’m using native Ubuntu 18.04 LTS in my labtop (Host pc).

I also checked that usb cable is fine. (It’s a cable from the kit)
Thank you

hello machasong,

it sometime the usb port issue,
please have your laptop connected with power-supply, and please check with other usb-ports for confirmation.

I double checked with my laptop. My laptop is connected with power-supply, and I tried in every other port. (Same result)

Also, I connected my smartphone and usb in laptob. Usb port works well.

Thank you