Error flashing agx xavier with sdkmanager

I am using the sdkmanager cli in the provided docker image (I also built my own ubuntu docker image with the deb package, but with the same result) to flash my agx xavier with jetpack v. 4.5.1:

sdkmanager --cli install --logintype devzone --product Jetson --version 4.5.1 --targetos Linux --host --target JETSON_AGX_XAVIER --flash all --additionalsdk DeepStream

However, the program fails at multiple points:

  • when creating the image, in /tmp/, sudo chroot . dpkg -P dnsmasq is called, where dpkg is an aarch64 executable. I fixed this by patching chroot to call dpkg with qemu-aarch64-static (which is explicitly installed, but never used)
  • in the tegra root file system (Tegra_Linux_Sample-Root-Filesystem_R32.5.1_aarch64.tbz2), there are multiple things missing:
    • a script checks for rootfs/usr/lib/aarch64-linux-gnu/tegra, which is not present; I “solved” that by creating this (empty) directory (to be able to continue in the installation process, but this is probably an issue)
    • rootfs/etc/wpa_supplicant.conf is missing during the flashing step, i “fixed” this by creating an empty file there
    • rootfs/lib/firmware/brcm/fw_bcmdhd.bin is missing during the flashing step, and I didn’t continue there because I fell like I’d brick my board

I also tried this with jetpack 4.4.1, but a different image file is missing there (see the last point in the list above, but it’s called firmware.img or something)

I can’t imagine this being my fault, since I only executed the command I got from sdkmanager --query, and the files in question are simply not there (and I don’t know what I could do differently to make them magically appear), so I’m guessing this might be a problem with an updated version of said tbz2, where files are moved/renamed/… and this is not reflected in the sdkmanager utility; is there any fix I can use to make this work? I haven’t tried using the ubuntu version natively since I’d have to set up an ubuntu instance for that, but I imagine that these problems won’t magically go away there…

Hi Lukor,

Docker did not work, so please find a computer and install Ubuntu 18.04.
Or refer to below link to see if can help:
Fix Jetpack 4.5.1 flashing from docker-based sdkmanager - Jetson & Embedded Systems / Jetson AGX Xavier - NVIDIA Developer Forums

Copying a TB of data somewhere else to have a free disk, installing ubuntu there and using the GUI to flash the board worked; however, it is still not entirely clear for my why the graphical version of the application downloads another base image (since I don’t think the missing files will appear in the CLI one out of thin air)
Also, is there a plan to fix this issue some time in the future? Having a docker image for sdkmanager in which the sdkmanager simply does not work seems pretty useless to me…

Hi Lukor,

Can you please package and upload ~/.nvsdkm folder in the docker image for more investigation?
Can you please let us know the host OS version when running the docker image?

The qemu-user-static package needs be installed on host. This is a known issue and is documented in Docker Images :: NVIDIA SDK Manager Documentation
Once the qemu-user-static package is installed on host, it is required to reinstall JetPack container from scratch to avoid missing files or other conflict.

Hi @EdwardZhou ,

I am running OpenSuSE Leap 15.2 on kernel 5.3.18-lp152.78-default. I have tried installing the user space qemu package qemu-linux-user and qemu-arm (there is no qemu-user-static for opensuse, but I figured that this should provide the same functionality (?), but only got the same results as before.

I have attached the nvsdkm folder you requested, once for the image provided by nvidia (without any modifications by myself) and once for the docker image I created myself:

nvsdkm.nvidia.tgz (247.3 KB)
nvsdkm.own.tgz (684.2 KB)

Thank you for your help.

Hi Lukor,

qemu-linux-user and qemu-arm are different from qemu-user-static package. From the log file in nvsdkm.nvidia.tgz, I could see that the error is caused by missing qemu-user-static on host.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.