[Solved] Flashing Jetson AGX Xavier 32GB from Docker?

I’m just trying to flash this NVIDIA Jetson AGX Xavier Developer Kit (32G) and having no luck. I’m aiming to do this from docker because there’s no reason for anyone to be running an outdated distro when they’re just trying to learn about new hardware.

Attached are my logs and Dockerfile and below is exactly what I did.

Maybe someone can point me in the right direction because I’ve been failing at this for months now and I’m thouroughly unimpressed by this device to the point it’s about to just meet it’s demise in a dumpster if I can’t use it.


Before beginning I made sure my Xavier was ready for flashing by checking lsusb:

# lsusb
...
Bus 001 Device 005: ID 0955:7019 NVIDIA Corp. APX
...

To ensure the binfmt_misc module is loaded, I installed binfmt-support at the host system level.

# apt-get install binfmt-support -y
# modprobe binfmt_misc
# lsmod | grep binfmt

The Dockerfile is attached. From that I ran docker build with sdkmanager_1.3.1-7110_amd64.deb in the same directory.

# docker build -t jetpack-sdk --build-arg USER_ID=$(id -u)  --build-arg GROUP_ID=$(id -g) .

Then I ran this to get into the new environment I built.

# docker run -it --rm --name=jetpack-sdk --rm=true --net=host --ipc host --privileged --volume="/dev/bus/usb:/dev/bus/usb" --user "$(id -u):$(id -g)" jetpack-sdk

I used this command to build my CLI command:

# sdkmanager --cli install --logintype devzone --staylogin true --query interactive

This was the command I ran to try to flash my device (I added the --staylogin true part):

# sdkmanager --cli install  --logintype devzone --staylogin true --product Jetson --host --target P2888-0001 --targetos Linux --version 4.4.1 --flash all --license accept

I click the link in my terminal to launch Firefox and I login. (btw, screw hCaptcha and the way it presents images, I never want to see another picture of a motorcycle again…).
sdkmanager does it’s thing.
It fails every time.
Attached is a fresh log of disappointment.

Dockerfile.txt (1022 Bytes)


nvsdkm.tar.gz (235.2 KB)

I figured this out. My notes are here: https://gist.github.com/protosam/48370bca14eeebca03b7cfe2ea042ef8