Can't get CUDA toolkit working on my Jetson

I got my Jetson the other day, and after hours of fiddling around with it I still can’t use it. I ran the installer.sh file as the README says to do. I then tried to connect to it from a working instance of NSight eclipse on my MacBook Pro but it always fails with “Failed to connect sshd on :22”. I verified that the same MBP can ping the Jetson over my home network.

I then tried to install the CUDA toolkit on my Jetson, following the instructions in the CUDA Getting Started Guide for Linux. However, when I reach section 3.7 (page 12), I run the following command to install the cuda-repo-l4t-r19.2_6.0-42_armhf.deb file which I downloaded from https://developer.nvidia.com/jetson-tk1-support but I get the same “broken pipe” message every time, as seen here:

$ sudo dpkg -i cuda-repo-l4t-r19.2_6.0-42_armhf.deb
(Reading database … 130336 files and directories currently installed.)
Preparing to unpack cuda-repo-l4t-r19.2_6.0-42_armhf.deb …
Unpacking cuda-repo-l4t-r19.2 (6.0-42) …
dpkg: error processing archive cuda-repo-l4t-r19.2_6.0-42_armhf.deb (–install):
trying to overwrite ‘/etc/apt/sources.list.d/cuda.list’, which is also in package cuda-repo-ubuntu1204 6.0-37
dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)
Errors were encountered while processing:
cuda-repo-l4t-r19.2_6.0-42_armhf.deb

I have no idea how to proceed. I am at my wit’s end with this, getting ready to smash my Jetson to little pieces! >:-(

Please help.

Thanks,
Josh

You might try posting your questions on the GPU Computing>Embedded Systems forum.

OK, I reposted it. Here’s a link for anyone having similar issues who wants to see what replies I get.

https://devtalk.nvidia.com/default/topic/749369/embedded-systems/can-t-get-cuda-toolkit-working-on-my-jetson/

Josh