Can't get SDK Manager to launch - SDK GUI Error

I’m new to NVIDIA tools AND Linux so bear with me if this is a silly issue. I have a Windows machine as my host (no option for anything else, unfortunately). I downloaded Ubuntu for Windows (ver. 18.04) and used that terminal to install sdkmanager_1.1.0-6343_amd64.deb. After installing some dependencies, I was able to install successfully. When I try to launch the SDK Manager, I get the following message:
$ [2595:0529/105311.681367:FATAL:setuid_sandbox_host.cc(157)] The SUID sandbox helper binary was found, but is not configured correctly. Rather than run without sandboxing I’m aborting now. You need to make sure that /opt/nvidia/sdkmanager/chrome-sandbox is owned by root and has mode 4755.

I’d appreciate some guidance - thanks!
Hayley

1 Like

I worked around the above error by using ‘sudo sdkmanager’. However, I’m now getting this message:
$ [2773:0529/111628.227935:FATAL:atom_main_delegate.cc(207)] Running as root without --no-sandbox is not supported. See https://crbug.com/638180.
When I try and run ‘sudo sdkmanager --no-sandbox’, I get:
Error: unknown argument ‘–sandbox’

I am having similar issue. If I launch without ‘sudo’ it silently fails. If I use 'sudo" then I get the error:

[9620:0615/162134.190645:FATAL:atom_main_delegate.cc(207)] Running as root without --no-sandbox is not supported. See https://crbug.com/638180.

It appears to be a display issue. I have done queries from the command line and can login and get query results.

I am running sdkmanager_1.1.0-6343 on Ubuntu 18.04.

1 Like

i am facing the same error. did anybody find a solution to it?

Any updates on this issue?

I have the same problem

Hello,
Please download the latest SDK Manager version: https://developer.nvidia.com/nvidia-sdk-manager and check if this issue still occurs.

The problem still occurs after downloaded the lastest SDK Manager based on Ubuntu 18.04.5 LTS

parallels@virtual:~/Downloads$ sudo sdkmanager --ver
1.3.1.7110
parallels@virtual:~/Downloads$ sudo sdkmanager
parallels@virtual:~/Downloads$ [877:1013/120410.489559:FATAL:atom_main_delegate.cc(207)] Running as root without --no-sandbox is not supported. See https://crbug.com/638180.

parallels@virtual:~/Downloads$ sdkmanager
/snapshot/main/node_modules/sql.js/js/sql.js:5
1<process.argv.length?process.argv[1].replace(/\/g,"/"):“unknown-program”);f.arguments=process.argv.slice(2);“undefined”!==typeof module&&(module.exports=f);process.on(“uncaughtException”,function(a){if(!(a instanceof ka))throw a;});f.inspect=function(){return"[Emscripten Module object]"}}else if(fa)f.print||(f.print=print),“undefined”!=typeof printErr&&(f.printErr=printErr),f.read=“undefined”!=typeof read?read:function(){throw"no read() available (jsc?)";},f.readBinary=function(a){if(“function”===
^

Error: EPERM: operation not permitted, unlink ‘/tmp/sdkmanager.sock’
at Object.unlinkSync (fs.js:1129:3)
at Socket. (/snapshot/main/headless.bundle.js)
at Socket.emit (events.js:315:20)
at emitErrorNT (internal/streams/destroy.js:92:8)
at emitErrorAndCloseNT (internal/streams/destroy.js:60:3)
at processTicksAndRejections (internal/process/task_queues.js:84:21) {
errno: -1,
syscall: ‘unlink’,
code: ‘EPERM’,
path: ‘/tmp/sdkmanager.sock’
}
parallels@virtual:~/Downloads$

SDK Manager is not officially supported on Ubuntu for Windows. It is only tested on pure Ubuntu OS.

Please run SDK Manager with “sdkmanager” command, in other words, remove the “sudo” before it.
If it fails to start silently, it may be caused by previous call of “sudo sdkmanager”. In this case, please run “sudo rm -rf ~/.nvsdkm” command then retry.

SDK Manager should not be started with “sudo” before the command.
Please run “sudo rm /tmp/sdkmanager.sock” to fix the EPERM error then run “sdkmanager” command again.

Thanks! This problem is solved.