NVIDIA SDK Manager root access issue


I’m facing two issues with sdkmanager

  1. I’ve installed the package (sdkmanager_1.9.1-10844_amd64.deb) in my Ubuntu 18.04 PC. However, it is not getting launched if I launch it as sudo/root user “Running as root is not supported. Please launch sdkmanager with normal user privilege” error is displayed.
  2. If I open sdkmanager as normal user, then sdkmanager opens and when I try to install Jetson Linux in SDKManager after entry of sudo user password for system verify readiness, following error is being displayed
    “Sorry, **** user is not allowed to execute ‘/usr/bin/dpkg --audit’ as root on machine id(****)”

Note: I’m trying to install on company’s PC(host machine)

Could you please help me on this?

Thank you!

Normally SDK Manager will ask you for your password while running as a regular user. That password would be used with sudo. Can that same regular user run the command “sudo dpkg --audit”?

Incidentally, I assume it is only a typographic error, but the command would be the first of these, and not the second:

  1. Correct:… /usr/bin/dpkg --audit
  2. Incorrect: /usr/bin/dpkg/ --audit
    (note the extra “/” after “dpkg/”)

If the command line “sdkmanager” has ever been run as root (with sudo), then it is possible it changed a file to root ownership, and that this persists despite now running it without sudo. Has it ever been run as root/sudo?

Actually I’m facing two separate issues, I’ve updated the thread description properly now.
Can you please check once again and assist me on this?

First, never run sdkmanager with sudo. It must run as a regular user. It will ask you for the local system password though, and when sudo is needed, sdkmanager will use that. Having run it as root might mean you need to remove the home directory’s NVIDIA content, and run again as a regular user. The binary executable is separate, and you don’t need to worry about reinstalling the .deb. However, you might want to carefully use recursive delete on these folders of the regular user’s home directory:

  • ~/.nvsdkm
  • ~/nvidia
  • ~/Downloads/nvidia/sdkm_downloads

Those directories would be recreated after running sdkmanager as a regular user.

This might also solve the second issue. On that host PC, if this does not solve the issue, does the following succeed (I’m wondering if dpkg itself is up to date):

sudo apt update
sudo apt-get upgrade

(if you’ve never done this, then it will take significant time)

I almost forgot, what do you see from “lsblk -f”? I am wondering if the “~/nvidia” content is on a separate partition, versus the same partition as home.

I’m running sdk manager as regular user only, but because of 2nd dpkg error I tried to run it as sudo user.

And for second error, I tried executing dpkg --audit with & without sudo in a separate terminal and found this

Also, executed “lsblk -f”, output is attached in text file for your reference and yes, “~/nvidia” is in home directory only
lsblk.txt (4.6 KB)

Apparently your user login on the host PC is not an admin login. The sudo command is refusing to all package updates or fixes. Are there multiple user accounts on this host PC whereby yours might not be an admin account? If this is the case, then you won’t be able to flash without becoming an administrator.

If your login is the only one on the host PC, and if the file “/etc/sudoers” has changed, or perhaps something in “/etc/sudoers.d/*” has changed, then it might account for this.

Yes, there are multiple accounts in the system and we don’t have full administrator access.
After logging in as administrator, we are able to install host machine components and target OS image

Thank you very much for your support!

Incidentally, the administrator could give you admin access. The administrator could also add limited sudo command access, e.g., just the needed dpkg commands (but in reality you’d also need to work with loopback devices and unpacking files, so on, and thus a lot of commands would need sudo access to flash software).

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.