Can't install ARM (32-bit) driver on Debian 10 / Raspberry Pi OS

If I try installing the latest ARM display driver (version 390.138) on Raspberry Pi OS 32-bit (similar to Debian 10 ‘Buster’), when I run the .run file I get the following errors in the install log and the ‘building kernel module’ stage fails:

In file included from /tmp/selfgz1694/NVIDIA-Linux-armv7l-gnueabihf-390.138/kernel/nvidia/os-interface.c:15:
/tmp/selfgz1694/NVIDIA-Linux-armv7l-gnueabihf-390.138/kernel/nvidia/os-interface.c: In function 'os_flush_cpu_write_combine_buffer':
/tmp/selfgz1694/NVIDIA-Linux-armv7l-gnueabihf-390.138/kernel/common/inc/nv-linux.h:464:43: error: implicit declaration of function 'outer_sync'; did you mean 'outer_resume'? [-Werror=implicit-function-declaration]
 #define WRITE_COMBINE_FLUSH()    { dsb(); outer_sync(); }
                                           ^~~~~~~~~~
/tmp/selfgz1694/NVIDIA-Linux-armv7l-gnueabihf-390.138/kernel/nvidia/os-interface.c:946:5: note: in expansion of macro 'WRITE_COMBINE_FLUSH'
     WRITE_COMBINE_FLUSH();
     ^~~~~~~~~~~~~~~~~~~
  CC [M]  /tmp/selfgz1694/NVIDIA-Linux-armv7l-gnueabihf-390.138/kernel/nvidia/os-registry.o
  CC [M]  /tmp/selfgz1694/NVIDIA-Linux-armv7l-gnueabihf-390.138/kernel/nvidia/os-usermap.o
cc1: some warnings being treated as errors

Full log: https://pastebin.com/3X8CN4mU

I am tracking my adventure here: https://gist.github.com/geerlingguy/9f1510ab028e68b712381520308db2af

And I also tried a few older versions (390.77 and 390.48), and ran into some other errors.

And finally, I also tried on Raspberry Pi OS 64-bit beta, and the driver successfully compiled and was able to load on the Compute Module 4, but then when the system tried using it, it had errors—that issue seems related to: GTX 1080 drivers fail to load with NVRM: GPU 0004:01:00.0: RmInitAdapter failed! (0x25:0x54:1211)