Can't Install Jetpack 4.2 / Multimedia API to Custom ROOTFS

Hello,

There does not appear to be a way to install all of the components that are included in Jetpack 4.2 to a custom rootfs.

I have tried both versions of the SDK Manager and neither of them detect the nano as others have stated.

It is fairly easy to create a custom rootfs and install the basic components required (Kernel etc) by downloading the L4T Driver package however the apply_binaries.sh script does not install the Multimedia API package.

Unless the SDK Manager starts working or a standalone Jetpack 4.2 package is offered for the nano i’m not sure what to do.

I have tried building the Multimedia API package on the nano however it seems to be missing some files located in /usr/bin.

Does anyone have any suggestions?

the custom rootfs I am using is xfce4 based ubuntu 18.04 and everything else seems to be working as normal.

Thank you!

Hi,
The Multimedia API package is dependent to CUDA, OpenCV, VisionWorks, cuDNN, TensorRt packages, and we use SDK manager to handle dependencies. If you run a custom rootfs, you need to manually include the packages into the rootfs.

Thanks for the reply,

Could you point me in the direction of those packages? where might I download them.

If I were to run the apply_binaries.sh script then install CUDA, OpenCV, VisionWorks, cuDN, TensorRt and build the Multimedia API on the Nano will that accomplish everything that jetpack 4.2 provides?

Minus the Ubuntu 18.04 version that’s included of course.

Because the SDK Manager isnt working with the nano currently it’s quite the headache trying to build a complete rootfs with everything that is included in the jetson nano pre built-sd card image.

Thanks again.

Hi mr.chrismitchells,

The SDKM is working on Jetson-Nano.
You can run ‘sdkmanager’ to flash image and install SDK components.
If you get problem when install SDK components via sdkmanager, please let me know.

There is a script in the JetPack install root called create-nano-sd-card-image.sh or somesuch and it will package a SD card image with rootfs, kernel. Everything appet to work including first boot scripts. It just worked for me:

https://devtalk.nvidia.com/default/topic/1051327/jetson-nano/jetson-nano-jetpack-4-2-firewall-broken-possible-kernel-compilation-issue-missing-iptables-modules/post/5342025/#5342025

Sdk manager is working with nano unless you download an old version which is unfortunately still linked from a few places. Perhaps Nvidia can delete it as you are not the only one who installed it.