Can't install TensorRT 8.6.1.6 from network repo

Description

Installing TensorRT 8.6.1.6 via the network repo no longer works. It used to as of early-mid March.

Steps To Reproduce

I can reproduce this both on my system and several of the official CUDA containers. Here are the simplest repro steps:

docker run --interactive nvcr.io/nvidia/cuda:12.0.1-base-ubuntu20.04
apt-get update
apt-get install tensorrt=8.6.1.6-1+cuda12.0

Output:

Reading package lists...
Building dependency tree...
Reading state information...
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 tensorrt : Depends: libnvinfer-bin (= 8.6.1.6-1+cuda12.0) but 10.0.0.6-1+cuda12.4 is to be installed
            Depends: libnvinfer-dev (= 8.6.1.6-1+cuda12.0) but 10.0.0.6-1+cuda12.4 is to be installed
            Depends: libnvinfer-lean-dev (= 8.6.1.6-1+cuda12.0) but 10.0.0.6-1+cuda12.4 is to be installed
            Depends: libnvinfer-plugin-dev (= 8.6.1.6-1+cuda12.0) but 10.0.0.6-1+cuda12.4 is to be installed
            Depends: libnvinfer-vc-plugin-dev (= 8.6.1.6-1+cuda12.0) but 10.0.0.6-1+cuda12.4 is to be installed
            Depends: libnvinfer-dispatch-dev (= 8.6.1.6-1+cuda12.0) but 10.0.0.6-1+cuda12.4 is to be installed
            Depends: libnvparsers-dev (= 8.6.1.6-1+cuda12.0) but it is not going to be installed
            Depends: libnvonnxparsers-dev (= 8.6.1.6-1+cuda12.0) but 10.0.0.6-1+cuda12.4 is to be installed
            Depends: libnvinfer-samples (= 8.6.1.6-1+cuda12.0) but 10.0.0.6-1+cuda12.4 is to be installed
E: Unable to correct problems, you have held broken packages.