Can't solve OCI runtime create failed

i followed

this

and this

and i still get the error when i try to check with
$ docker run --gpus all nvcr.io/nvidia/k8s/cuda-sample:nbody nbody -gpu -benchmark

i tired

  1. install cuda-toolkit, through $ apt-get install -y cuda-toolkit-11-0
  2. didn’t install cuda-toolkit
  3. stopping windows docker desktop
  4. delete windows docker desktop

it didn’t work at all and gave me same error

i don’t know what else to do more.

[windows version]
windows 10 pro
build 19041.508

[wsl2]
Linux version 4.19.128-microsoft-standard (oe-user@oe-host) (gcc version 8.2.0 (GCC)) #1 SMP Tue Jun 23 12:58:10 UTC 2020
Ubuntu 18.04 lts

[dxdiag]
DxDiag.txt (103.4 KB)

[nvidia-smi]

[error]
docker: Error response from daemon: OCI runtime create failed: container_linux.go:349: starting container process caused “process_linux.go:449: container init caused “process_linux.go:432: running prestart hook 0 caused \“error running hook: exit status 1, stdout: , stderr: nvidia-container-cli: initialization error: driver error: failed to process request\\n\”””: unknown.
ERRO[0037] error waiting for container: context canceled

For CUDA in WSL2 you need a Windows Insider build from the Dev channel. (build >=20145)

thank you. i didn’t check that one. i’ll try to update and see if it works.

++
that worked. thanks for helping

1 Like

I’m on b21390 and Ubuntu 20.04 on WSL 2 and have the same issue.
Any idea how to fix it?

A bit late, but you need to install latest drivers from CUDA on WSL | NVIDIA Developer

1 Like

I have the driver installed

OS version:
image

GPU drivers:
image

WSL backend:
image

The driver update to 470.76 helped, thanks

1 Like