Error when running docker benchmark

Hello,

I am running into an error when trying to run the docker benchmark sample. I have gone through the steps on: CUDA on WSL :: CUDA Toolkit Documentation but to no avail. The error that I am receiving when running the code “docker run --gpus all nvcr.io/nvidia/k8s/cuda-sample:nbody nbody -gpu -benchmark” is “docker: Error response from daemon: OCI runtime create failed: container_linux.go:367: starting container process caused: process_linux.go:495: container init caused: Running hook #0:: error running hook: exit status 1, stdout: , stderr: nvidia-container-cli: requirement error: unsatisfied condition: cuda>=11.2, please update your driver to a newer version, or use an earlier cuda container: unknown.
ERRO[0000] error waiting for container: context canceled”

I am running this on Ubuntu 18.04 with WSL2 and I am signed up for the Windows Insider program with the latest version.

Can someone please explain why I am receiving this error? I

1 Like

I am also getting the same error message: I think the issue is nvidia-container-cli reports a CUDA version <= 11.2.

What’s noteworthy is the default nvcc in my path is from /usr/bin/nvcc, which is version 10.1:

nvcc: NVIDIA (R) Cuda compiler driver
Copyright (c) 2005-2019 NVIDIA Corporation
Built on Sun_Jul_28_19:07:16_PDT_2019
Cuda compilation tools, release 10.1, V10.1.243

I tried apt-get remove nvidia-cuda-toolkit which came installed on my WSL: that didn’t seem to fix the issue.

I have also tried installing cuda-toolkit-11.2. This has nvcc and other bins under /usr/local/cuda-11.2/bin (nvcc --version reports CUDA 11.2). This however does not update the CUDA version reported under nvidia-container-cli info, which shows:

NVRM version:   460.0
CUDA version:   11.0

Device Index:   0
Device Minor:   0
Model:          UNKNOWN
Brand:          UNKNOWN
GPU UUID:       GPU-00000000-0000-0000-0000-000000000000
Bus Location:   0
Architecture:   UNKNOWN
1 Like