Cboot takes long time to show the boot logo on screen

I often found the boot logo can’t be shown on LCD. After some debug, it looks it took long time to show the boot logo on LCD screen.

From the log, after DP is initialized, and display_boot_logo is called, I still need wait for about 6 seconds to see the boot logo showing on screen.

I attached a video, you can see serial boot log and when the boot logo is shown.

attached video.

Sorry for the late response, have you managed to get issue resolved or still need the support? Thanks

My issue is not resolved. still need your support.
I found both DP and HDMI will take long time to show on the screen. Dont know why this happens

Here comes our internal team’s suggeston as your reference:

This appears to be due to the built-in timeouts in CBoot - you can see in the video that it waits 2 seconds (autoboot timeout) for input to enter the CBoot shell, then after reading in extlinux.conf, it waits 3 seconds based on the TIMEOUT 30 entry in extlinux.conf. So if they want to speed this up, i.e. always skip the shell and always boot the first entry in extlinux.conf w/o waiting for input, then they can:

Modify the public CBoot source for T19x to remove CONFIG_ENABLE_SHELL from the rules.mk/l4t.mk config files and rebuild & reflash their new CBoot (copy lk.bin to cboot_t194.bin in their BSPs ‘bootloader’ subdir). That should get rid of the autoboot timeout.

Modify their eMMC extlinux.conf (/boot/extlinux/extlinux.conf) to set the TIMEOUT parameter to 1, or remove it. IIRC, that should skip any delay and process the first menu entry right away.

Together that should shave off 5-6 seconds of boot delay before you see the splash screen (which happens in CBoot right before kernel boot, so one of the last things it does).

1 Like

I did remove CONFIG_ENABLE_SHELL, and also dont wait on TIMEOUT in extlinux.conf. The issue is even I display boot BMP early, it can’t be shown on screen. Looks like DP/eDP display is not ready to show BMP on screen.

Any update for this issue?

I can’t see boot BMP on screen if I reduce boot time with above steps. I need set more TIMEOUT to wait for the boot BMP display on screen.

From the boot log, dp is initialized successfully in 4 seconds, but can’t see logo display at that time. We must wait for more time( more about 5 seconds ) to see the logo display on screen.

Dont know why this happen. I saw other thread said NX DP need so long time to display. What is the reason for this?

Are you using devkit to test or your custom board?

I tested both. Our custom board is almost same with devkit.

So devkit also gives slow one for showing up the logo?

Yes. devkit also shows up slowly.

Please check the cboot code and see which one is causing the delay. This may be expected.

From the cboot log, dp is initalized successfully and display logo in 4 seconds, but we must wait for more time (about 5 secons) to see the logo showing on screen.


Have you tried different kind of monitors?

Yes. We tried on different monitor, also on LCD screen.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.