Clock setting issue on Drive AGX Xavier upon flashing

Please provide the following info (check/uncheck the boxes after creating this topic):
Software Version
DRIVE OS Linux 5.2.6
DRIVE OS Linux 5.2.6 and DriveWorks 4.0
DRIVE OS Linux 5.2.0
DRIVE OS Linux 5.2.0 and DriveWorks 3.5
[*] NVIDIA DRIVE™ Software 10.0 (Linux)
NVIDIA DRIVE™ Software 9.0 (Linux)
other DRIVE OS version

Target Operating System
[*] Linux

Hardware Platform
[*] NVIDIA DRIVE™ AGX Xavier DevKit (E3550)
NVIDIA DRIVE™ AGX Pegasus DevKit (E3550)

SDK Manager Version

Host Machine Version
[*] native Ubuntu 18.04

I flashed drive agx xavier board using drive software 10.0.I was following the set up video

In Xavier A clock is correct but in Xavier B clock changes to default even after trying these methods.

Screenshot from 2023-05-30 11-26-58

Screenshot from 2023-05-30 11-48-26

We tried setting clock through NTP server, Htpdate and Chrony but nothing is working

We tried several methods suggested in

but after few seconds time is setting to some date in 2019.
Can some one help out? This has prevent me from installing things.
Thank you!

Dear @sankal.pattanashetti,
Could you search previous posts in forum on similar topic like Clock setting issue on Drive AGX Xavier upon set up ,
setting correct time on xavier to see if it helps.

Thanks for the help @SivaRamaKrishnaNV .
First I tried methods which are given in this post but got to know that there is no unit related to nv_ptp_master.service in systemd.

nvidia@tegra-ubuntu:~$ systemctl stop nv_ptp_master
==== AUTHENTICATING FOR org.freedesktop.systemd1.manage-units ===
Authentication is required to stop ‘nv_ptp_master.service’.
Authenticating as: , (nvidia)
Failed to stop nv_ptp_master.service: Unit nv_ptp_master.service not loaded.

nvidia@tegra-ubuntu:~$ systemctl list-unit-files | grep nv_ptp_*
nv_ptp_slave.service enabled

Tried this also

nvidia@tegra-ubuntu:~$ sudo bash /usr/local/sbin/ get
could not get time from dongle
Could not get time from RTC dongle
nvidia@tegra-ubuntu:~$ sudo bash /usr/local/sbin/ set
setting time and date to “0a.”
no dongle detected skipping update
Could not set time to RTC dongle

I need to try Aurix board method. How can we connect to aurix console.

Dear @sankal.pattanashetti ,

How can we connect to aurix console

Please check Sudo minicom -D /dev/ttyUSB3

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.