Clock is behind / Hyperion Launcher does not work

Hello,

I am currently trying to do my fist steps with the Nvidia Drive Development Platform Xavier. I am new to the system and ubuntu so i need some help from you.

I currently having two problems:

  1. Cannot access the internet with my xavier plattform

When ubuntu has successfully booted and the chromium browser is opened, it says “my clock is behind”
I should update date and time.
Ubuntu says its the 24 Oct in 2002.
This is set when using the Time&Date Settings Automatically from the internet. When switching to manually and editing the time, it switches shortly to the selected date and then back to the 24 of october. I also tried some npt commands and tried to set the hwclock but that didn’t work.

  1. Besides that when I open the Hyperion Launcher and try to start the Drive AV or something different, the application closes and I just see the normal screen.

Other than that I would like to read some more about the Xavier, I tried to gain some over https://developer.nvidia.com/drive/drive-early-access-developer-program-documentation

but it always says Approval pending. Is there another way to get documentation for the Xavier?

Thank you!

  1. Did you connected E3556(CAN RTC and PPS module) module to CAN 6&4 port on DriveAGX harness cable?

  2. When booting DRIVE AGX Development Platform; you will be greeted with the following UI automatically
    However, this UI will not work unless you have a full DRIVE Hyperion Development Kit. If you do not have a DRIVE Hyperion Development Kit, you may safely ignore and close this UI.

Regarding “Approval pending issue”, we will check and update it.

I suffered the same problem and use following steps with ptpd to workaround…

sudo service ntp stop
sudo timedatectl set-ntp false
sudo date +%Y%m%d -s “20190110”
sudo date +%T -s “15:34:00”

Yes i connected the module to the CAN6 & 4. But it’s still not working.

Can i install the SDK from this site to the Xavier Platform?
https://developer.nvidia.com/nvidia-drive-downloads
Because when i open the installer on the host pc, the selectable platform to install the sdk is just the drive px2 and the px2 chaffeur.

Thank you.

@garywang
thx for your workaround, I will test it

I ran into the same problem. As workaround I had to kill the ptp4l and phc2sys processes (similar to what’s on a previous comment):

sudo killall ptp4l
sudo killall phc2sys
sudo service ntp stop
sudo timedatectl set-ntp false
sudo ntpdate pool.ntp.org

I created NVONLIVE bug #2485258 https://partners.nvidia.com/bug/viewbug/2485258 for sighting.

I’m unable to access that bug report. Any update on this?

Hi,

we are on it.

  • Fabian

Dear nunovxax9,

Please try this workaround. You might have to run these commands as “sudo.”

First, go to https://www.epochconverter.com and convert any arbitrary human readable date/time to epoch time format - this will be a decimal value so be sure to convert it to hex

On Aurix shell

Check current epoch time

date

Set epoch time

date 0x[epoch in hex format]

Confirm the time you set above

date

Enable gPTP

gptpon

On Tegra shell

Read system time

date

Take down br0.200

ifconfig br0.200 down

Create a new VLAN to communicate with Aurix

ip link add link eth0 name eth0.200 type vlan id 200

Set ip addr of eth0.200 (x.x.x.28 if Tegra A, x.x.x.29 if Tegra B)

ifconfig eth0.200 10.42.0.28
ifconfig eth0.200 up

Follow the normal procedure

cd ~/drive-t186ref-linux/samples/nvavb/daemons
timedatectl set-ntp 0
./phc2sys -s /dev/ptp0 -w -S 1.0 -O 0 &
./ptp4l -f ./gPTP_slave.cfg -p /dev/ptp0 -i eth0.200 -m -l 7

Verify system time is synced (might need a separate terminal)

date