Unable to get the display working after updating Pegasus xavier to 5.2.6 linux

Please provide the following info (check/uncheck the boxes after creating this topic):
Software Version
DRIVE OS Linux 5.2.6
DRIVE OS Linux 5.2.6 and DriveWorks 4.0
DRIVE OS Linux 5.2.0
DRIVE OS Linux 5.2.0 and DriveWorks 3.5
NVIDIA DRIVE™ Software 10.0 (Linux)
NVIDIA DRIVE™ Software 9.0 (Linux)
other DRIVE OS version

Target Operating System

Hardware Platform
NVIDIA DRIVE™ AGX Xavier DevKit (E3550)
NVIDIA DRIVE™ AGX Pegasus DevKit (E3550)

SDK Manager Version

Host Machine Version
native Ubuntu 18.04

I am currently using pegasus xavier and moved the unit from QNX to Linux 5.2.6 release and i see that the display is not functional. I made sure to force write wipe persistent partitions. when i try to enable display/gui by installing gdm3 or ubuntu unity desktop I see the following error

vidia@tegra-ubuntu:~$ sudo apt install gdm3
[sudo] password for nvidia:
Reading package lists… Done
Building dependency tree
Reading state information… Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
gdm3 : Depends: libcanberra-gtk3-0 (>= 0.25) but it is not going to be installed
Depends: libgtk-3-0 (>= 3.0.0) but it is not going to be installed
Depends: gnome-session-bin (>= 3.10) but it is not going to be installed
Depends: gnome-settings-daemon (>= 3.24) but it is not going to be installed
Depends: gnome-shell (>= 3.19.92) but it is not going to be installed
Depends: librsvg2-common but it is not going to be installed
Depends: libglib2.0-bin (>= 2.35.0) but it is not going to be installed
Recommends: zenity but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

After wiping and flashing the system, what else commands were issued prior to this one? Does the package installation work fine on Xavier B?

I did sudo apt-get update , before issuing this command.
How can i check if Xavier B is working right ? Can you provide me input on what is the network path between the 2 ?

You can access Xavier B from A with IP address or refer to Accessing the SoC from UART.

Ok vick this package installation fails on Xavier B as well

Does “sudo apt update” work well?

Hi Vick,

nvidia@tegra-ubuntu:~/sampleSSD$ sudo apt-get update
[sudo] password for nvidia:
Hit:1 Index of /ubuntu-ports bionic InRelease
Get:2 Index of /ubuntu-ports bionic-updates InRelease [88.7 kB]
Get:3 Index of /ubuntu-ports bionic-security InRelease [88.7 kB]
Reading package lists… Done
E: Release file for http://ports.ubuntu.com/ubuntu-ports/dists/bionic-updates/InRelease is not valid yet (invalid for another 4h 8min 36s). Updates for this repository will not be applied.
E: Release file for http://ports.ubuntu.com/ubuntu-ports/dists/bionic-security/InRelease is not valid yet (invalid for another 4h 7min 4s). Updates for this repository will not be applied.

I see that it fails too as well

hi Vick any inputs on this ?

Are you accessing via ssh connection? Is the network available on the system? Please clarify why update doesn’t work first.

Yes the access is via ssh connection. If i try to update some other dependent packages i am able to update. Also i am able to send driveworks tar file over network to the board. . So network is not an issue at all

Hi Vick,
The only thing i can think of that i did not enable the secureboot during the configuration time . Will that cause any issue ?

It seems due to time zone issues. Please make sure your system has the correct time first.

Is there any command to set the timezone on xavier ? I dont see the timedatectl doesnt list any other timezone than UTC.

i tried to update the time to set using the ntp and i still see the same issue

I’m not sure what’s the mechanism behind apt/apt-get. But does the “date” command output the correct time for you?

Please try to update after setting the local date and time as below.
$ sudo ntpdate time.google.com
$ sudo apt update

Thanks Vick, I played with the network to get the right UTC time and it solved all the issues. we can mark this close

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.