DRIVE AGX "No board connected"

Please provide the following info (check/uncheck the boxes after clicking “+ Create Topic”):
Software Version
DRIVE OS Linux 5.2.0
DRIVE OS Linux 5.2.0 and DriveWorks 3.5
NVIDIA DRIVE™ Software 10.0 (Linux)
NVIDIA DRIVE™ Software 9.0 (Linux)
other DRIVE OS version

Target Operating System

Hardware Platform
NVIDIA DRIVE™ AGX Xavier DevKit (E3550)
NVIDIA DRIVE™ AGX Pegasus DevKit (E3550)

SDK Manager Version

Host Machine Version
native Ubuntu 18.04

My SDK Manager UI shows that there’s no board connected even though there is a USB cable connecting my host machine and my DRIVE AGX.

Should I uninstall SDK Manager and install it once again ? If so, how can I proceed ?

P.S: I installed SDK Manager before installing the NVIDIA Driver.

Hi @mohammed.el-yaagoubi,

Have you ever installed any DRIVE OS or DRIVE Software release successfully before?
Please follow “System Requirements” document to install Graphics driver on your host system.
If it’s still not working, please reboot your host system and then try again.

I have been able to install DRIVE OS 5.2.0 and flash successfully A + B on the AGX DRIVER.
However after the reboot, the DRIVE AGX screen display doesn’t show anything even if the HDMI cable was connected from the start

Good to hear the installation is successful.
For your display question, please refer to “Finalize DRIVE AGX System Setup” section in “DRIVE Platform Installation Guide with NVIDIA SDK Manager” documentation.

I don’t think I was clear in my previous comment. I have two display screens one for my host machine (Ubuntu 18.04) and the other for Dev System (DRIVE AGX).
At the end of “step 4”, it showed 'INSTALLATION COMPLETED SUCCESSFULLY" on SDK Manager. Then the AGX DRIVE rebooted automatically, however its display screen don’t show anything as if no HDMI cable is connected to it

DRIVE OS doesn’t have ubuntu desktop installed. That’s why you don’t see anything on your monitor.
In the section I pointed out, there is “Enable Display”. It can solve your problem.

I understand but how am I supposed to install Ubuntu Desktop on the target with :

sudo apt-get update
sudo apt-get install gdm3 ubuntu-unity-desktop

when the monitor doesn’t show anything ?

The section also includes “Connect Console to the Target” information. Or you can also follow “Accessing the SoC from UART” document.

If I uninstalled DRIVE OS 5.2 with SDK Manager in the section “Repair/Uninstall”, will the monitor show the home page of the dev system once again ?
Maybe it would be easier to install Ubuntu Desktop first on the target then proceed to install DRIVE OS 5.2 a second time with SDK Manager

DRIVE OS was flashed onto the target so I think it won’t work.
Accessing the target shell via minicom is pretty simple. You can just follow the document.

I was able to access to the target shell via minicom.
I checked if I have to right IP address with ipconfig and if I have internet access with ping, it is all good !
However the command sudo apt-get install gdm3 ubuntu-unity-desktop didn’t work. The error was "E: Unable to fetch some archives, maybe run apt-get update … "

Yes, you need to run “sudo apt-get update” first to re-synchronize the package index files.

I ran “sudo apt-get clean” then “sudo apt-get update” multiple times and when I run “sudo apt-get install gdm3 ubuntu-unity-desktop” it starts installing until 70% and then gives me this error.

Could you create another topic for it? The original connection problem was solved. Let’s not clutter this topic with multi-issue.

Done, thank you for you help