How RTC synchronized with /etc/systemd/scripts/nv_rtc_sync.sh?

Please provide the following info (check/uncheck the boxes after creating this topic):
Software Version
DRIVE OS Linux 5.2.6
DRIVE OS Linux 5.2.6 and DriveWorks 4.0
DRIVE OS Linux 5.2.0
DRIVE OS Linux 5.2.0 and DriveWorks 3.5
NVIDIA DRIVE™ Software 10.0 (Linux)
NVIDIA DRIVE™ Software 9.0 (Linux)
other DRIVE OS version
other

Target Operating System
Linux
QNX
other

Hardware Platform
NVIDIA DRIVE™ AGX Xavier DevKit (E3550)
NVIDIA DRIVE™ AGX Pegasus DevKit (E3550)
other

SDK Manager Version
1.8.0.10363
other

Host Machine Version
native Ubuntu 18.04
other

As the journal log of our AGX system always sets its start date back to 2021-12-10 or also, I’m investigating the time synchronization scheme of AGX. I’m suspect the clock is set after journald started.
As far as the manual (DRIVE OS Linux) shows, it uses /etc/systemd/scripts/nv_rtc_sync.sh, but I cannot find the systemd service which calls that script.

How that script is called ?

Please see if Clock setting issue on Drive AGX Xavier upon set up helps.

1 Like

Thanks,

I already know the issue but I found that I searched nv_ptp_master.service in … XavierB.
(the service is only available on XA)
I try to investigate the behavior of time settings from nv_ptp_master.service and I may additional question.

After disabling nv_ptp_master.service, Xavier B’s clock is not set automatically.
XA’s date is correctly set by (perhaps) nv_rtc_sync.sh.

I tried to set the clock by sudo /etc/systemd/scripts/nv_rtc_sync.sh, it shows
setting time and date to “00.03.07.03.0d.07.16”
but date is set as

$ date
Fri Dec 10 09:47:34 UTC 2021

Also I tried sudo ntpdate time.google.com , it shows the time is synchronized, but date is not set correctly (same date as described above).

I put the nv_ptp_master.service back on XavierA, XavierB’s clock is correctly set.

The points of my question are

  • How can I set the clock (both XA and XB) before systemd-journald starts to avoid journal log start date corruption.
  • The detail of oritinal time synchronization mechanism of Xavier (ptp_master → nv_rtc_sync.sh)

Please refer to Setting system time at startup for your questions. Thanks.

Please run the command to check if the script runs well.

$ systemctl status nv_rtc_sync.service

I don’t see the issue on 5.2.6 as below. As far as I know, 5.2.0 shouldn’t have the issue too. I saw you moved to 5.2.0 in your topic. You can have a check.

nvidia@tegra-ubuntu:~$ journalctl --list-boots
-1 1d0ee9edb28c435bbadcd7f3e2fcc9ad Thu 2021-04-22 18:13:02 UTCThu 2021-04-22 2
0 dbb9368b4af14862b7dd1165374f7aae Thu 2021-04-22 21:38:24 UTCThu 2021-04-22 2