Time and Date Settings Not Saving Changes and Canrtc.sh Not Working - NVIDIA Drive AGX Xavier

Setup info:
Hardware Platform: DRIVE AGX Xavier™ Developer Kit**
**Software Version:DRIVE Software 9
Host Machine Version:Ubuntu 16.04
SDK Manager Version:


I seem to be having issues with the Drive AGX Xavier’s Date and Time Settings since every time I go to “Time & Date” in “System Settings” and change the time and date, the program automatically reverts back to the wrong time. The wrong set time is July 4, 2017; 3:32 PM. The correct time should be November 23, 2020; 3:29 PM.

I tried looking in previous developer forums and messed around with the RTC module but that didn’t help or fix the issue. I made sure all the correct cables were connected to the RTC module, such as CAD 6&4 to the module with the PPS and accessory power plugs also being connected to the RTC module. I also tinkered with the canrtc.sh with the set and get commands in the terminal but neither worked to change the time. I tried switching from Manual to Automatic in my time settings as well already. Nothing seems to work to allow me to set the time. Please help me with this time issue so that I may access such resources like Google. I may also add that I have already tried changing out the CR2032 lithium coin batteries in the RTC module just to see if that helped. Changing the batteries in the module, unfortunately, did not help.

Please provide assistance. Thank you!

Brendan Sting

Dear @stin7931,
Could you update to latest DRIVE SW. Also, check setting correct time on xavier thread to see if helps?

Dear @SivaRamaKrishnaNV,

I cannot update to the latest Drive Software due to the fact that our host PC runs strictly on Ubuntu 16.04. However, it seems I might have fixed the issue by removing outdated packages manually and then doing sudo apt dist-upgrade and then doing a reboot via sudo reboot.

I will try to do some installs since I need pip, cmake, and opencv3 to install ros kinetic full on the Drive AGX Xavier. Also, thanks for the tread suggestion. It helped with analyzing the issue using the CAN real time clock commands.

Brendan Sting