Color artifacts on playback

I have had these artifacts on playback since day 1 with a Jetson Nano, like nov/2019, but never cared about asking until today.

See the attached picture:

It looks like something in the shadows or when pure black, and not always green. Can also be blue or red. I have read various discussions online but most of them are Windows and the fixes don’t seem to apply here. Nvidia driver is 32.2.1 and plugged via HDMI, but the same happens in DisplayPort. Resolution is 3440x1440. Also happens in OpenGL apps such as a screensaver. It has a small fan attached and temps never go higher than 32 C even when running long CUDA sessions.

I have been using the Nano as a regular PC since I bought it but mostly for programming, the issue doesn’t really disturb me because I can use other computers to watch videos, but always wondered if I have a defective unit in hands or if it is a known fixable problem.

Any idea?

Do you run a gstreamer pipeline and observe the issue? We enable hardware decoding in gstreamer and jerson_ multimedia_api. If video file is good, you should not see any issue in the two software stacks.

Thanks for your considerations, Dane.

And sorry for not being specific, the picture above is from youtube, where I watch news while working on something else. But I did try playing a video file on the Nano and these artifacts show, I can’t tell exactly which color is being messed up but it seems to be in the dark areas/edges. But as I mentioned, they also happen in OpenGL apps such as screensavers or the original desktop manager in the factory installation of Ubuntu (which I replaced with LXDE for memory-saving purposes).

Do you want me to test something else for extra diagnosis?

UPDATE: depending on the video file I try to play, Videos will show an error “GStreamer encountered a general supporting library error” and not play it, but SMPlayer plays. I don’t know if it is useful or not, so I am just mentioning.

Please check if you upgrade to latest r32.5.1. You can get the current version by executing $ head -1 /etc/nv_tegra_release on Jetson Nano.

Thanks for your reply, Dane.

The file you mentioned doesn’t exist in my system, but I can tell you it currently uses 32.2.1 according to nvidia-settings and “uname -a” shows “4.9.140-tegra”.
It is the jetson image that was available in late 2019 and so far I have only applied the suggested updates when synaptic pops up. Do you want me to upgrade to a new point version according to Over the air updates?

I have seen the same with Xavier NX running R32.5.1.
In my case, it only happens with Firefox since version 89.
Playing with chromium is fine.

1 Like

@Honey_Patouceul , after reading your comment I have just installed and tested chromium and it is exactly what you say: it plays correctly while in firefox it shows the artifacts. Thanks for sharing your experience.

If there is one browser I don’t trust it is chromium, which is irrelevant for our discussion, but there seems to have something in common with how firefox plays the stream and how OpenGL apps render their stuff. These red, green and blue artifacts, from what I can see, happen around edges or areas of brightness contrast.

Seems I’ve got rid of this (not tested much, though).

For reference, here’s what I did:

  • Checked available versions from apt:
sudo apt-cache showpkg firefox
  • downgraded firefox to version 59.0.2
sudo apt install firefox=59.0.2+build1-0ubuntu1
  • This had some problems for playing some streams

  • Rebooted and launched Ubuntu software-updater

  • It proposed to upgrade both firefox and chromium-browser with some dependancies. Accepted.

Not yet rebooted, but seems fixed so far.

1 Like

@Honey_Patouceul first of all, thanks for taking your time sharing this experience.

I have tried what you described and it played correctly with firefox 59.xx, no artifacts. As soon as the downgrade finished, the system wanted to upgrade it again, so I did a reboot to check if the fix persisted. All worked fine and then I ran software updater, which upgrades firefox back to 89.xx and guess what: the videos play correctly with no artifacts on 89…

I want to thank you for these tips and will mark it solved. Haven’t yet tried the few OpenGL apps that showed the same behavior but if it happens, and is important, I start another thread.

Thanks a lot.