Screen artifacts flickering

I have been developing with my Jetson nano for some time and recently noticed some weird artifacts being displayed on screen on some occasions. The screen, or a least a region of it will flicker for a few second, switching rapidly between a previous frame and the current one. This behavior only lasts a few seconds and starts at random, but I noticed it more often with high CPU/GPU loads. Those artifacts may appear on any part of the screen, not just for a specific application.

I am running the LXDE Desktop with lighdm enabled, and the board is running a Jetpack 4.6.1 system with a 5V 4A power supply. I am using the HDMI port to connect to my display.

The memory does not seem to be the issue as the bug occurred while I was using less than 4Gb of memory, and no swap was being used. I also tried running Chromium by simply running an X server with the xinit command and could reproduce the bug. I also tried to enable jetson-clocks to get better performance and noticed the problem happening less frequently but still happening. Nothing is logged in dmesg when the issue occurs.

You can find attached an example video of the issue, here while running a web browser.

Any suggestions on what may cause this problem or possible solution ?

Would you see this issue if you try to use gdm3?

I’ve been experiencing the same kind of flickering on my jetson nano.
Here is the artifacts on the default gnome installed on the Jetpack 4.6 :

I tried pushing the fan at 100% to keep the Nano around 40-45°C (with jtop). But is didn’t solved the problem.

Any idea where does it come from ? Do you need any further information ?

No idea. Is that a pure image from sdkmanager and devkit? Have you tried jp4.6.2?

I used a plain 4.6.1 jetpack image from NVIDIA website to flash the SDCard. I will try the 4.6.2 image and keep you updated.

The problem comes from “compton”, the desktop compositor of LXDE.

This software is already known to be buggy in some conditions. It appears that using a vertical screen on Jetson Nano under LXDE is bugged (haven’t tried if the vertical screen is truely part of the problem).

pkill compton solves the flickering issue.
In order to not run compton at startup: rm /etc/xdg/autostart/nvlxde-compton.desktop, so that flickering never comes back.

The Gnome issue I showed before, may have been caused on Gnome by full swap & RAM.

1 Like

That solved the issue, Thanks !

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.