Graphic flickering on Xavier after flashing to jetpack 4.5

Hi everyone,
I flashed two AGX Xavier dev kits with the new released Jetpack 4.5. and the Monitor i want to use is rotated counterclockwise by 90°. If i rotate the screen in the software i have some weird graphic flickering in the menu and icon bar.
I guess there is a bug, as it happens on both modules.

Kind regards,
Nils

here is a gif of some glitches is see

Could you confirm

  1. This issue only happens after you rotate screen

  2. This issue does not happen if you use jetpack4.4.1.

  1. yes
  2. in 4.4.1 everything was okay

fresh installation of 4.5. + apt update + apt upgrade

apt update + apt upgrade

Are these two necessary to do?

hmm for the later use yes, but the flickering is there before and after.
I have just mentioned it to eliminate one source of concern.

Let us check this internally.

1 Like

Hello,

Does only desktop get affected or even some other things rendered on monitor?

Could you check if this setup help your case?

Hi,
i have noticed it especially on the desktop and not in other apps, but i am not sure.

There was no “10-monitor.conf” so i created one with the following content:

Section “Device”
Identifier “Device0”
Driver “nvidia”
VendorName “NVIDIA Corporation”
Option “ForceFullCompositionPipeline” “on”
EndSection

It was still the same problem.

Kind regards,
Nils

Hi,

I am not sure if adding 10-monitor.conf will take effect or not. Actually, I want you to add that to xorg.conf and check the log under /var/log/xorg.0.log to see if any keyword “ForceFullCompositionPipeline”.

okay, i added it to /etc/X11/xorg.conf.t194_ref, see below.
In /var/log/Xorg.0.log is one line about it:

[ 10.999] (**) NVIDIA(0): Option “ForceFullCompositionPipeline” “on”

The problem persists.

# Copyright © 2017, NVIDIA CORPORATION. All Rights Reserved.
#
# This is the minimal configuration necessary to use the Tegra driver.
# Please refer to the xorg.conf man page for more configuration
# options provided by the X server, including display-related options
# provided by RandR 1.2 and higher.

# Disable extensions not useful on Tegra.
Section “Module”
Disable “dri”
SubSection “extmod”
Option “omit xfree86-dga”
EndSubSection
EndSection

Section “Device”
Identifier “Tegra0”
Driver “nvidia”
Option “AllowEmptyInitialConfiguration” “true”
Option “ForceFullCompositionPipeline” “on”
EndSection

Not sure it helps, but you may also try adding:

Option "TripleBuffer" "true"

thanks for the idea, but unfortunately it does not work either

[ 11.029] (**) NVIDIA(0): Option “TripleBuffer” “true”
[ 11.029] (**) NVIDIA(0): Option “AllowEmptyInitialConfiguration” “true”
[ 11.029] (**) NVIDIA(0): Option “ForceFullCompositionPipeline” “on”
[ 11.030] (**) NVIDIA(0): Enabling 2D acceleration

now it is getting super weird… because it is super annoying to work with, i have rotated the display back and use it in the original landscape mode.
With the two changes, i have the same problem now in the original format as well.

edit: the flickering is there if : Option “ForceFullCompositionPipeline” “on” is added

Again, not sure, but you may try to install compiz config manager and run it:

sudo apt-get install compizconfig-settings-manager
ccsm

and try in OpenGL to disable Sync to VBlank… or else if that sounds relevant for your case.

Good idea. I have disabled everything… still there… i have enabled everything… still there…

Yesterday I started to work with nomachine remote on the Xavier and notice that the flickering is not transmitted via nx. So it is not present in the remote desktop, but at the same time visible on the connected monitor.

any news or updates?

We have located which patch is causing this issue. Will try to fix this.

1 Like