Jetson Nano with MIPI LCD LS055R1SX04

Hello there…

I bought few LCD panels LS055R1SX04 with boards from aliexpress (5.5 inch 2k LCD with 50pins MIPI connector HDMI driver board 1440*2560 landscape with cover lens for VR 3D printer LS055R1SX04|Tablet LCDs & Panels| - AliExpress) with a thought HDMI - HDMI connection that nothing could go wrong. But yes… it seams it can go wrong :)

I’m trying to solve an issue of display but I just couldn’t get it to work. It tried to play with these LCD panels on Raspberry pi with /boot/config.txt and everything works. But when I connect them to Jetson Nano the real fun begins…

I found out on this forum I need to rebuild kernel to use resolution 1440x2560 (1440x2560 HDMI display not working). I’ve rebuild the kernel with these scripts (GitHub - jetsonhacks/buildJetsonTX1Kernel: Build the 64-bit Jetson TX1 Kernel) - I changed links to point to 32.6.1 version.

When I boot with new kernel display shows picture as it should but it flickers so much you can’t watch the display. The strangest thing about it is that if I reconnect this screen to Raspberry Pi it also flickers and it looks like Jetson did something to the screen - I know it sounds strange but it looks like it was somehow reprogrammed through HDMI port.

Did anyone else had problems with flickering display?

Best, Jernej

Maybe you should firstly follow the correct method to build kernel.
https://docs.nvidia.com/jetson/l4t/index.html#page/Tegra%20Linux%20Driver%20Package%20Development%20Guide/kernel_custom.html#wwpID0E0WD0HA

Hello @WayneWWW, thanks for replay and pointers. While waiting for answer I was searching through forum and found this post (VR display for jetson nano - #5 by Lissanro). The result is the same on both procedures - with your help and solution on this post.

Boot up Nano with disconnected MIPI board, after system is booted I connect LCD panel and everything is perfect. If I disconnect LCD panel reboot system connect it again, LCD starts to flicker. It doesn’t matter to which system I connect it after this, it will flicker (Raspberry Pi, Windows laptop). If I disconnect LCD panel, wait for 3h screen won’t flicker but if I repeat procedure it starts to flicker again. I tried this on three different MIPI boards and LCD panels and result is the same.

I can’t get it to flicker no matter how and where I connect it just that Jetson Nano isn’t included.

Hi,

What is the exact interface that is connected on jetson side?

Do you mean MIPI controller?

No, I mean on jetons nano.

What port on jetson nano is connected to your panel? You attached a photo but I am not sure what is the exact interface got used here.

Oh sorry, HDMI port.

Ok, so you are using a MIPI → HDMI converter here and directly connect on the jetson nano’s HDMI port.

If you can see the desktop on your panel without the patch, then I don’t think that patch you used from that post would help.

That patch only takes effect for cases that you totally not able to see the correct mode. Our driver filters this mode out because the hardware may not support it well.

For the flicker issue, you can dump the dmesg and check the pclk. See if this pclk is what you expect. But as I said, it may not support well for such mode.

I am not sure what kind of modes are supported on your panel.

If possible, switch to most common CEA modes and see if the flicker is still. Jetson should support CEA modes well.

Attaching dmesg and xrandr output.

How can I switch to CEA mode (did a little quick search, but didn’t find any solution)?

xrandr.txt (246 Bytes)
dmesg.txt (59.1 KB)

If your panel does not provide EDID to the driver, then it has no modes to switch.

Thanks for all help :) I will go and buy another ones to see if I can get them to work…

My personal suggestion is please directly try native HDMI interface. Do not go through such MIPI controller if possible.

Based on past experience, such converter always gives out some uncertain factors to the debug…

I can’t find anything like it? We need 5.5inch with 2560x1440 LCD panel - I know this isn’t the place to ask, but do you have any suggestions (link) what to buy?

Hello @WayneWWW,

do this information in any way somehow help setting display up on Jetson Nano?

config.txt - working config from RPI config.txt (2.4 KB)
parsededid.txt - parsed edid from command tvservice (RPI) parsededid.txt (4.3 KB)

And a screenshot of Custom Resolution Utility from Windows 10:
w1yTxRS

Thanks for all your help!

Do you mean you can configure the edid on the panel with this tool?

If possible, can you use a common 1920x1080@60 mode? or 1280x720p.

No, this is just HDMI connected to PC - USB port is connected to USB charger directly. You can change resolution but it doesn’t look good any more… just more “advanced” tool to set resolution on windows PC…

Ok, then it does not help.