Jetson nano flashes the screen for some time then goes blank

I just brought my jetson nano 4GB BO1 version . Flashed the image onto a 32GB San disk SD card as per the instructions. The jetson nano, however, does not show the first boot screen. And when it does show , it flashes the command lines and then goes completely blank. I also tried to flash the OS image around 15 times now

I have used a 5V-2A micro USB power supply and a VeiwSonic 21.5" LED monitor. Also tried on the TV, but it was no good. On the TV it showed the Nvidia logo and went goodbye.Even a power supply of 5V-3.4A an 5V-2.7A doesn’t work. I am using an HDMI cable for this and tried with a couple of them.

Is it the screen display , or is it because of insuffecient power supply .

Thank You

Just some preliminaries…

  • Are all monitors attempted (even if it is a TV) using true HDMI cabling without adapters?
  • 5V-2A sounds a bit low unless in low power mode, but this would cause immediate shutdown if insufficient, and would not cause video to flash as it does.
  • Each SD card model has both some QSPI memory internal to the module during boot, and uses the SD card for the rest of that content. The content of the QSPI must be the correct content release versus the SD card release. There are many releases of SD card which will work without changing the QSPI, but at times you must use SDK Manager to flash the module itself. There is a strong chance that you need to flash the module via SDK Manager. Have you ever flashed the module? Which software release version do you use?

Thank you for your response.
Actually, I have used an HDMI to VGA convertor for the monitor. However , for the TV, I have used the HDMI cable directly.

And, yes , even I had thought about low power, hence, I ordered a 5V-4A DC power output for the same. Expecting it by this saturday.

The SD card actually works for the 2GB version of jetson nano ( with the OS for 2GB ) . I used balena etcher for flashing the image as per the instructions given on the “getting started” guide.

I have a new TV coming up this friday, so I will also try with that screen .

Thank You for your response.

FYI, VGA cables are not supported. Long ago one would use a “driver disk” for any VGA monitor as a method of telling the GPU what specifications the monitor supports. There was no ability in those monitors to allow a GPU to query the monitor for its specifications. There were certain modes which were “standard” and you would have been able to get one of those modes without the driver disk, but mostly the world (and definitely NVIDIA embedded systems) now require a more modern method whereby the GPU can query the monitor and get a response from the monitor as to specifications. This is done with the ddc wire, which uses i2c protocol to ask the monitor what its capabilities are (this is the EDID data).

NVIDIA embedded GPUs only accept specifications via this EDID content. Not all monitor capabilities are supported, e.g., no interlaced monitor is supported. It is possible that the TV did not support a non-interlaced specification. Any DVI-D supports the EDID, and you could use a proper adapter for that to HDMI and it would work. Anything DisplayPort also supports EDID, so an adapter from this to HDMI would work. You should avoid anything using VGA (some later models of VGA did have an equivalent to the DDC wire added, but so far as I know they all use an earlier protocol and don’t necessarily have a usable EDID…those monitors would also have a DVI-D connector, so there wouldn’t be any reason to use a purely VGA monitor).

Some HDMI televisions will work, but I’ve seen reports of televisions being less reliable as to whether or not they work relative to a true HDMI computer monitor.

When using the pre-built SD card images it is important to understand that the SD card models also have QSPI memory built in to the module. This memory is used during boot. Several earlier releases used the same QSPI content, and so within that set of releases the QSPI did not need to change for using different SD card images. There was then some change, and the newer releases of the SD card images work with that newer release of QSPI content, but mixing older and newer does not work. The only way to change the QSPI memory is to flash the actual Jetson, and so I am wondering if you are mixing a Nano with older QSPI and newer SD card image.

The 2GB and 4GB would of course have different QSPI content as well.

There is a chance that what you’ve created with Balena Etcher is just in need of the Nano itself getting the QSPI flashed to a matching release. I couldn’t say for sure, but it would always be advised that the first time you change a release on the SD card that you also flash the Nano itself from an Ubuntu PC. One hint that this might be the case is if an older SD card still works.

Thank you for your response.

Will surely try it with a newer display using direct HDMI cable. The SD card is an older one brought 6 months ago . However, I will try to flash it using the SDK . I did think of using the SDK , but I have a windows computer .

If the new display doesn’t work, I will try using a new SD card. And if that also doesn’t work , I will use the SDK .

The TV screen is also and old one so that might be the major problem. But, I have a new screen coming up, so I will try with that.

Thank You for your responses.

Thank you for all your support.

The jetson nano works perfectly now. Turns out, The display was not proper. The VGA convertor was a bad idea. It works with the new display.

Thank You for your support